Du kan inte installera Unified Communications hanterade API Redistributable och ett oklart felmeddelande


Symptom


Du har en dator med Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package versionen 9.0.30729 installerat. Installationen misslyckas om du försöker installera Microsoft Unified Communications hanterade API Redistributable (UCMARedist.msi). Dessutom visas följande felmeddelande:
Microsoft Unified Communications hanterade API 2.0 Core Redist-installationen eller avinstallationen kräver att VC ++ 2008 Redistributable redan är installerat.
Det här felmeddelandet är inte klart eftersom det inte visar att det krävs en viss version av Visual C++ 2008 Redistributable package.

Lösning


Lös problemet för att installera den Microsoft Unified Communications hanterade API Redistributable inte hämta och installera Microsoft Visual C++ 2008 Redistributable Package version 9.0.21022 från följande Microsoft-webbplats:

Status


Microsoft har bekräftat att detta är ett problem i Microsoft-produkterna som nämns i avsnittet "Gäller".

Mer Information


Mer information om de Microsoft Unified Communications hanterade API Redistributable (UCMARedist.msi) finns i följande artikel i Microsoft Knowledge Base:
976657 beskrivning av kumulativ uppdatering för Office Communications Server 2007 R2, Unified Communications hanteras API 2.0 Redist 64-bitars: April 2010