Viktigt!
Supporten för Microsoft InfoPath 2013 upphörde den 14 juli 2026. Vi rekommenderar att du migrerar befintliga InfoPath-formulär och -arbetsflöden till Microsoft 365-lösningar som stöds. Läs mer om att InfoPath ska tas ur bruk.
Med Microsoft Office InfoPath kan du skapa formulärmallar för datainmatning och datainsamling. Med Microsoft Office Excel 2007 kan du beräkna, skapa diagram över och analysera data. Genom att använda båda dessa program och XML kan du enkelt skapa en enkel men effektiv affärslösning utan kod för att spåra tillgångar i ett företag.
Artikelinnehåll
- Introduktion till att skapa en lösning för tillgångsspårning
- Steg 1: Anpassa formulärmallen för tillgångsspårning
- Steg 2: Mappa schemafilen och anpassa tabellayouten i Excel
- Steg 3: Skapa en sammanfattningsrapport med pivottabeller och pivotdiagram
- Steg 4: Samla in tillgångsinformation från användare
- Steg 5: Importera formulär till Excel
- Några sista reflektioner: Överväga att använda en SharePoint-lista eller Access-databas
Introduktion till att skapa en lösning för tillgångsspårning
Du kan utbyta XML-data mellan InfoPath och Excel. Kommandot Infopath-export är ett enkelt sätt att skicka formulärdata till Excel, men det finns en annan metod som ger mycket större flexibilitet. Genom att uttryckligen mappa XML-schemafilen (.xsd) i InfoPath i Excel och sedan importera InfoPath-formulärfiler (.xml) till Excel kan du anpassa informationens layout och bättre utnyttja funktionerna i Excel så att du kan hantera och analysera dina data mer effektivt.
I den här artikeln använder vi exempelformulärmallen för tillgångsspårning i InfoPath för att illustrera hur du kan få InfoPath, XML och Excel att fungera tillsammans. Anta att din organisation varje år inventerar tillgångar på varje anställds kontor. En Excel-rapport körs sedan för att bestämma hur budgeten för utrustning ska fördelas för nästa år. Följande diagram är en översikt över hur du kan samla in, spåra och rapportera tillgångsinformation på din avdelning.
1. veckor Formulärmallen för tillgångsspårning skapas.
2. veckor Schemafilen mappas till en Excel-tabell och tabellens layout anpassas.
3. veckor En tom sammanfattningsrapport för pivottabeller och pivotdiagram skapas.
4. veckor Formuläret för tillgångsspårning används för att samla in data från användare.
5. veckor Alla formulärdata exporteras till Excel-tabellen och pivottabell- och pivotdiagramrapporterna uppdateras.
Den här lösningen omfattar följande användarroller och produkter:
= Obligatorisk
= Inte obligatorisk
| Programvarukrav | |||
|---|---|---|---|
| Roller | Office InfoPath 2007 | Office Outlook 2007 | Office Excel 2007 |
| Solution Designer |
|
|
|
| Beslutsfattare |
|
|
|
| Employees |
|
|
|
Steg 1: Anpassa formulärmallen för tillgångsspårning
Med formulärmallen för tillgångsspårning, som ingår i InfoPath, kan du samla in information om alla tillgångar på en anställds kontor, avdelningen som den anställda tillhör, tillgångskategorier samt information om varje tillgång. I den här lösningen skickar en formulärdesigner formulärmallen till beslutsfattarens e-postkonto med hjälp av Office Outlook 2007.
Uppgift 1: Öppna och anpassa formulärmallen för tillgångsspårning
Eftersom du inte kan publicera en formulärmall till en lista med e-postmottagare om den har en RTF-kontroll som innehåller länkade bilder måste du göra en liten ändring i exempelmallformuläret för tillgångsspårning.
- Klicka på Designa en formulärmall på Arkiv-menyn.
- Klicka på Anpassa ett exempel under Öppna en formulärmall i dialogrutan Designa enformulärmall.
- Klicka på Exempel - Tillgångsspårning i dialogrutan Komma igång och klicka sedan på Designa det här formuläret under Formuläruppgifter.
- Högerklicka på assetNotes-kontrollen, peka på RTF-egenskaper och klicka på fliken Visa. Avmarkera sedan kryssrutan Länkade bilder under Tillgänglig formatering.
Uppgift 2: Definiera alternativ för att skicka
Nästa uppgift är att definiera alternativen så att anställda kan skicka en formulärfil med ett unikt namn (.xml) till beslutsfattarens e-postkonto som en bifogad fil.
Klicka på Sändningsalternativ på Verktyg-menyn.
Markera kryssrutan Tillåt användare att skicka formuläret i dialogrutan Sändningsalternativ.
Klicka på Skicka formulärdata till en plats och klicka sedan på E-post i listan.
Klicka på Lägg till.
Guiden Dataanslutning visas.I rutan Till anger du alias för den beslutsfattare som ska ta emot alla inskickade formulär.
Om du vill ange ett unikt ämne i rutan Ämne :
- Klicka på Infoga formel
. - Skriv följande formel:
- Klicka på Infoga formel
concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)
- Klicka på Kontrollera formel och klicka sedan på OK två gånger.
I rutan Introduktion skriver du ett meddelande eller lägger till viktiga instruktioner för lösningen.
Klicka på Nästa.
På nästa sida i guiden klickar du på Skicka formulärdata som en bifogad fil och markerar sedan kryssrutan Bifoga formulärmallen för att säkerställa att användarna kan öppna formuläret .
På så sätt kan du vara säker på att anställda har åtkomst till formulärmallen (.xsn) om de inte kan komma åt den från dess nätverksplats.Så här anger du ett unikt filnamn för varje formulärfil (.xml) i rutan Bifogad fil :
- Klicka på Infoga formel
. - Skriv samma formel som i ämnesraden :
- Klicka på Infoga formel
concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)
- Klicka på Kontrollera formel och klicka sedan på OK två gånger.
- Klicka på Nästa.
- I rutan Ange ett namn på dataanslutningen på nästa sida i guiden skriver du ett beskrivande namn för den här dataöverföringsanslutningen.
- Kontrollera att informationen är korrekt i avsnittet Sammanfattning och klicka sedan på Slutför.
- Spara formuläret i en gemensam nätverksmapp som är tillgänglig för beslutsfattaren och för alla anställda.
Steg 2: Mappa schemafilen och anpassa tabellayouten i Excel
När du konfigurerar anslutningen mellan InfoPath och Excel utför du tre uppgifter: du extraherar schemafilen för formulärmallen för tillgångsspårning, du mappar schemafilen i Excel och du anpassar standardlayouten i Excel-tabellen som ska innehålla alla importerade XML-formulärdatafiler.
Uppgift 1: Extrahera schemafilen från InfoPath
- Öppna formulärmallen för tillgångsspårning i InfoPath.
- Klicka på Designa det här formuläret på Verktyg-menyn.
- Klicka på Spara som källa på Arkiv-menyn Files.
- I dialogrutan Bläddra efter mapp väljer du en mapp eller skapar en ny mapp där du vill lagra schemafilen.
Notera platsen för mappen där alla källfilerna sparas och namnet på schemafilen, i det här fallet myschema.xsd, som innehåller schemadefinitionen av formulärets XML-data.
Uppgift 2: Mappa InfoPath-schemafilen i Excel
Skapa en ny Excel-fil och spara den på en plats som beslutsfattaren har åtkomst till.
Om fliken Utvecklare inte visas i Excel gör du så här:
Klicka på Microsoft Office-knappen
och klicka sedan på Excel-alternativ.Markera kryssrutan Visa fliken Utvecklare i menyfliksområdet under De vanligaste alternativen i kategorinPopulära och klicka sedan på OK.
Obs
Menyfliksområdet är en del av användargränssnittet Microsoft Office Fluent.
Klicka på Källa i gruppen XML på fliken Utvecklare.
Åtgärdsfönstret XML-källa visas.Klicka på XML-mappningar och sedan på Lägg till i dialogrutan XML-mappningar.
På en dator med Windows Vista
- I adressfältet klickar du på enheten eller mappen som innehåller filen myschema.xsd som du skapade i steg 2 i avsnittet Uppgift 1: Extrahera schemafilen från InfoPath.
På en dator med Microsoft Windows XP - I listan Leta i klickar du på enheten eller mappen som innehåller filen myschema.xsd som du skapade i steg 2 i avsnittet Uppgift 1: Extrahera schemafilen från InfoPath.
- I adressfältet klickar du på enheten eller mappen som innehåller filen myschema.xsd som du skapade i steg 2 i avsnittet Uppgift 1: Extrahera schemafilen från InfoPath.
Klicka på filen och sedan på Öppna.
När dialogrutan Flera rötter visas klickar du på rotnoden assetTracking som definieras i filen myschema.xsd och klickar sedan på OK.
XML-mappningen visas i åtgärdsfönstret XML-källa .Dra nodelementet ns1:asset , som är ett upprepande XML-element, till den plats i kalkylbladet där du vill att Excel-tabellen ska visas.
Uppgift 3: Anpassa Excel-tabellens layout
Som standard använder Excel XML-elementens namn som kolumnrubriker för tabellen. Du kan dock ändra rubrikerna genom att redigera cellerna för kolumnrubrikerna.
- Om du vill ändra standardkolumnrubrikerna markerar du Excel-tabellen och letar upp och tar bort strängprefixet ns1:asset. Du kan till exempel ändra ns1:assetID till ID.
- Om du vill justera kolumnbredden klickar du på Markera alla och dubbelklickar sedan på kanten till en kolumnrubrik.
Steg 3: Skapa en sammanfattningsrapport med pivottabeller och pivotdiagram
Beslutsfattare använder pivottabell- och pivotdiagramrapporter för att analysera, utforska och visualisera sammanfattningsdata. Genom att i förväg skapa pivottabell- och pivotdiagramrapporter som du vill använda i det här scenariot blir det enkelt för beslutsfattaren att köra rapporten med ifyllda data senare.
- Markera en cell i Excel-tabellen.
- Klicka på Pivottabell i gruppen Tabeller på fliken Infoga och klicka sedan på Pivottabell.
Dialogrutan Skapa pivottabell öppnas i Excel. - Om du vill infoga pivottabellrapporten i ett nytt kalkylblad med början i cell A1 klickar du på Nytt kalkylblad och sedan på OK.
Excel lägger till en tom pivottabellrapport på den angivna platsen och visar Fältlista för pivottabell så att du kan lägga till fält, skapa en layout och anpassa pivottabellrapporten. - Skapa en korstabellrapport av dina data genom att dra ID-fältet till området Värden, fältet Avdelning till området Kolumnetiketter, fältet Kategori till området Radetiketter och fältet Tilldelat till området Rapportfilter.
- Klicka på pivottabellrapporten.
- Klicka på typen Stapeldiagram i gruppen Diagrampå fliken Infoga.
- Välj Grupperad liggande stapel under 2D-liggande.
- Justera pivotdiagramrapportens storlek och placering efter önskemål.
Steg 4: Samla in tillgångsinformation från användare
Nu när formulärmallen är redo att fyllas i av alla anställda måste du publicera formuläret och skicka det till varje anställd. När en anställd skickar in det ifyllda formuläret skickas det till beslutsfattarens e-postkonto som en bifogad XML-datafil (.xml) i ett e-postmeddelande. Beslutsfattaren kan sedan flytta alla meddelanden till en dedikerad InfoPath-mapp i Outlook. I det här scenariot bör du sätta en tidsgräns då alla användare ska ha fyllt i formulären så att beslutsfattaren kan köra rapporten med alla ifyllda formulär när tidsgränsen för datainsamlingen har nåtts.
- Öppna formulärmallen (.xsn) som du sparade i steg 1 i InfoPath : Designa exempelformulärmallen för tillgångsspårning
- Klicka på Designa det här formuläret på Verktyg-menyn.
- Klicka på Publicera på Arkiv-menyn.
- Klicka på Till en lista med e-postmottagare i Publiceringsguiden och klicka sedan på Nästa.
- Skriv ett namn för formulärmallen i rutan Formulärmallsnamn på nästa sida i guiden och klicka sedan på Nästa. Formulärmallsnamnet visas på ärenderaden i det e-postmeddelande som skickas till mottagarna.
- På nästa sida i guiden kan du välja att skapa kolumner som ska visas i dina Outlook-mappar så att det blir lättare att ordna e-postmeddelandena.
- Klicka på Nästa.
- Klicka på Publicera.
- När publiceringsguiden har publicerat formulärmallen öppnas ett e-postmeddelande med formuläret.
- Fyll i meddelandet, skriv den anställdas namn eller använd en distributionslista och skicka meddelandet.
I Outlook kan beslutsfattaren ordna alla inskickade XML-formulär på något av två sätt:
- Om meddelanderutan InfoPath-formulärmappar visas första gången meddelandet öppnas klickar du på Skapa formulärmapp.
- Skapa en regel i Outlook för att flytta alla relaterade InfoPath-formulär till en InfoPath-mapp.
Mer information finns i Hantera meddelanden med hjälp av regler.
Steg 5: Importera formulär till Excel
Eftersom du redan har skapat Excel-arbetsboken – i steg 2 och 3 – är det enkelt för beslutsfattaren att exportera och gå igenom alla formulärdata. Beslutsfattaren behöver bara exportera XML-filerna (.xml) från Outlook, importera alla formulärfiler (.xml) till Excel-arbetsboken och uppdatera data.
Uppgift 1: Exportera formulären från Outlook till en Windows-mapp
- Välj mappen som innehåller alla formulär som du fått från de anställda i Outlook och markera alla formulärrelaterade e-postmeddelanden genom att trycka på CTRL+A.
- Högerklicka på markeringen, peka på InfoPath-åtgärder och klicka sedan på Exportera formulär.
- Välj en mapp i dialogrutan Exportera formulär och tryck på OK.
Uppgift 2: Importera formulären till Excel
I Excel-arbetsboken som du skapade i Steg 2: Mappa schemafilen och anpassa tabellayouten i Excel väljer du en av de mappade cellerna i Excel-tabellen.
Klicka på Importera i gruppen XML på fliken Utvecklare.
Dialogrutan Importera XML öppnas.På en dator med Windows Vista
- Klicka i adressfältet på mappen som innehåller XML-datafilerna (.xml) som skapades i Uppgift 1: Exportera formulären från Outlook till en Windows-mapp.
På en dator med Microsoft Windows XP - I listan Leta i klickar du på mappen som innehåller XML-datafilerna (.xml) som skapades i Uppgift 1: Exportera formulären från Outlook till en Windows-mapp.
- Klicka i adressfältet på mappen som innehåller XML-datafilerna (.xml) som skapades i Uppgift 1: Exportera formulären från Outlook till en Windows-mapp.
Gör något av följande:
- Om filerna ligger efter varandra trycker du på SKIFT och klickar sedan på första och sista filen i listan.
- Om filerna inte ligger efter varandra trycker du på CTRL och klickar på var och en av de filer i listan du vill importera.
Klicka på Importera.
Som standard skriver Excel över befintliga data i de mappade cellerna, vilket är det önskade slutresultatet för den här affärslösningen. Dock kan en beslutsfattare till exempel importera data flera gånger för att mäta förloppet innan den schemalagda tidsgränsen.
Obs
I Excel kan du också lägga till data med hjälp av alternativet Lägg till nya data till befintliga XML-tabeller (klicka på Egenskaper för mappning i gruppen XML på fliken Utvecklare), som kan vara lämpligt för andra lösningar.
Mer information finns i Ansluta till en XML-fil.
Uppgift 3: Uppdatera pivottabell- och pivotdiagramrapporterna
- Klicka på en cell i pivottabellrapporten.
- Klicka på pilen bredvid Uppdatera alla i gruppen Data på fliken Alternativ och klicka sedan på Uppdatera.
Nu innehåller Excel-arbetsboken alla data och sammanfattningsrapporter som du behöver för att fördela utrustningsbudgeten för nästa år. Naturligtvis kan du göra vidare analyser i Excel-arbetsboken om det behövs, till exempel genom att sortera, filtrera eller tillämpa villkorlig formatering.
Några sista reflektioner: Överväga att använda en SharePoint-lista eller Access-databas
Som ett alternativ kan du överväga att använda en SharePoint-lista eller en Access-databas i stället för XML för att överföra data mellan InfoPath och Excel.
Använda en SharePoint-lista
Du kan enkelt använda en SharePoint-lista som en skrivskyddad datakälla från InfoPath. Du kan göra en av två saker:
- Exportera data till Excel från SharePoint-listan, vilket gör att en dataanslutning skapas i Excel.
- Skapa uttryckligen en dataanslutning från Excel till SharePoint-listan.
När du har skapat en dataanslutning kan du uppdatera informationen i Excel så att uppdaterade data hämtas.
Du kan använda en SharePoint-lista för att lägga till och uppdatera data, använda ett InfoPath-formulär för att visa ett objekt från listan (till exempel ett långt eller komplext objekt som bäst återges i lodrätt format) och sedan använda Excel för att analysera informationen ytterligare.
1. veckor Visa ett enskilt objekt för enkel granskning i InfoPath.
2. veckor Lägga till och uppdatera data i en SharePoint-lista.
3. veckor Uppdatera och hämta aktuella data med Excel.
Mer information finns i Lägga till en dataanslutning i ett SharePoint-dokumentbibliotek eller en SharePoint-lista
Använda en Access-databas
Från InfoPath kan du skapa en anslutning för läsning och skrivning till en Access-databas. Från Excel kan du uttryckligen skapa en dataanslutning till Access-databasen som du kan uppdatera för att hämta aktuella data. Du kan även definiera anslutningen så att den uppdateras automatiskt när arbetsboken öppnas, eller så att den uppdateras regelbundet, t.ex. var femte minut.
Du kan använda en Access-databas som ett mellanled mellan InfoPath och Excel. När du skickar ett InfoPath-formulär till Access uppdateras Access-databasen. När du uppdaterar dataanslutningen i Excel hämtar du uppdaterade data från Access. I praktiken skickar du data indirekt från InfoPath till en Excel-arbetsbok.
1. veckor Visa och skicka ett formulär till en Access-databas.
2. veckor Lagra data i en Access-databas.
3. veckor Uppdatera och hämta aktuella data med Excel.
Mer information finns i Designa en formulärmall som är baserad på en Microsoft Access-databas.
Tips
Visste du att du kan skapa ett InfoPath-formulär direkt från Access? Om dina användare har Outlook 2007 eller 2010 och InfoPath 2007 eller 2010 installerade på sina datorer kan du samla in data från olika användare direkt från Access med hjälp av guiden Samla in data från e-postmeddelanden . Mer information finns i hjälpavsnittet om Access Lägga till data som samlats in via e-post i en Access-databas.