Du arbetar offline, väntar på att återansluta till Internet

Använda LETARAD eller LETAKOLUMN för att hitta en exakt matchning

Supporten för Office 2003 har upphört

Microsoft upphörde med supporten för Office 2003 den 8 april 2014. Denna ändring påverkar dina programuppdateringar och säkerhetsalternativ. Läs om vad detta innebär för dig och hur du behåller skyddet.

Sammanfattning
Funktionerna LETARAD och LETAKOLUMN innehåller argumentet "ungefärlig", som gör att du kan hitta en exakt matchning för uppslagsvärdet utan att sortera uppslagstabellen.

Obs! Du behöver inte sortera uppslagstabellen om du använder argumentet "ungefärlig" på rätt sätt.
Mer Information
De här funktionerna har följande syntax:

Funktionen LETARAD

   =LETARAD(letauppvärde,tabell,kolumnindex,ungefärlig)				
där:
   Argument     Definition av argument   ---------------------------------------------------------------------   letauppvärde Värdet som ska letas upp i matrisens första kolumn.   tabell  Tabellen med information i vilken data ska letas upp.   kolumnindex    Kolumnnumret i tabellen varifrån det matchande                värdet ska returneras.   ungefärlig Är ett logiskt värde som anger om du söker efter                en exakt eller ungefärlig matchning.                Om det är SANT eller utelämnas returneras en ungefärlig matchning,                d.v.s. om ingen exakt matchning hittas returneras                närmaste större värde som är mindre än letauppvärde.                Om värdet är FALSKT söker LETARAD efter en exakt matchning. Om ingen                exakt matchning hittas returneras felvärdet #Saknas!.				
Obs! Om ungefärlig har värdet SANT eller utelämnas (för en ungefärlig matchning), måste värdena i tabellens första kolumn sorteras i stigande ordning. Om ungefärlig har värdet FALSKT (för en exakt matchning) behöver tabellen inte sorteras.

Exempel där FALSKT används som ungefärlig-argument

Följande lista innehåller några frukter och färger. Observera att den första kolumnen inte är sorterad:
   A1: Frukt    B1: Färg     A2: Kiwi     B2: Grön    A3: Banan   B3: Gul    A4: Vindruva    B4: Lila     A5: Äpple    B5: Röd   				
Med följande formel hittar du färgen (Röd) som motsvarar frukten Äpple. Du kan skriva in formeln i vilken cell som helst i kalkylbladet:
=LETARAD("Äpple",A2:B5,2,FALSKT)				
Om du ändrar argumentet ungefärlig till SANT returneras felet #Saknas!, eftersom den första kolumnen inte sorteras.

Funktionen LETAKOLUMN

=LETAKOLUMN(letauppvärde,tabell,radindex,ungefärlig)				
där:
   Argument     Definition av argument   ---------------------------------------------------------------------   letauppvärde Värdet som ska letas upp i matrisens första kolumn.   tabell  Tabellen med information i vilken data ska letas upp.   radindex    Radnumret i tabellen varifrån det matchande                värdet ska returneras.   ungefärlig Är ett logiskt värde som anger om du söker efter                en exakt eller ungefärlig matchning.                Om det är SANT eller utelämnas returneras en ungefärlig matchning,                d.v.s. om ingen exakt matchning hittas returneras                närmaste större värde som är mindre än letauppvärde.                Om värdet är FALSKT söker LETARAD efter en exakt matchning.                Om ingen sådan hittas returneras felvärdet                #Saknas!.				
Obs! Om ungefärlig har värdet SANT eller utelämnas (för en ungefärlig matchning), måste värdena i tabellens första rad sorteras i stigande ordning. Om ungefärlig har värdet FALSKT (för en exakt matchning) behöver tabellen inte sorteras.

Exempel där FALSKT används som ungefärlig-argument

Följande lista innehåller några frukter och färger. Observera att den första kolumnen inte är sorterad:
   A1: Frukt    B1: Färg   A2: Kiwi     B2: Grön   A3: Banan   B3: Gul   A4: Vindruva    B4: Lila   A5: Äpple    B5: Röd				
Med följande formel hittas kolumnen Färg, och det tredje elementet (-1) returneras för rubriken Gul. Du kan skriva in formeln i vilken cell som helst i kalkylbladet:
=LETAKOLUMN("Färg",A1:B5,3,FALSKT)				
Om du ändrar argumentet ungefärlig till SANT returneras felet #Saknas!, eftersom den första kolumnen inte sorteras.
Referenser
Om du vill veta mer om hur du använder LETAUPP-funktionerna i Microsoft Excel klickar du på artikelnumren nedan och läser artiklarna i Microsoft Knowledge Base:
181212 XL: Söka med osorterade data i Excel
214264 XL: Göra en skiftlägeskänslig sökning
214069 XL: Returnera den första eller sista matchningen i en matris
181201 XL: LETAKOLUMN, LETARAD, LETAUPP returnerar felaktiga värden
213476 XL: Oväntade resultat när text och tal blandas i en uppslagstabell
280094 XL: Användardefinierad exempelfunktion för döljande av formelfel
Gör så här om du vill veta mer om funktionen LETAKOLUMN: klicka på Hjälp om Microsoft ExcelHjälp-menyn, skriv kalkylbladsfunktionen LETAKOLUMN i Office-assistenten eller Svarsguiden och klicka på Sök.
Gör så här om du vill veta mer om funktionen LETARAD: klicka på Hjälp om Microsoft ExcelHjälp-menyn, skriv kalkylbladsfunktionen LETARAD i Office-assistenten eller Svarsguiden och klicka på Sök.
XL2002 XL2000 XL97 XL XL2003 XL2007 XL2010
Obs! Det här är en "FAST PUBLISH”-artikel som skapats direkt inom Microsofts supportorganisation. Informationen i artikeln tillhandahålls i befintligt skick för att besvara framtida frågor. På grund av den snabba framtagningen kan materialet innehålla typografiska fel och kan utan förvarning när som helst komma att omarbetas. Se användarvillkoren för andra hänsynstaganden.
Egenskaper

Artikel-id: 181213 – senaste granskning 02/26/2014 15:24:00 – revision: 1.0

Microsoft Excel 2002 Standard Edition, Microsoft Excel 2000 Standard Edition, Microsoft Excel 97 Standard Edition, Microsoft Office Excel 2003, Microsoft Excel 2010, Microsoft Office Excel 2007

  • kbhowto KB181213
Feedback