Du arbetar offline, väntar på att återansluta till Internet

XL: Så tar du reda på om ett år är ett skottår

Sammanfattning
I den här artikeln beskrivs hur du tar reda på om ett år i ett datum som används i ett Microsoft Excel-dokument är ett skottår.
Mer Information
Datumsystemet i Excel baseras på den gregorianska kalendern, som infördes 1582 av påven Gregorius XIII för att åtgärda felen i den julianska kalendern.

I den gregorianska kalendern består ett vanligt år av 365 dagar. Eftersom ett sideriskt år (den tid det tar för jorden att gå ett varv runt solen) är 365,25635 dagar, används ett "skottår" med 366 dagar vart fjärde år för att eliminera felet som orsakas av tre normala (men korta) år. Alla år som är jämnt delbara med 4 är skottår, vilket innebär att exempelvis 1988, 1992 och 1996 är skottår.

Det återstår emellertid ett litet fel att ta hänsyn till. För att eliminera detta fel är ett år som är jämnt delbart med 100 (till exempel 1900) ett skottår i den gregorianska kalendern endast om det också är jämnt delbart med 400.

Därför är åren
1700, 1800, 1900, 2100, 2200, 2300, 2500, 2600
INTE skottår, eftersom de är jämnt delbara med 100 men INTE med 400.

Åren
1600, 2000, 2400
ÄR däremot skottår, eftersom de är jämnt delbara med både 100 och 400.

Eftersom endast år från 1900 till 2078 hanteras i tidigare Microsoft Excel-versioner än Excel 97, berörs endast året 1900 av 100/400-uteslutningsregeln för skottår i Microsoft Excel. För att Microsoft Excel ska vara kompatibelt med andra program behandlas emellertid år 1900 som ett skottår.

Mer information finns i följande artikel i Microsoft Knowledge Base:
214058 XL2000: Veckodagar före den 1 mars 1900 är felaktiga (Länken kan leda till en webbplats som är helt eller delvis på engelska)

Så tar du reda på om ett år är ett skottår

Så här tar du reda på om ett år är ett skottår:
  1. Om året är jämnt delbart med 4 går du till steg 2. Annars går du till steg 5.
  2. Om året är jämnt delbart med 100 går du till steg 3. Annars går du till steg 4.
  3. Om året är jämnt delbart med 400 går du till steg 4. Annars går du till steg 5.
  4. Året är ett skottår (det har 366 dagar).
  5. Året är inte ett skottår (det har 365 dagar).

Formel för att fastställa om ett år är ett skottår

Med hjälp av följande formel kan du ta reda på om årtalet i en cell (i det här fallet A1) är ett skottår:

=OM(ELLER(MOD(A1,400)=0,OCH(MOD(A1,4)=0,MOD(A1,100)<>0)),"Skottår", "INTE skottår")
   Om värdet i cell A1 är        Returnerar formeln   ----------------------------------------------------------   1992                                   Skottår   2000                                   Skottår   1900                                   INTE skottår				
XL2000 y2k years leapyear 365 366 xl2002 xl2001 xl98 xl97
Egenskaper

Artikel-id: 214019 – senaste granskning 02/26/2008 10:37:00 – revision: 3.1

Microsoft Excel 2000 Standard Edition, Microsoft Excel 2002 Standard Edition, Microsoft Excel 97 Standard Edition, Microsoft Excel 2001 för Macintosh, Microsoft Excel 98 för Macintosh

  • kbhowto KB214019
Feedback