Du arbetar offline, väntar på att återansluta till Internet

Webbläsaren stöds inte

Du måste uppdatera webbläsaren för att använda webbplatsen.

Uppdatera till den senaste versionen av Internet Explorer

"Det gick inte att läsa in 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy'" undantag när du har installerat uppdateringen 982167 eller uppdatera 982168

Supporten för Windows XP har upphört

Microsoft upphörde med supporten för Windows XP den 8 april 2014. Denna ändring påverkar dina programuppdateringar och säkerhetsalternativ. Läs om vad detta innebär för dig och hur du behåller skyddet.

Supporten för Windows Server 2003 upphörde 14 juli 2015

Microsoft upphörde med supporten för Windows Server 2003 den 14 juli 2015. Denna ändring påverkar dina programuppdateringar och säkerhetsalternativ. Läs om vad detta innebär för dig och hur du behåller skyddet.

VIKTIGT: Denna artikel har översatts av Microsofts programvara för maskin-översättning och möjligen efterredigerats via CTF-teknologi av Microsofts community istället för av en professionell mänsklig översättare. För att du på ditt eget språk skall få tillgång till samtliga Knowledge Base-artiklar erbjuder Microsoft både mänskligt översatta såväl som maskinöversatta artiklar samt artiklar som efterredigerats av en community. En maskinöversatt artikel likväl som en artikel som blivit efterredigerad av en community är dock inte alltid helt perfekt, då de kan innehålla misstag i ordförrådet, syntax- och grammatikfel. Microsoft är inte ansvarigt för några felaktigheter, misstag eller skador orsakade av felöversättningar eller för våra kunders bruk av innehållet. Microsoft uppdaterar ofta sin programvara för maskinöversättning samt de verktyg som förbättrar den maskinöversatta efterredigeringen.

Den engelska versionen av artikeln är följande: 2262911
Symptom
När du har installerat uppdatering 982167 eller uppdatering 982168 kan det hända att ett felmeddelande av följande slag när du kör Windows Communication Foundation-baserade program för undantag:
Det gick inte att läsa in typen ' System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy
Orsak
Uppdatering av 982167 och 982168 i.NET Framework 2.0 funktionen Uppdateringsskiktet i.NET Framework 3.5 SP1 för att införa den nya typen 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy'. Den här nya typen används av motsvarande ny funktion i Windows Communication Foundation.

Felet inträffar eftersom underliggande klientbibliotek för.NET Framework 2.0 SP2-nätverket funktionen lagret inte uppdateras när Windows Communication Foundation funktionen lagret uppdateras till att använda den nya typen. Det underliggande lagret i klientbibliotek för.NET Framework 2.0 SP2-nätverket funktionen stöder inte den här nya typen och så det här felet returneras.

Den här situationen kan uppstå av flera anledningar, vissa problem med installation av fel som är relaterade till dual branch servicing. Om du vill veta mer klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:
960043 Dual Branch Servicing för .NET Framework 2.0 Service Pack 2, .NET Framework 3.0 Service Pack 2 och .NET Framework 3.5 Service Pack 1
Workaround
Lös problemet så här:
  1. Installera snabbkorrigering 975954. MSI-uppdateringar kan hämtas på följande MSDN-webbsidan:
  2. Reparation av produkten. Vi kan reparera produkten du automatiskt eller du kan reparera produkten själv.

    Lös det åt mig

    Om du vill köra en reparation av produkten automatiskt klickar du på länken Lös det här problemet. Klicka på Kör i dialogrutan Filhämtningoch följ anvisningarna i guiden.

    Obs!Den här guiden finns för närvarande endast på engelska. Men fungerar den automatiska korrigeringsfilen även för andra språkversioner av Windows.

    Obs!Om du inte sitter vid datorn där problemet kan du spara den automatiska korrigeringsfilen på en flash-enhet eller en CD så att du kan köra den på rätt dator.

    Jag löser det själv

    Om du vill reparera produkten själv, skriver du följande kommando i en kommandotolk:
    msiexec /f {C09FB3CD-3D0C-3F2D-899A-6A1D67F2073F}

    Detta medför att alla funktioner i.NET Framework 2.0 SP2 produkten att omvärdera sin installationstillstånd.
    Detta löser problemet och gör det möjligt för uppdatering 982167 eller 982168 att tillämpa sina respektive nyttolaster.
Obs! Om steg 1 och 2 inte fungerar kan du försöka avinstallera uppdateringen du installerade innan felet och sedan installera om uppdateringen.
Status
Microsoft har bekräftat att detta är ett problem i Microsoft-produkterna som nämns i avsnittet "Gäller".
Mer Information
Mer information om hur du kör ett kommando med förhöjd behörighet finns på följande Microsoft-webbsida: Mer information om kommandoradsväxlar som stöds av Windows Installer finns på följande MSDN-webbsida: Mer information om Windows Installer finns på följande MSDN-webbsidan:
Säkerhetsuppdatering beläggningstypen patch 982167 982168 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy' WCF fixit fix Det

Varning: Den här artikeln har automatöversatts

Egenskaper

Artikel-id: 2262911 – senaste granskning 11/26/2013 23:21:00 – revision: 4.0

  • Microsoft .NET Framework 3.5 Service Pack 1
  • Microsoft .NET Framework 2.0 Service Pack 2
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows XP Service Pack 2
  • kbbug kbexpertiseinter kbinfo kbsecurity kbmsifixme kbfixme kbmt KB2262911 KbMtsv
Feedback
/script>");