Ledig/upptagen-sökningar mellan Exchange Online och lokal användare slutar fungera när du har skapat OAuth-autentisering

VIKTIGT: Denna artikel har översatts av Microsofts programvara för maskin-översättning och möjligen efterredigerats via CTF-teknologi av Microsofts community istället för av en professionell mänsklig översättare. För att du på ditt eget språk skall få tillgång till samtliga Knowledge Base-artiklar erbjuder Microsoft både mänskligt översatta såväl som maskinöversatta artiklar samt artiklar som efterredigerats av en community. En maskinöversatt artikel likväl som en artikel som blivit efterredigerad av en community är dock inte alltid helt perfekt, då de kan innehålla misstag i ordförrådet, syntax- och grammatikfel. Microsoft är inte ansvarigt för några felaktigheter, misstag eller skador orsakade av felöversättningar eller för våra kunders bruk av innehållet. Microsoft uppdaterar ofta sin programvara för maskinöversättning samt de verktyg som förbättrar den maskinöversatta efterredigeringen.

Den engelska versionen av artikeln är följande: 3001281
Obs! Hybrid konfigurationsguiden som ingår i Exchange Management Console i Microsoft Exchange Server 2010 stöds inte längre. Därför kan använder du inte längre den gamla Hybrid konfigurationsguiden. Använd i stället guiden Office 365 Hybrid-konfiguration finns på http://aka.MS/HybridWizard. Mer information finns i Office 365 Hybrid konfigurationsguiden för Exchange 2010.
PROBLEMET
Anta att du har en hybrid distribution av lokal Exchange Server och Exchange Online och konfigurera OAuth-autentisering genom att följa instruktionerna på Konfigurera OAuth-autentisering mellan Exchange och Exchange Online organisationer. Ledig/upptagen-sökningar mellan lokal Exchange och Exchange Online-användare fungerar inte längre i den här situationen. Användare se hash-tecken ("\\\") i stället för ledig/upptagen-information. Men ledig/upptagen sökningar mellan lokal Exchange-användare fortfarande fungerar.
ORSAK
Det här problemet kan uppstå om följande villkor är uppfyllda:
  • Lokal miljö innehåller både Exchange 2010 och 2013 Exchange-servrar.
  • OAuth-autentisering är aktiverat.
LÖSNING
Inaktivera IntraOrganizationConnector funktioner som förhindrar OAuth-autentisering för automatisk upptäckt begär mellan lokal Exchange Server och Exchange Online. Gör så här:
  1. Testa OAuth-autentisering i din miljö:
    1. Anslut till Exchange Online med hjälp av remote PowerShell. Mer information om hur du gör detta finns i Ansluta till Exchange Online använder Remote PowerShell.
    2. Kör följande kommando:
      Test-OAuthConnectivity -Service EWS -TargetUri <external hostname authority of your on-premises Exchange deployment> -Mailbox <Exchange Online mailbox> -Verbose | fl 
    3. Om testet misslyckas bekräftar det att OAuth inte har ställts in korrekt. Gå till steg 2.
  2. Inaktivera IntraOrganizationConnector. Det gör du genom att köra följande kommando:
    Set-IntraOrganizationConnector <connector_name> -Enabled $false
Denna ändring kan ta 30 minuter att slutföra. Efter att ska ledig/upptagen-sökningar fungera.
MER INFORMATION
Förutom de problem som beskrivs i avsnittet "Problem" om du undersöker ledig/upptagen-begäran i Internet Information Services (IIS) loggar, svaret "401" av följande slag visas:
2014-06-17 19:09:07 W3SVC1 Server 192.168.216.90POST /autodiscover/autodiscover.svc443 - 10.0.0.0 HTTP/1.1 ASAutoDiscover/CrossForest/EmailDomain//15.00.0959.014 - hybrid.contoso.com 401 0 0 359
Behöver du hjälp? Gå till den Office 365-Community webbplatsen eller TechNet-forum för Exchange.

Varning: Den här artikeln har automatöversatts

Lastnosti

ID članka: 3001281 – Zadnji pregled: 04/27/2016 02:52:00 – Revizija: 2.0

Microsoft Exchange Online, Microsoft Exchange Server 2013 Enterprise, Microsoft Exchange Server 2013 Standard, Microsoft Exchange Server 2010 Enterprise, Microsoft Exchange Server 2010 Standard

  • o365e o365m o365022013 o365 o365a hybrid kbbug kbmt KB3001281 KbMtsv
Povratne informacije