Felmeddelandet "Tjänstspecifik felkod 2147944102" om du försöker starta BITS-tjänsten

Den här artikeln innehåller en lösning på ett fel 2147944102 som inträffar när du startar BITS-tjänsten (Background Intelligent Transfer Service).

Gäller för: Windows Server 2012 R2
Ursprungligt KB-nummer: 326460

Symptom

Om du försöker starta BITS-tjänsten på en Windows 2000-baserad dator där Terminal Services är installerat kan följande problem uppstå:

  • Du får något av följande felmeddelanden:

    Windows kunde inte starta Background Intelligent Transfer Service på den lokala datorn. Mer information finns i systemhändelseloggen. Om det här är en tjänst som inte kommer från Microsoft kontaktar du tjänstleverantören och hänvisar till tjänstspecifik felkod -2147023194.

    eller

    Ett tjänstspecifikt fel uppstod: -2147944102.

  • Följande händelse registreras i systemloggen för Windows NT Loggboken:

    Händelsetyp: Fel
    Händelsekälla: Service Control Manager
    Händelsekategori: Ingen
    Händelse-ID: 7024
    Användare: Ej tillämpligt
    Beskrivning: Tjänsten Background Intelligent Transfer Service avslutades med ett tjänstspecifikt fel 2147944102.

Orsak

Det här beteendet kan inträffa om Terminal Services-tjänsten är inaktiverad.

När Terminal Services-komponenten är installerad är starttypen för Terminal Services-tjänsten som standard inställd på Automatisk. Om en administratör ändrar tjänstens starttyp till Inaktiverad startar inte BITS-tjänsten.

Åtgärd

Lös problemet genom att hämta det senaste Service Pack för Microsoft Windows 2000.

Lösning

Du kan lösa det här problemet genom att använda någon av följande metoder (beroende på din situation).

Metod 1: Konfigurera Terminal Services att starta automatiskt

Så här konfigurerar du Terminal Services-tjänsten så att den startar automatiskt:

  1. Klicka på Start, peka på Inställningar och klicka sedan på Kontrollpanelen.
  2. Dubbelklicka på Administrationsverktyg och dubbelklicka sedan på Tjänster.
  3. Högerklicka på Terminal Services i den högra rutan och klicka sedan på Egenskaper.
  4. Klicka på fliken Allmänt .
  5. I rutan Starttyp klickar du på Automatisk och sedan på OK.

Metod 2: Ta bort Terminal Services

Om du inte behöver Terminal Services, eller om det inte används på servern, tar du bort Terminal Services. Gör så här:

  1. Klicka på Start, peka på Inställningar och klicka sedan på Kontrollpanelen.
  2. Dubbelklicka på Lägg till/ta bort program.
  3. Klicka på Lägg till/ta bort Windows-komponenter.
  4. I guiden Windows-komponenter klickar du för att avmarkera kryssrutan Terminal Services och klickar sedan på Nästa.
  5. På sidan Slutför guiden Windows-komponenter klickar du på Slutför.
  6. I fönstret Lägg till/ta bort program klickar du på Stäng.

Status

Microsoft har bekräftat att detta är ett problem i De Microsoft-produkter som visas i början av den här artikeln. Det här problemet korrigerades först i Microsoft Windows 2000 Service Pack 4.

Mer information

Problemet som beskrivs i avsnittet "Symptom" i den här artikeln kan också inträffa när du har installerat Microsoft Software Update Services (SUS) 1.0 eller klienten Automatisk Uppdateringar 2.2 på en Windows 2000 Server-baserad dator med Terminal Services installerat.