Felmeddelande när du installerar ett MSU-uppdateringspaket på en dator som kör Windows: "Moduler Windows Installer måste uppdateras innan du kan installera det här paketet"

VIKTIGT: Denna artikel har översatts av Microsofts programvara för maskin-översättning och möjligen efterredigerats via CTF-teknologi av Microsofts community istället för av en professionell mänsklig översättare. För att du på ditt eget språk skall få tillgång till samtliga Knowledge Base-artiklar erbjuder Microsoft både mänskligt översatta såväl som maskinöversatta artiklar samt artiklar som efterredigerats av en community. En maskinöversatt artikel likväl som en artikel som blivit efterredigerad av en community är dock inte alltid helt perfekt, då de kan innehålla misstag i ordförrådet, syntax- och grammatikfel. Microsoft är inte ansvarigt för några felaktigheter, misstag eller skador orsakade av felöversättningar eller för våra kunders bruk av innehållet. Microsoft uppdaterar ofta sin programvara för maskinöversättning samt de verktyg som förbättrar den maskinöversatta efterredigeringen.

Den engelska versionen av artikeln är följande: 925316
Symptom
När du installerar ett MSU-uppdateringspaket på en dator som kör Windows kan det hända att följande felmeddelande visas:
Installationsprogrammet för Windows-moduler måste uppdateras innan du kan installera det här paketet. Uppdatera Windows Modules Installer på datorn och försök sedan starta installationsprogrammet igen.
När du använder ett skript för att installera MSU-uppdateringspaketet, misslyckas installationen. När detta inträffar returnerar Wusa.exe processen felkoden 0x800f0823.
Orsak
Det här problemet beror på att installationen kräver en ny version av Windows Installer för moduler eller den betjänande stacken.
Lösning
Lös problemet genom att använda Windows Update för att uppdatera moduler Windows Installer eller den betjänande stacken. Eller hämta uppdateringarna som beskrivs i följande tabell från Microsoft Download Center.
OperativsystemKB-nummer
Windows Vista och Windows Server 2008955430
Windows 7 och Windows Server 2008 R22533552
Windows 8 och Windows Server 20122871777
Windows 8.1 och Windows Server 2012 R22919442
Mer Information
När du använder Windows Update krävs moduler Windows Installer eller servicing stack-uppdatering. När du installerar ett MSU-uppdateringspaket dock installationsprogrammet inte ansluta till Windows Update för att uppdatera Windows Installer för moduler eller den betjänande stacken.

Varning: Den här artikeln har automatöversatts

Egenskaper

Artikel-id: 925316 – senaste granskning 07/03/2016 20:33:00 – revision: 6.0

Windows 8.1 Enterprise, Windows 8.1, Windows 8.1 Pro, Windows Server 2012 R2 Datacenter, Windows Server 2012 R2 Essentials, Windows Server 2012 R2 Standard, Windows Server 2012 R2 Foundation, Windows RT 8.1, Windows 8 Enterprise, Windows 8, Windows 8 Pro, Windows RT, Windows Server 2012 Datacenter, Windows Server 2012 Essentials, Windows Server 2012 Foundation, Windows Server 2012 Standard, Windows 7 Enterprise, Windows 7 Home Basic, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Ultimate, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 Foundation, Windows Server 2008 R2 Standard, Windows Server 2008 Enterprise, Windows Server 2008 Datacenter, Windows Server 2008 Foundation, Windows Server 2008 Standard, Windows Vista Home Basic, Windows Vista Home Premium, Windows Vista Ultimate, Windows Vista Business, Windows Vista Enterprise, Windows Vista Home Basic 64-bit edition, Windows Vista Home Premium 64-bit edition, Windows Vista Ultimate 64-bit edition, Windows Vista Business 64-bit edition, Windows Vista Enterprise 64-bit edition

  • kbtshoot kbexpertisebeginner kbprb kbmt KB925316 KbMtsv
Feedback