MS10-022: Beskrivning av säkerhetsuppdateringen för Visual Basic Scripting (VBScript) 5.6: 13 april 2010

Supporten för Windows XP har upphört

Microsoft upphörde med supporten för Windows XP den 8 april 2014. Denna ändring påverkar dina programuppdateringar och säkerhetsalternativ. Läs om vad detta innebär för dig och hur du behåller skyddet.

Supporten för Windows Server 2003 upphörde 14 juli 2015

Microsoft upphörde med supporten för Windows Server 2003 den 14 juli 2015. Denna ändring påverkar dina programuppdateringar och säkerhetsalternativ. Läs om vad detta innebär för dig och hur du behåller skyddet.

Den här artikeln har arkiverats. Den erbjuds "i befintligt skick" och kommer inte längre att uppdateras.
INLEDNING
Microsoft har gett ut säkerhetsbulletinen MS10-022. Du hittar hela säkerhetsbulletinen på följande Microsoft-webbplatser:

Här finns hjälp och support för säkerhetsuppdateringen

Hemanvändare kan få kostnadsfri support genom att ringa 1-866-PCSAFETY i USA och Kanada eller genom att kontakta närmaste Microsoft-kontor. Information om hur du kontaktar närmaste Microsoft-kontor för support vid problem med säkerhetsuppdateringar finns på följande internationella Microsoft-supportwebbplats: Kunder i Nordamerika kan även få omedelbar tillgång till obegränsad kostnadsfri e-postsupport eller obegränsad individuell chattsupport på följande Microsoft-webbplats: Företagskunder kan få support på säkerhetsuppdateringar genom sina normala supportkontakter.
Mer Information

Mer information om den här säkerhetsuppdateringen

Känt problem

Ett problem har rapporterats som påverkar ett begränsat antal datorer där samtliga följande villkor uppfylls:
  • Windows XP Service Pack 3 är installerat.
  • En gammal version av Windows Script Host 5.6 har installerats manuellt.
Obs! Windows Script Host 5.7 installeras som standard med Windows XP Service Pack 3. Det här problemet drabbar endast datorer där en tidigare version av Windows Script Host har installerats manuellt, även om det inte behövts.

På datorer som drabbats av det här problemet kan det hända att säkerhetsuppdateringen inte kan installeras eftersom det finns en oväntat version av Vbscript.dll. För att det ska gå att installera säkerhetsuppdateringen på Windows XP Service Pack 3 får Vbscript.dll-filen vara högst version 5.7.

Om datorn kör Windows XP Service Pack 3 och Vbscript.dll-filversionen är 5.6, väljer du den metod nedan som passar din Windows Internet Explorer-version.

Internet Explorer 6
  1. Återställ Vbscript.dll till en förväntad filversion.

    Gör något av följande för att återställa Vbscript.dll till version 5.7:
    • Hämta och installera KB951978 skriptmotoruppdateringen för Windows XP:
      951978 Skriptutdata visas inte som förväntat när du kör VBScript- eller JScript-skript i Windows Vista Service Pack 1, Windows Server 2008 eller Windows XP Service Pack 3 (Länken kan leda till en webbplats som är helt eller delvis på engelska)
      Obs! Om du har aktiverat automatiska uppdateringar erbjuds du den här uppdateringen automatiskt.
    • Uppgradera till Internet Explorer 8. Mer information om hur du skaffar Internet Explorer 8 hittar du på följande Microsoft-webbplats:Obs! Om du har aktiverat automatiska uppdateringar erbjuds du den här uppdateringen automatiskt.
    • Uppgradera till Internet Explorer 7. Mer information om hur du skaffar Internet Explorer 7 hittar du på följande Microsoft-webbplats:
  2. Installera säkerhetsuppdateringen.

    När du har återställt Vbscript.dll till en förväntad version enligt anvisningarna installerar du VBScript 5.7-säkerhetsuppdateringen för Windows XP Service Pack 3 (KB981349) enligt säkerhetsbulletinen MS10-022.

    Obs! Den här säkerhetsuppdateringen erbjuds via Automatiska uppdateringar om Vbscript.dll-versionen är minst 5.7.0.0.
Internet Explorer 7
  1. Återställ Vbscript.dll till en förväntad filversion.

    Gör något av följande för att återställa Vbscript.dll till version 5.7:
    • Hämta och installera KB951978 skriptmotoruppdateringen för Windows XP:
      951978 Skriptutdata visas inte som förväntat när du kör VBScript- eller JScript-skript i Windows Vista Service Pack 1, Windows Server 2008 eller Windows XP Service Pack 3 (Länken kan leda till en webbplats som är helt eller delvis på engelska)
      Obs! Om du har aktiverat automatiska uppdateringar erbjuds du den här uppdateringen automatiskt.
    • Uppgradera till Internet Explorer 8. Mer information om hur du skaffar Internet Explorer 8 hittar du på följande Microsoft-webbplats:Obs! Om du har aktiverat automatiska uppdateringar erbjuds du den här uppdateringen automatiskt.
    • Avinstallera Internet Explorer 7 och installera sedan om det.
  2. Installera säkerhetsuppdateringen.

    När du har återställt Vbscript.dll till en förväntad version enligt anvisningarna installerar du VBScript 5.7-säkerhetsuppdateringen för Windows XP Service Pack 3 (KB981349) enligt säkerhetsbulletinen MS10-022.

    Obs! Om du har aktiverat automatiska uppdateringar erbjuds du den här uppdateringen automatiskt.
Internet Explorer 8

Om Internet Explorer 8 är installerat och du har aktiverat automatiska uppdateringar, erbjuds du den rätta uppdateringen automatiskt och behöver inte vidta några åtgärder. Om du måste installera den här säkerhetsuppdateringen manuellt hämtar och installerar du VBScript 5.8-säkerhetsuppdateringen för Windows XP Service Pack 3 (KB981349) enligt säkerhetsbulletinen MS10-022.

Förutsättningar för att installera den här säkerhetsuppdateringen

Innan du kan installera säkerhetsuppdateringen måste Microsoft Visual Basic Scripting Edition (VBScript) 5.6 vara installerat på datorn.

VBScript 5.6 installeras enligt följande:
  • Microsoft Internet Explorer 6
  • Windows Server 2003 (följande versioner: x86-baserade SP2, x64-baserade SP2 och Itanium-baserade SP2)
  • Windows XP (följande versioner: x86-baserade SP2 och x64-baserade SP2)
  • Windows Script Host 5.6
Så här tar du reda på vilken version av VBScript som är installerad på datorn:
  1. Öppna Utforskaren i Windows.
  2. Leta reda på följande katalog:
    %systemroot%\system32
  3. Högerklicka på Vbscript.dll-filen och klicka på Egenskaper.
  4. Klicka på fliken Version och visa fältet Filversion.
Om filversionen börjar med 5.6 (till exempel 5.6.0.8825) är VBScript 5.6 installerat.

Information om borttagning

Gör något av följande om du vill ta bort den här säkerhetsuppdateringen:
  • Använd Lägg till eller ta bort program på Kontrollpanelen.
  • Använd Spuninst.exe som finns i följande mapp:
    %Windir%\$NTUninstallKB981350$\Spuninst

Information om omstart

Du måste kanske starta om datorn när du har installerat den här säkerhetsuppdateringen.

Filinformation

Den engelska (USA) versionen av den här säkerhetsuppdateringen har filattributen som visas i följande tabell (eller senare). Datum och tider för dessa filer anges i UTC-tid (Coordinated Universal Time), Innan du läser filinformationen konverteras den till lokal tid. Du kan se skillnaden mellan UTC-tid och lokal tid med hjälp av fliken Tidszon i verktyget Datum och tid på Kontrollpanelen.
För alla x86-baserade versioner av Windows 2000 SP4 som stöds
File nameFile versionFile sizeDateTimePlatform
Vbscript.dll5.6.0.8838401,40812-Mar-201021:44x86
För alla x86-baserade versioner av Windows XP SP2 som stöds
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838417,79210-Mar-201008:02x86SP2SP2GDR
Vbscript.dll5.6.0.8838417,79210-Mar-201008:07x86SP2SP2QFE
För alla x86-baserade versioner av Windows Server 2003 SP2 som stöds
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838401,40809-Mar-201005:20x86SP2SP2GDR
Vbscript.dll5.6.0.8838401,40809-Mar-201005:27x86SP2SP2QFE
För alla x64-baserade versioner av Windows Server 2003 SP2 och Windows XP Professional som stöds
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838663,04009-Mar-201004:43x64SP2SP2GDR
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:43x86SP2SP2GDR\WOW
Vbscript.dll5.6.0.8838663,55209-Mar-201004:38x64SP2SP2QFE
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:38x86SP2SP2QFE\WOW
För alla Itanium-baserade versioner av Windows Server 2003 SP2 som stöds
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.88381,116,67209-Mar-201004:41IA-64SP2SP2GDR
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:41x86SP2SP2GDR\WOW
Vbscript.dll5.6.0.88381,117,69609-Mar-201004:38IA-64SP2SP2QFE
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:38x86SP2SP2QFE\WOW
update security_patch security_update security bug flaw vulnerability malicious attacker exploit registry unauthenticated buffer overrun overflow specially-formed scope specially-crafted denial of service dos
Egenskaper

Artikel-id: 981350 – senaste granskning 12/12/2015 03:43:30 – revision: 1.0

Microsoft Internet Explorer 6.0, Microsoft Windows Server 2003 Service Pack 2, Microsoft Windows XP Service Pack 2, Microsoft Windows 2000 Service Pack 4

  • kbnosurvey kbarchive kbsurveynew kbfix kbbug kbsecvulnerability kbsecbulletin kbsecurity kbqfe kbexpertiseinter KB981350
Feedback