Beräkna en löpande summa i Excel

Du kan använda en löpande summa för att se hur värdena för objekt i celler addera när du lägger till nya objekt och värden över tid. Använd följande procedur för att beräkna en löpande summa.

  1. Skapa ett kalkylblad som i följande exempel.

    Detta blir enklare att förstå om du kopierar exemplet till ett kalkylblad.

    Så här kopierar du ett exempel

    1. Skapa en tom arbetsbok eller ett tomt kalkylblad.

    2. Markera exemplet i hjälpavsnittet.

      Obs!: Markera inte rad- eller kolumnrubrikerna.

      Markera exempeldata

    3. Tryck på Ctrl+C.

    4. Markera cell A1 i kalkylbladet och tryck på Ctrl+V.

    5. Om du vill växla mellan att visa resultatet och de formler som returnerar resultatet trycker du på Ctrl+§. Du kan också gå till fliken Formler och klicka på Visa formler i gruppen Formelgranskning.

      A

      B

      C

      D

      E

      1

      Datum

      Produkt

      Antal

      Formel

      Löpande summa

      2

      2-jan

      Beach toys

      5

      =SUMMA($C$2:$C 2)

      5

      3

      2-jan

      Kan inte göra det

      3

      =SUMMA($C$2:$C 3)

      8

      4

      3-jan

      Beach toys

      9

      =SUMMA($C$2:$C 4)

      17

      5

      3-jan

      Kan inte göra det

      8

      =SUMMA($C$2:$C 5)

      25

      6

      3-jan

      700 000

      1

      =SUMMA($C$2:$C 6)

      26

      7

      4-jan

      Beach toys

      6

      =SUMMA($C$2:$C 7)

      32

      8

      4-jan

      Kan inte göra det

      4

      =SUMMA($C$2:$C 8)

      36

      9

      5-jan

      Beach toys

      11

      =SUMMA($C$2:$C 9)

      47

      10

      5-jan

      Begränsat läge (sandbox)

      1

      =SUMMA($C$2:$C 10)

      48

      11

      5-jan

      Kan inte göra det

      5

      =SUMMA($C$2:$C 11)

      53

      1,2

      5-jan

      700 000

      2

      =SUMMA($C$2:$C 12)

      55

      Om du tittar närmare på formlerna i kolumn D kommer du att se att den första delen av området är en absolut referens (både kolumnen och raden föregås av symbolen $), och att den andra delen av området är en blandad referens (endast kolumnen föregås av symbolen $). Om du anger formeln på det här sättet kan den fungera som en löpande summa när du kopierar den till angränsande rader.

  2. För att bibehålla den löpande summan lägger du till en rad för varje ny post och kopierar formeln från kolumn D till den raden.

    Du behöver inte ange eller kopiera formeln manuellt på varje rad. Du kan till exempel ange formeln i bara cell D2. Kopiera sedan formeln till andra rader som innehåller data genom att dra fyllningshandtaget till cell D13.

Obs!: En löpande summa skiljer sig från en löpande balans där du ser hur summan av värden växer eller krymper (till exempel ett checkboksregister) när nya poster läggs till.

  1. Skapa ett kalkylblad som i följande exempel.

    Detta blir enklare att förstå om du kopierar exemplet till ett kalkylblad.

    Så här kopierar du ett exempel

    1. Skapa en tom arbetsbok eller ett tomt kalkylblad.

    2. Markera exemplet i hjälpavsnittet.

      Obs!: Markera inte rad- eller kolumnrubrikerna.

      Markera exempeldata

    3. Tryck KOMMANDO + C.

    4. Markera cell A1 i kalkylbladet och tryck sedan på KOMMANDO + V.

    5. Om du vill växla mellan att visa resultatet och de formler som returnerar resultatet trycker du på CTRL+' (grav accent). Du kan också gå till fliken Formler och klicka på Visa formler i gruppen Formelgranskning.

      A

      B

      C

      D

      E

      1

      Datum

      Produkt

      Antal

      Formel

      Löpande summa

      2

      2-jan

      Beach toys

      5

      =SUMMA($C$2:$C 2)

      5

      3

      2-jan

      Kan inte göra det

      3

      =SUMMA($C$2:$C 3)

      8

      4

      3-jan

      Beach toys

      9

      =SUMMA($C$2:$C 4)

      17

      5

      3-jan

      Kan inte göra det

      8

      =SUMMA($C$2:$C 5)

      25

      6

      3-jan

      700 000

      1

      =SUMMA($C$2:$C 6)

      26

      7

      4-jan

      Beach toys

      6

      =SUMMA($C$2:$C 7)

      32

      8

      4-jan

      Kan inte göra det

      4

      =SUMMA($C$2:$C 8)

      36

      9

      5-jan

      Beach toys

      11

      =SUMMA($C$2:$C 9)

      47

      10

      5-jan

      Begränsat läge (sandbox)

      1

      =SUMMA($C$2:$C 10)

      48

      11

      5-jan

      Kan inte göra det

      5

      =SUMMA($C$2:$C 11)

      53

      1,2

      5-jan

      700 000

      2

      =SUMMA($C$2:$C 12)

      55

      Om du tittar närmare på formlerna i kolumn D kommer du att se att den första delen av området är en absolut referens (både kolumnen och raden föregås av symbolen $), och att den andra delen av området är en blandad referens (endast kolumnen föregås av symbolen $). Om du anger formeln på det här sättet kan den fungera som en löpande summa när du kopierar den till angränsande rader.

  2. För att bibehålla den löpande summan lägger du till en rad för varje ny post och kopierar formeln från kolumn D till den raden.

    Du behöver inte ange eller kopiera formeln manuellt på varje rad. Du kan till exempel ange formeln i bara cell D2. Kopiera sedan formeln till andra rader som innehåller data genom att dra fyllningshandtaget till cell D13.

Obs!: En löpande summa skiljer sig från en löpande balans där du ser hur summan av värden växer eller krymper (till exempel ett checkboksregister) när nya poster läggs till.

Behöver du mer hjälp?

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

×