Beräkningsoperatorer och prioritet i Excel

Operatorer anger vilken typ av beräkning som du vill utföra på element i en formel – t.ex. addition, subtraktion, multiplikation eller division. I den här artikeln får du lära dig standardordningen för hur operatorer agerar på elementen i en beräkning. Du får också lära dig hur du ändrar ordningen med parenteser.

Typer av operatorer

Det finns fyra olika typer av beräkningsoperatorer: aritmetiska operatorer, jämförelseoperatorer, textkombinationsoperatorer och referensoperatorer.

Om du vill utföra grundläggande matematiska operationer som addition, subtraktion eller multiplikation – eller kombinera tal – och producera numeriska resultat, använder du de aritmetiska operatorerna i den här tabellen.

Aritmetisk operator

Betydelse

Exempel

+ (plustecken)

Addition

=3+3

– (minustecken)

Subtraktion
Negation

=3–1
=-1

* (asterisk)

Multiplikation

=3*3

/ (snedstreck)

Division

=3/3

% (procenttecken)

Procent

=20%

^ (cirkumflex)

Exponentiering

=

Med operatorerna i tabellen nedan kan du jämföra två värden. När två värden jämförs med hjälp av dessa operatorer, blir resultatet ett logiskt värde, antingen SANT eller FALSKT.

Jämförelseoperator

Betydelse

Exempel

= (likhetstecken)

Lika med

=A1=B1

> (större än-tecken)

Större än

=A1>B1

< (mindre än-tecken)

Mindre än

=A1<B1

>= (större än eller lika med-tecken)

Större än eller lika med

=A1>=B1

<= (mindre än eller lika med-tecken)

Mindre än eller lika med

=A1<=B1

<> (inte lika med-tecken)

Inte lika med

=A1<>B1

Använd et-tecken (&) för att sammanfoga en eller flera textsträngar för att skapa ett enda textstycke.

Textoperator

Betydelse

Exempel

& (et-tecken)

Ansluter eller sammanfogar två värden för att ge ett sammanhängande textvärde.

="North"&"wind"

Kombinera cellområden för beräkningar med dessa operatorer.

Referensoperator

Betydelse

Exempel

: (kolon)

Områdesoperator som skapar en referens till alla celler mellan två referenser, inklusive de två referenserna.

=SUMMA(B5:B15)

, (komma)

Unionsoperator som kombinerar flera referenser till en referens.

=SUMMA(B5:B15;D5:D15)

(blanksteg)

Skärningspunktsoperator som skapar en referens till celler som är gemensamma för de två referenserna.

=SUMMA(B7:D7 C6:C8)

# (fyrkant)

Symbolen # används i flera sammanhang:

  • Används som en del av ett felnamn.

  • Används för att indikera otillräckligt med utrymme för att rendera. I de flesta fall kan du bredda kolumnen tills innehållet visas korrekt.

  • Intervalloperator, som används för att referera till ett helt område i en dynamisk matrisformel.

  • #VÄRDEFEL!

  • #####

  • =SUMMA(A2#)

@ (at)

Referensoperator, som används för att ange implicit skärningspunkt i en formel. 

=@A1:A10

=SUMMA(Tabell1[@[Januari]:[December]])

Prioritetsordningen för operationer i Excel

Ibland kan beräkningsordningen påverka resultatet av formeln, så det är viktigt att du förstår ordningen och hur du kan ändra ordningen för att få fram det resultat du förväntar dig.

Formler beräknar värden i en särskild ordning. En formel i Excel börjar alltid med ett likhetstecken (=). Likhetstecknet anger Excel att tecknen som följer utgör en formel. Efter det här likhetstecknet kan det finnas en serie element som ska beräknas (operanderna), som avgränsas med operatorer. Formeln beräknas från vänster till höger, enligt en särskild ordning för varje operator i formeln.

Om du kombinerar flera operatorer i en enstaka formel utförs operationerna i den ordning som visas i tabellen nedan. Om en formel innehåller operatorer med samma prioritet ,det kan vara en formel som innehåller både en multiplikations- och divisionsoperator,  beräknas operatorerna från vänster till höger.

Operator

Beskrivning

: (kolon)

(enkelt blanksteg)

, (komma)

Referensoperatorer

Negation (som i –1)

%

Procent

^

Exponentiering

* och /

Multiplikation och division

+ och –

Addition och subtraktion

&

Sammanfogar två textsträngar

=
< >
<=
>=
<>

Jämförelse

Om du vill ändra beräkningsordningen omsluter du den del som ska beräknas först med parenteser. Följande formel ger till exempel värdet 11, eftersom Excel beräknar multiplikation före addition. Formeln multiplicerar först 2 med 3 och adderar sedan 5 till resultatet.

=5+2*3

Om du däremot använder parenteser för att ändra syntaxen Excel adderar 5 och 2 och multiplicerar sedan resultatet med 3 så att resultatet blir 21.

=(5+2)*3

I exemplet nedan gör parenteserna runt den första delen av formeln att Excel först beräknar B4+25 och dividerar resultatet med summan av värdena i cell D5, E5 och F5.

=(B4+25)/SUMMA(D5:F5)

Titta på den här videon om operatörsordning i Excel om du vill veta mer.

Hur Excel konverterar värden i formler

När du anger en formel Excel specifika typer av värden för varje operator. Om du anger en annan typ av värde än förväntat Excel värdet.

Formeln

Ger

Förklaring

= "1"+"2"

3

När du använder ett plustecken (+) Excel förväntar sig tal i formeln. Även om citattecknen betyder att "1" och "2" är textvärden omvandlar Excel automatiskt textvärdena till tal.

= 1+"$4,00"

5

När en formel förväntar sig ett tal Excel text om den är i ett format som normalt accepteras för ett tal.

= "2001-06-01"-"2001-05-01"

31

Excel tolkar texten som ett datum i formatet mm/dd/yyyy, konverterar datumen till serienummer och beräknar sedan skillnaden mellan dem.

=ROT ("8+1")

#VÄRDEFEL!

Excel kan inte konvertera texten till ett tal eftersom texten "8+1" inte kan konverteras till ett tal. Du kan använda "9" eller "8"+"1" i stället för "8+1" för att konvertera texten till ett tal och returnera resultatet 3.

= "A"&SANT

ATRUE

När text förväntas omvandlar Excel tal och logiska värden som SANT och FALSKT till text.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community eller få support i Answers-communityn.

Se även

Behöver du mer hjälp?

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

×