Tips: Prova att använda den nya funktionen XLOOKUP, en förbättrad version av VLOOKUP som fungerar i valfri riktning och returnerar exakta matchningar som standard, vilket gör det enklare och mer praktiskt att använda än föregående.

Använd LETARAD när du behöver hitta saker i en tabell eller ett område efter rad. Du kan till exempel slå upp ett pris på en reservdel till en bil efter artikelnumret, eller söka efter namnet på en medarbetare baserat på medarbetar-ID:t.

I sin enklaste form anger LETARAD-funktionen:

=LETARAD(Det du vill slå upp, var du vill söka efter det, kolumnnumret i området som innehåller värdet som ska returneras, returnera en ungefärlig eller exakt matchning – som anges som 1/SANT eller 0/FALSKT).

Din webbläsare har inte stöd för video. Installera Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

Tips: Hemligheten med LETARAD är att ordna data så att värdet du slår upp (Frukt) är till vänster om returvärdet (Belopp) du vill hitta.

Använda funktionen LETARAD till att slå upp ett värde i en tabell.

Syntax 

LETARAD (letauppvärde; tabellmatris; kolumnindex; [ungefärlig])

Till exempel:

  • =LETARAD(A2;A10:C20;2;SANT)

  • =LETARAD( "Färnstrand";B2:E7;2;FALSKT)

  • =LETARAD(A2;"Klientinformation"! A:F,3,FALSKT)

Argumentnamn

Beskrivning

letauppvärde    (obligatoriskt)

Det värde du vill slå upp. Det värde du vill slå upp måste finnas i den första kolumnen i cellintervallet du anger i argumentet tabellmatrisen.

Om tabellmatrisen exempelvis omfattar tabellerna B2:D7 måste det värde du vill ha fram, ditt letauppvärde, finnas i kolumn B.

letauppvärde kan vara ett värde eller en referens till en cell.

tabellmatris    (obligatoriskt)

Det cellintervall där LETARAD söker efter letauppvärde och returvärde. Du kan använda ett namngivet område eller en tabell och du kan använda namn i argumentet i stället för cellreferenser. 

Den första kolumnen i cellintervallet måste innehålla ditt letauppvärde. Cellområdet måste också innehålla det returvärde som du vill hitta.

Lär dig hur du markerar områden i ett kalkylblad.

kolumnindex    (obligatoriskt)

Kolumnnumret (med början på 1 för kolumnen längst till vänster i tabellmatrisen) som innehåller returvärdet.

ungefärlig   (valfritt)

Ett logiskt värde som anger om LETARAD ska söka efter en ungefärlig eller en exakt matchning.

  • MedUngefärlig matchning - 1/SANT antar du att den första kolumnen i tabellen är sorterad antingen numeriskt eller alfabetiskt och söker efter närmaste värde. Det här är den metod som används om du inte gör ett aktivt val av metod. Exempel: =LETARAD(90;A1:B100;2;SANT).

  • Med Exakt matchning – 0/FALSKTsöker du efter det exakta värdet i den första kolumnen. Exempel, =LETARAD("Smith",A1:B100,2,FALSKT).

Komma igång

Det finns fyra delar med information som du måste ordna när du skapar LETARAD-syntaxen:

  1. Värdet du vill slå upp, ett så kallat ”letauppvärde”.

  2. Området där värdet finns. Kom ihåg att ”letauppvärde” alltid bör finnas i den första kolumnen i området för att LETARAD ska kunna fungera på rätt sätt. Om ditt värde finns i cell C2 ska området börja med C.

  3. Kolumnnumret i området som innehåller returvärdet. Om du till exempel anger B2:D11 som område räknar du B som den första kolumnen, C som den andra osv.

  4. Alternativt kan du ange SANT om du vill ha en ungefärlig matchning eller FALSKT om du vill ha en exakt matchning för returvärdet. Om du inte anger någonting är standardvärdet alltid SANT, alltså en ungefärlig matchning.

Sammanställ nu allt ovanstående enligt följande:

=LETARAD(letauppvärde, området som innehåller värdet, kolumnnumret i området som innehåller returvärdet, ungefärlig matchning (SANT) eller Exakt matchning (FALSKT)).

Exempel

Här är några exempel på LETARAD:

Exempel

=LETARAD (B3,B2:E7,2,FALSKT)

LETARAD söker efter Fontana i den första kolumnen (kolumn B) i table_array B2:E7 och returnerar Olivier från den andra kolumnen (kolumn C) i tabellmatris.  Falskt returnerar en exakt matchning.

Exempel 2

=LETARAD (102,A2:C7,2,FALSKT)

LETARAD söker efter en exakt matchning (FALSKT) av efternamnet för 102 (letauppvärde) i den andra kolumnen (kolumn B) i A2:C7-området och returnerar Fontana.

Exempel 3

=OM(LETARAD(103;A1:E7;2;FALSKT)="Souse";"Finns";"Hittades inte")

OM kontrollerar om LETARAD returnerar Sousa som efternamn för medarbetarens korrelering till 103 (letauppvärde) i A1:E7 (tabellmatris). Eftersom efternamnet som motsvarar 103 är Leal är villkoret OM falskt och Hittades inte.

Exempel 4

=INT(YEARFRAC(DATE(2014,6,30),LETARAD(105,A2:E7,5,FLASE),1))



LETARAD söker efter födelsedatumet för medarbetaren som motsvarar 109 (letauppvärde) i A2:E7-intervallet (tabellmatris) och returnerar 03/04/1955. Sedan subtraherar YEARFRAC detta födelsedatum från 2014/6/30 och returnerar ett värde som sedan konverteras av INY till heltal 59.

Exempel 5

OM(ISNA(LETARAD(105,A2:E7,2,FLASE))=SANT,"Anställd hittades inte",LETARAD(105,A2:E7,2,FALSKT))



OM kontrollerar om LETARAD returnerar ett värde för efternamn från kolumn B för 105 (letauppvärde). Om LETARAD hittar ett efternamn visar OM efternamnet, annars returnerar OM Anställd hittades inte. ISNA kontrollerar att om LETARAD returnerar #N/A ersätts felet med Anställd som inte hittas i stället för #N/A.



I det här exemplet är returvärdet Burke, som är efternamnet som motsvarar 105.

Du kan använda LETARAD för att kombinera flera tabeller till en, så länge en av tabellerna har gemensamma fält med alla andra. Detta kan vara särskilt användbart om du behöver dela en arbetsbok med personer som har äldre versioner av Excel som inte stöder datafunktioner med flera tabeller som datakällor; genom att kombinera källorna i en tabell och ändra datafunktionens datakälla till den nya tabellen kan datafunktionen användas i äldre Excel-versioner (förutsatt att själva datafunktionen stöds av den äldre versionen).

Ett kalkylblad med kolumner som använder LETARAD för att hämta data från andra tabeller

Här har kolumnerna A-F och H värden eller formler som bara använder värden i kalkylbladet, och resten av kolumnerna använder LETARAD och värdena i kolumn A (Klientkod) och kolumn B (Advokat) för att hämta data från andra tabeller.

  1. Kopiera tabellen som innehåller de gemensamma fälten till ett nytt kalkylblad och ge den ett namn.

  2. Klicka på Data > Dataverktyg > Relationer för att öppna dialogrutan Hantera relationer.

    Dialogrutan Redigera relationer
  3. Observera följande för varje relation i listan:

    • Fältet som länkar tabellerna (visas inom parentes i dialogrutan). Det här är letauppvärdet för LETARAD-formeln.

    • Namnet på den relaterade uppslagstabellen. Det här är tabellmatrisen i letaradformeln.

    • Fältet (kolumnen) i den relaterade uppslagstabellen som innehåller de data du vill ha i den nya kolumnen. Den här informationen visas inte i dialogrutan Hantera relationer: du måste titta på den relaterade uppslagstabellen för att se vilket fält du vill hämta. Du vill anteckna kolumnnumret (A=1) – det här är col_index_num i formeln.

  4. Om du vill lägga till ett fält i den nya tabellen anger du letaradformeln i den första tomma kolumnen med den information du samlade in i steg 3.

    I vårt exempel använder kolumn G Advokat (lletauppvärdet) för att hämta fakturor från den fjärde kolumnen (col_index_num = 4) från kalkylbladstabellen Advokater, tblAttorneys ( table_array), med formeln =LETARAD([@Attorney],tbl_Attorneys,4,FALSKT).

    Formeln kan också använda en cellreferens och en områdesreferens. I vårt exempel skulle det vara =LETARAD(A2;"Advokater"! A:D,4,FALSKT).

  5. Fortsätt att lägga till fält tills du har alla fält som du behöver. Om du försöker förbereda en arbetsbok som innehåller datafunktioner som använder flera tabeller ändrar du datakällan för datafunktionen till den nya tabellen.

Problem

Vad gick fel

Fel värde returneras

Om ungefärlig är SANT eller utelämnas måste den första kolumnen sorteras alfabetiskt eller numeriskt. Om den första kolumnen inte är sorterad kan värdet som returneras bli något du inte väntar dig. Sortera den första kolumnen eller använd FALSKT så att du får en exakt matchning.

#SAKNAS i cell

  • Om ungefärlig är SANT och värdet i letauppvärde är mindre än det minsta värdet i den första kolumnen i tabell får du felvärdet #SAKNAS.

  • Om ungefärlig är FALSKT visar felvärdet #SAKNAS att det exakta talet inte hittas.

Mer information om hur du löser #SAKNAS-fel i LETARAD finns i Så här korrigerar du ett #SAKNAS!-fel i funktionen LETARAD.

#REFERENS! i cell

Om kolumnindex är större än antalet kolumner i tabellmatris får du felvärdet #REFERENS!.

Mer information om hur du löser #REFERENS!-fel i LETARAD finns i Så här korrigerar du #REFERENS!-fel.

#VÄRDEFEL! i cell

Om tabellmatris är mindre än 1 får du felvärdet #VÄRDEFEL!.

Mer information om hur du löser #VÄRDEFEL!-fel i LETARAD finns i Så här korrigerar du ett #VÄRDEFEL!-fel i funktionen LETARAD.

#NAMN? i cell

Felvärdet #NAMN? innebär ofta att citattecken saknas i formeln. För att leta upp en persons namn kontrollerar du att du använder citattecken runt namnet i formeln. Till exempel kan du ange namnet som "Färnstrand" i =LETARAD("Färnstrand";B2:E7;2;FALSKT).

Mer information finns i Korrigera #NAMN?-fel..

Felet #SPILL! i cell

Det här specifika #SPILL!-felet innebär vanligtvis att formeln förlitar sig på implicit skärningspunkt för uppslagsvärdet och att en hel kolumn används som referens. Exempel: =LETARAD(A:A;A:C;2;FALSKT). Du kan lösa problemet genom att fästa uppslagsreferensen med @-operatorn så här: =LETARAD(@A:A,A:C,2,FALSKT). Alternativt kan du använda den traditionella LETARAD-metoden och referera till en enda cell i stället för en hel kolumn: =LETARAD(A2;A:C;2;FALSKT).

Gör du så här

Varför

Använd absoluta referenser för ungefärlig

Med hjälp av absoluta referenser kan du skriva en formel så att den alltid gäller exakt samma uppslagsområde.

Lär dig hur du använder absoluta cellreferenser.

Förvara inte nummer och datumvärden som text.

Se till att informationen i den första kolumnen i tabellmatris inte lagras som textvärden när du söker efter nummer eller datumvärden. I så fall kan LETARAD returnera ett felaktigt eller oväntat värde.

Sortera den första kolumnen

Sortera den första kolumnen i tabellmatris innan du använder LETARAD när ungefärlig är SANT.

Använda jokertecken

Om ungefärlig är FALSKT och letauppvärde är text, kan du använda jokertecken – frågetecken (?) och asterisk (*) – i letauppvärde. Ett frågetecken motsvarar valfritt enstaka tecken. En asterisk matchar en obestämd teckensekvens. Om du vill söka efter ett frågetecken eller en asterisk skriver du ett tilde ( ~) framför tecknet.

Till exempel söker =LETARAD("Fontan?",B2:E7,2,FALSKT) efter alla instanser av Fontana med en sista bokstav som kan variera.

Kontrollera att dina data inte innehåller felaktiga tecken.

Kontrollera att informationen i den första kolumnen inte innehåller några inledande blanksteg, avslutande blanksteg, inkonsekvent användning av raka (' eller ") eller typografiska (‘ eller “) citattecken eller icke utskrivbara tecken när du söker efter textvärden i den första kolumnen. Annars kan LETARAD returnera ett oväntat värde.

För att få korrekt resultat kan du prova att använda funktionen STÄDA eller funktionen RENSA för att ta bort avslutande blanksteg efter tabellvärden i en cell.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community eller få support i Answers-communityn.

Mer information finns i

Snabbreferens: LETARAD-uppdatering
Snabbreferens: Felsökningstips för LETARAD
Så här korrigerar du ett #VALUE!-fel i funktionen LETARAD
Så här korrigerar du felet #SAKNAS! i funktionen LETARAD
Översikt över formler i Excel
Hur du undviker felaktiga formler
Upptäcka fel i formler
Excel-funktioner (alfabetisk ordning)
Excel-funktioner (efter kategori)
LETARAD (gratis smakprov)

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Gå med i Microsoft Office Insiders

Hade du nytta av den här informationen?

Hur nöjd är du med språkkvaliteten?
Vad påverkade din upplevelse?

Tack för din feedback!

×