Funktionen LETARAD

Tips: Prova att använda den nya funktionen XLOOKUP, en förbättrad version av LETARAD som fungerar i valfri riktning och returnerar exakta matchningar som standard, vilket gör det enklare och mer praktiskt att använda än föregående.

Använd LETARAD när du behöver hitta saker i en tabell eller ett område efter rad. Du kan till exempel slå upp priset på en bildel efter deltidsnumret eller hitta en anställds namn baserat på deras anställnings-ID.

Tips: Kolla in de här YouTube-videorna från Microsoft Creators om du vill ha mer hjälp med LETARAD!

I sin enklaste form anger LETARAD-funktionen:

=LETARAD(Det du vill slå upp, där du vill leta efter det, kolumnnumret i området som innehåller värdet som ska returneras, en ungefärlig eller exakt matchning – anges som 1/SANT eller 0/FALSKT).

Din webbläsare har inte stöd för video.

Tips: Hemligheten med LETARAD är att ordna data så att värdet du slår upp (Frukt) är till vänster om returvärdet (Belopp) du vill hitta.

Använda funktionen LETARAD till att slå upp ett värde i en tabell.

Syntax

LETARAD (letauppvärde; tabellmatris; kolumnindex; [ungefärlig])

Till exempel:

  • =LETARAD(A2;A10:C20;2;SANT)

  • =LETARAD( "Färnstrand";B2:E7;2;FALSKT)

  • =LETARAD(A2;'Klientinformation'! S:F,3;FALSKT)

Argumentnamn

Beskrivning

letauppvärde    (obligatoriskt)

Det värde du vill slå upp. Det värde du vill slå upp måste finnas i den första kolumnen i cellområdet som du anger i argumentet table_array värde.

Om tabellmatrisen exempelvis omfattar cellerna B2:D7 måste lookup_value i kolumn B.

letauppvärde kan vara ett värde eller en referens till en cell.

tabellmatris    (obligatoriskt)

Det cellintervall där LETARAD söker efter letauppvärde och returvärde. Du kan använda ett namngivet område eller en tabell, och du kan använda namn i argumentet i stället för cellreferenser. 

Den första kolumnen i cellområdet måste innehålla lookup_value. Cellområdet måste också omfatta det returvärde du vill hitta.

Lär dig hur du markerar områden i ett kalkylblad.

kolumnindex    (obligatoriskt)

Kolumnnumret (som börjar med 1 i kolumnen mest till vänster table_array)som innehåller returvärdet.

ungefärlig   (valfritt)

Ett logiskt värde som anger om LETARAD ska söka efter en ungefärlig eller en exakt matchning.

  • Ungefärlig matchning – 1/SANT förutsätter att den första kolumnen i tabellen är sorterad antingen numeriskt eller alfabetiskt och söker sedan efter närmaste värde. Det här är den metod som används om du inte gör ett aktivt val av metod. Exempel: =LETARAD(90;A1:B100;2;SANT).

  • Exakt matchning – 0/FALSKT söker efter det exakta värdet i den första kolumnen. Exempel: =LETARAD("Svensson";A1:B100;2;FALSKT).

Komma igång

Det finns fyra delar med information som du måste ordna när du skapar LETARAD-syntaxen:

  1. Värdet du vill slå upp, ett så kallat ”letauppvärde”.

  2. Området där värdet finns. Kom ihåg att ”letauppvärde” alltid bör finnas i den första kolumnen i området för att LETARAD ska kunna fungera på rätt sätt. Om ditt värde finns i cell C2 ska området börja med C.

  3. Kolumnnumret i området som innehåller returvärdet. Om du till exempel anger B2:D11 som område räknar du B som den första kolumnen, C som den andra osv.

  4. Alternativt kan du ange SANT om du vill ha en ungefärlig matchning eller FALSKT om du vill ha en exakt matchning för returvärdet. Om du inte anger någonting är standardvärdet alltid SANT, alltså en ungefärlig matchning.

Sammanställ nu allt ovanstående enligt följande:

=LETARAD(letauppvärde, område som innehåller uppslagsvärdet, kolumnnumret i området som innehåller returvärdet, Ungefärlig matchning (SANT) eller Exakt matchning (FALSKT)).

Exempel

Här är några exempel på LETARAD:

Exempel

LETARAD – exempel 1

Exempel 2

LETARAD – exempel 2

Exempel 3

LETARAD – exempel 3

Exempel 4

LETARAD – exempel 4

Exempel 5

LETARAD – exempel 5

Du kan använda LETARAD för att kombinera flera tabeller till en, så länge en av tabellerna har fält gemensamt med alla andra. Det kan vara särskilt användbart om du behöver dela en arbetsbok med personer som har äldre versioner av Excel som inte har stöd för datafunktioner med flera tabeller som datakällor – genom att kombinera källorna till en tabell och ändra datafunktionens datakälla till den nya tabellen, kan datafunktionen användas i äldre Excel-versioner (förutsatt att själva datafunktionen stöds av den äldre versionen).

Ett kalkylblad med kolumner som använder LETARAD för att hämta data från andra tabeller

Här har kolumnerna A–F och H värden eller formler som bara använder värden i kalkylbladet, och i resten av kolumnerna används LETARAD och värdena i kolumn A (Klientkod) och kolumn B (jurist) för att hämta data från andra tabeller.

  1. Kopiera den tabell som innehåller de gemensamma fälten till ett nytt kalkylblad och ge den ett namn.

  2. Klicka > dataverktyg > relationer för att öppna dialogrutan Hantera relationer.

    Dialogrutan Hantera relationer
  3. Observera följande för varje relation som listas:

    • Det fält som länkar tabellerna (visas inom parentes i dialogrutan). Det här är lookup_value för LETARAD-formeln.

    • Namnet Relaterad uppslagstabell. Det här är table_array formel i LETARAD.

    • Fältet (kolumnen) i den relaterade uppslagstabellen som innehåller de data du vill ha i den nya kolumnen. Den här informationen visas inte i dialogrutan Hantera relationer – du måste titta i tabellen Relaterad uppslag för att se vilket fält du vill hämta. Du vill anteckna kolumnnumret (A=1) – det här är col_index_num i formeln.

  4. Om du vill lägga till ett fält i den nya tabellen anger du LETARAD-formeln i den första tomma kolumnen med informationen du hämtade i steg 3.

    I vårt exempel använder kolumn G Jurist (lookup_value)för att hämta data om fakturaräntan från den fjärde kolumnen(col_index_num = 4) från tabellen Jurister i kalkylbladet, tblAttorneys (table_array),med formeln =LETARAD([@Attorney],tbl_Attorneys,4,FALSKT).

    Formeln kan också använda en cellreferens och en områdesreferens. I vårt exempel skulle det vara =LETARAD(A2;'Jurister'! A:D,4,FALSE).

  5. Fortsätt att lägga till fält tills du har alla fält som du behöver. Om du försöker förbereda en arbetsbok som innehåller datafunktioner som använder flera tabeller ändrar du datakällan för datafunktionen till den nya tabellen.

Problem

Vad gick fel

Fel värde returneras

Om ungefärlig är SANT eller utelämnas måste den första kolumnen sorteras alfabetiskt eller numeriskt. Om den första kolumnen inte är sorterad kan värdet som returneras bli något du inte väntar dig. Sortera den första kolumnen eller använd FALSKT så att du får en exakt matchning.

#SAKNAS i cell

  • Om ungefärlig är SANT och värdet i letauppvärde är mindre än det minsta värdet i den första kolumnen i tabell får du felvärdet #SAKNAS.

  • Om ungefärlig är FALSKT visar felvärdet #SAKNAS att det exakta talet inte hittas.

Mer information om hur du löser #SAKNAS-fel i LETARAD finns i Så här korrigerar du ett #SAKNAS!-fel i funktionen LETARAD.

#REFERENS! i cell

Om kolumnindex är större än antalet kolumner i tabellmatris får du felvärdet #REFERENS!.

Mer information om hur du löser #REFERENS!-fel i LETARAD finns i Så här korrigerar du #REFERENS!-fel.

#VÄRDEFEL! i cell

Om tabellmatris är mindre än 1 får du felvärdet #VÄRDEFEL!.

Mer information om hur du löser #VÄRDEFEL!-fel i LETARAD finns i Så här korrigerar du ett #VÄRDEFEL!-fel i funktionen LETARAD.

#NAMN? i cell

Felvärdet #NAMN? innebär ofta att citattecken saknas i formeln. För att leta upp en persons namn kontrollerar du att du använder citattecken runt namnet i formeln. Till exempel kan du ange namnet som "Färnstrand" i =LETARAD("Färnstrand";B2:E7;2;FALSKT).

Mer information finns i Korrigera #NAMN?-fel..

Felet #SPILL! i cell

Just det #SPILL! Innebär vanligtvis att formeln förlitar sig på implicit skärningspunkt för uppslagsvärdet och att en hel kolumn används som referens. Till exempel =LETARAD(A:A;A:C;2;FALSKT). Du kan lösa problemet genom att fästa uppslagsreferensen med @-operatorn så här: =LETARAD(@A:A,A:C,2,FALSKT). Alternativt kan du använda den traditionella METODEN LETARAD och referera till en enskild cell i stället för en hel kolumn:=LETARAD( A2,A:C,2,FALSKT).

Gör du så här

Varför

Använd absoluta referenser för ungefärlig

Med hjälp av absoluta referenser kan du skriva en formel så att den alltid gäller exakt samma uppslagsområde.

Lär dig hur du använder absoluta cellreferenser.

Förvara inte nummer och datumvärden som text.

Se till att informationen i den första kolumnen i tabellmatris inte lagras som textvärden när du söker efter nummer eller datumvärden. I så fall kan LETARAD returnera ett felaktigt eller oväntat värde.

Sortera den första kolumnen

Sortera den första kolumnen i tabellmatris innan du använder LETARAD när ungefärlig är SANT.

Använda jokertecken

Om ungefärlig är FALSKT och letauppvärde är text, kan du använda jokertecken – frågetecken (?) och asterisk (*) – i letauppvärde. Ett frågetecken motsvarar valfritt enstaka tecken. En asterisk matchar en obestämd teckensekvens. Om du vill söka efter ett frågetecken eller en asterisk skriver du ett tilde ( ~) framför tecknet.

Exempel: =LETARAD("Fontan?",B2:E7,2,FALSKT) söker efter alla förekomster av Fontana med en sista bokstav som kan variera.

Kontrollera att dina data inte innehåller felaktiga tecken.

Kontrollera att informationen i den första kolumnen inte innehåller några inledande blanksteg, avslutande blanksteg, inkonsekvent användning av raka (' eller ") eller typografiska (‘ eller “) citattecken eller icke utskrivbara tecken när du söker efter textvärden i den första kolumnen. Annars kan LETARAD returnera ett oväntat värde.

För att få korrekt resultat kan du prova att använda funktionen STÄDA eller funktionen RENSA för att ta bort avslutande blanksteg efter tabellvärden i en cell.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Mer information finns i

Snabbreferens: UPPDATERA LETARAD
Snabbreferens: Felsökningstips för LETARAD
YouTube: LETARAD-videor från Microsoft Creators
Korrigera ett #VALUE! i funktionen LETARAD
Så här korrigerar du felet #SAKNAS! i funktionen LETARAD
Översikt över formler i Excel
Hur du undviker felaktiga formler
Upptäcka fel i formler
Excel-funktioner (alfabetisk ordning)
Excel-funktioner (efter kategori)
LETARAD (gratis smakprov)

Behöver du mer hjälp?

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×