Skriva och redigera

Kontrollera grammatik, stavning och mycket mer i Word

Kontrollera grammatik, stavning och mycket mer i Word

Microsoft Editor körs i Word för Microsoft 365 för att analysera ditt dokument och ge förslag på stavning, grammatik och stilistiska problem, t. ex. göra meningarna mer koncisa, välja enklare ord eller skriva med mer formellt.

Om du vill använda Editor går du till fliken Start och väljer Editor.

Välj Editor på fliken Start eller tryck på F7 för att öppna Editor-fönstret.

Granska förslag

Om du vill fokusera på de problem du bryr dig om väljer du en korrigering eller en typ av förfining, t. ex. Grammatik eller Tydlighet. Använd sedan pilarna högst upp i fönstret för att stega igenom vart och ett av dessa problem.

Flytta direkt från ett problem till nästa överst i Editor-fönstret.

Välj ett förslag för att infoga det i dokumentet. Om du inte gillar förslaget väljer du Ignorera en gång. Om du aldrig vill använda den här typen av förslag väljer du Kontrollera inte för detta problem.

Obs!: Om du ändrar dig angående ett problem som du ignorerat stänger du dokumentet, öppnar det igen och går tillbaka till Editor. Editor hittar problemet igen.

Skräddarsy Editor ska kontrollera 

Som standard söker Editor efter flera olika kategorier av problem och det kan hända att förslagen inte passar för ditt sätt att skriva. Gör så här om du vill göra det möjligt att finjustera Editor och få förslag du vill ha:

  1. I fönstret Editor väljer du Inställningar.
    I fönstret Editor väljer du Inställningar.

  2. I dialogrutan Word-alternativ, intill Grammatik och finjusteringar, väljer du Inställningar.
    Välj Inställningar i dialogrutan Word-alternativ, bredvid Grammatik och finjusteringar

  3. Bläddra igenom listan med alternativ. Välj vilka problem du vill att Editor ska kontrollera och avmarkera de problem som du vill att Editor ska ignorera.

    Obs!: Om du väljer Återställ alla återgår du till standardinställningarna.

  4. Välj OK.

Tips: Editor är utformad för att ge dig möjlighet att ta fram det bästa för ditt sätt att skriva. Vi uppdaterar kontinuerligt förslagen och experiment för att lära oss mer om vilka förslag som är de bästa. Om du har feedback till oss väljer du Hjälpa till att förbättra Office? högst upp i Word-fönstret för att öppna feedback-fönstret.
Välj Hjälp till att förbättra Office? ikonen längst upp i Word-fönstret för att öppna feedback-fönstret.

Du kanske märker att Editors röda, blå och lila understrykningar visas i dokumentet även när Editor-fönstret är stängt. Det beror på att Editor alltid körs i bakgrunden och kontrollerar stavning, grammatik och vissa stilproblem.

Högerklicka på den understrukna texten om du vill se förslag. Använd snabbmenyn för att:

  • Lyssna på förslaget genom att klicka på pilen bredvid förslaget och sedan välja Uppläsning.

  • Hoppa över den här förekomsten av problemet genom att välja Ignorera en gång.

  • Meddela Editor att sluta söka efter problemet genom att välja Kontrollera inte problemet.

  • Finjustera inställningarna för den här typen av problem genom att välja länken Alternativ.

  • Om du vill ha mer information om problemet väljer du Se mer.

Snabbmenyn i Editor ger dig flera alternativ för det aktuella förslaget.

Ditt dokument kanske är skrivet på mer än ett språk, eller så kanske du vill växla till ett annat språk som Editor ska kontrollera. Om du har konfigurerat för att använda flera redigeringsspråk (Arkiv > Alternativ > Språk), känner Word igen det språk som du skriver på och Editor söker efter problem på det språket.

Men du kanske skriver på ett språk som Word inte känner igen automatiskt. I så fall kan du få Editor att kontrollera text på det språket genom att markera texten och gå till Granska > Språk > Ange språk för språkkontrolloch sedan välja språk.

Välj Ange språk för språkkontroll i menyn Språk på fliken Granska.

När Editor kontrollerar fler än ett språk visas korrigeringar och finjusteringar för varje språk i dokumentet i Editor-fönstret. 

Korrigeringar och finjusteringar anges per språk i Editor-fönstret.

Om du vill ha mer information om de problem som Editor kontrollerar på olika språk kan du läsa Tillgänglighet av stavning, grammatik och finjustering i Editor efter språk.

När du arbetar med dokument i Word på webben får du en omfattande uppsättning funktioner som kommer snart till Word för Windows. Även om du inte använder Word kan du med hjälp Editor-tillägget för webbläsare hjälpa dig att skriva på webbplatser som LinkedIn, Twitter, Facebook och Gmail.

När du arbetar med en CV söker Editor efter problem som referens till den första personen, vaga verb, olämpliga uttryck och mycket mer.

  1. Gå till Granska > CV-assistenten.

  2. Ange Roll och Bransch. Längst ned i fönstret CV-assistenten kan du aktivera eller inaktivera Editors CV-kontroll.

    Visa växling Editor för CV-assistenten
Få stor påverkan med meddelanden

Tips: Är inte videon på ditt språk? Prova att välja Textning Knappen för dold textning .

Word markerar stavnings-, grammatiska och stilistiska problem med en understrykning. Högerklicka på det understrukna ordet och välj det förslag som du vill använda eller läs mer om felet och hur du åtgärdar det.

Du kan också öppna Editor-fönstret för att lösa problem utifrån kategori.

  1. På fliken Granska väljer du Kontrollera dokument.

    Visar Kontrollera dokument under fliken Granska
  2. Fönstret Editor kategoriserar stavnings-, grammatiska och stilistiska problem.

    Visar översikt över problem i språkkontrollen
  3. Åtgärda problemet genom att klicka på varje kategori.

    Obs!: Du behöver inte trycka på Alt för kortkommandon i Editor-fönstret. Använd bara den understrukna bokstaven för att välja kommandot (till exempel i för Ignorera en gång,g för Ignorera allao.s.v.).

  1. Gå till fönstret Editor och klicka på Inställningar.

  2. Välj Inställningar under Vid stavnings- och grammatikkontroll i Word.

  3. För Skrivstilväljer du Grammatik och finjusteringar.

  4. Bläddra nedåt för att se alla tillgängliga alternativ och markera eller avmarkera de regler som du vill använda. Inställningarna tillämpas på alla dokument som du redigerar, inte bara det aktuella.

Kraven och tillgängligheten för Editor-fönstret inkluderar följande:

Word markerar stavnings-, grammatiska och stilistiska problem med en understrykning. Ctrl-klicka på ordet eller frasen och välj ett av alternativen.

Om ett ord felaktigt har markerats som felstavat och du vill lägga till ordet i ordlistan så att Word känner igen det i framtiden läser du Lägga till och redigera ord i en ordlista för stavningskontroll

Om stavfel eller språkliga fel inte markeras kan det hända att du måste aktivera den automatiska stavnings- och grammatikkontrollen. 

Aktivera och inaktivera den automatiska stavnings- och grammatikkontrollen

  1. På menyn Word klickar du på Inställningar > Stavning och grammatik.

  2. I dialogrutan Stavning och grammatik under Stavning, markerar eller avmarkerar du kryssrutan Kontrollera stavning medan du skriver.

  3. Under Grammatik markerar eller avmarkerar du kryssrutan Kontrollera grammatik medan du skriver.

  4. Stäng dialogrutan för att spara ändringarna.

  1. Klicka på Stavning och grammatik på fliken Granska.

  2. Word visas de problem den hittar i dialogrutan Stavning och grammatik.

  3. Åtgärda problemet genom att göra något av följande:

    • Ange korrigering i rutan och klicka sedan på Ändra.

    • Under Förslag klickar du på ordet du vill använda och sedan på Ändra.

    Hoppa över felet genom att göra något av följande:

    • Klicka på Ignorera en gång om du vill hoppa över felet en gång.

    • Klicka på Ignorera alla om du vill hoppa över alla förekomster av felet.

    • Om det är ett språkligt fel klickar du på Nästa mening för att hoppa över den förekomsten av felet och flytta till nästa fel.

    Om du vill hoppa över ett felstavat ord i alla dokument klickar du på Lägg till för att lägga till det i ordlistan. Det här fungerar bara för stavningskontroll. Du kan inte lägga till anpassad grammatik i ordlistan.

  4. När du har rättat, ignorerat eller hoppat över ett fel går Word vidare till nästa. När Word har avslutat granskningen av dokumentet visas ett meddelande om att stavnings- och grammatikkontrollen är klar.

  5. Klicka på OK för att återgå till dokumentet.

Du kan rensa eller återställa listan med ignorerade ord och grammatikregler så att Word kontrollerar stavning och grammatik du tidigare angett ska ignoreras.

Obs!: När du återställer listan med ignorerade ord rensas listan bara för det dokument du har öppet. Inga stavfel eller grammatiska problem du angett att Word ska ignorera i andra dokument påverkas.

  1. Öppna det dokument som du vill kontrollera.

  2. På menyn Verktyg pekar du på Stavning och grammatik och klickar sedan på Återställ ignorerade ord och grammatikregler.

    Rensa listorna över ord och grammatikregler som ignoreras i Word genom att klicka på Återställ ignorerade ord och grammatikregler.

    En varning visas om att åtgärden återställer stavnings- och grammatikkontrollen.

    Gör så att Word kontrollerar stavning och grammatik som du tidigare angav att Word skulle ignorera genom att klicka på Ja.
  3. Klicka på Ja för att fortsätta.

  4. Klicka på fliken Granska och sedan på Stavning och grammatik om du vill kontrollera stavning och grammatik.

I Word markeras potentiella stavfel med en röd, vågig linje och möjliga grammatiska fel med en blå, vågig linje.

Högerklicka på det understrukna ordet eller frasen och välj en korrigering eller ignorera förslaget.

Obs!: Om Word flaggar ord som felstavade men stavningen är som du vill ha det väljer du Lägg till i ordlista för att lära Word att inte flagga det ordet som felstavat i framtiden. Mer information om detta finns i: Lägg till och redigera ord i en ordlista för stavningskontroll.

Om du inte vill att Office ska markera möjliga fel med vågiga linjer medan du arbetar kan du inaktivera den automatiska stavnings- och grammatikkontrollen:

  1. Klicka på AlternativArkiv-menyn och klicka sedan på Språkkontroll.

  2. Markera eller avmarkera kryssrutorna Kontrollera stavning medan du skriver och Markera grammatikfel medan du skriver.

    Kryssrutan Kontrollera stavning medan du skriver

    Obs!: Du kan aktivera eller inaktivera stavningskontrollen för dokumentet du arbetar med eller för alla nya dokument. Välj ett alternativ i listan Undantag för och markera eller avmarkera kryssrutorna Dölj stavfel endast i det här dokumentet och Dölj grammatiska fel endast i det här dokumentet.

Om du inte vill att Word ska kontrollera grammatik alls (när du kör en stavningskontroll eller automatiskt medan du skriver) kan du inaktivera den:

  1. Klicka på AlternativArkiv-menyn och klicka sedan på Språkkontroll.

  2. Avmarkera kryssrutorna Markera grammatikfel medan du skriver och Kontrollera grammatik och stavning.

    Kryssrutor för grammatik

  1. På menyn Arkiv klickar du på Alternativ > Språkkontroll > Kontrollera igen.

  2. Klicka på Ja när du ser varningsmeddelandet om att återställa stavnings- och grammatikkontrollen.

  3. Klicka på OK i dialogrutan för att gå tillbaka till dokumentet och sedan köra stavnings- och grammatikkontrollen igen.

Se även

Mer information om Microsoft Editor finns i Microsoft Editor kontrollerar grammatik och mer i dokument, e-post och webben.

Mer ämnen om stavning och grammatik finns i Stavning och grammatik i Word

Behöver du mer hjälp?

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×