#REFERENS!-felet visas när en formel refererar till en cell som inte är giltig. Det här händer oftast när celler som formler refererar till tas bort eller klistras över.

Exempel – #REF! som orsakas av att en kolumn har tagits bort

I följande exempel används formeln =SUMMA(B2,C2,D2) i kolumnen E.

En formel som använder uttryckliga cellreferenser, t.ex. =SUMMA(B2,C2,D2) kan orsaka ett #REFERENS!-fel om en kolumn tas bort.

Om du skulle ta bort kolumn B, C eller D skulle det orsaka #REF! fel. I det här fallet tar vi bort kolumn C (Försäljning 2007) och formeln läser nu =SUMMA(B2,#REF!,C2). När du använder uttryckliga cellreferenser som detta (där du refererar varje cell separat, avgränsad med kommatecken) och tar bort en refererad rad eller kolumn så kan Excel inte lösa det, så det returnerar #REF! fel. Det här är den primära orsaken till att vi inte rekommenderar att du använder explicita cellreferenser i funktioner.

Exempel på #REF! som orsakas av att en kolumn har tagits bort.

Lösning

  • Om du tar bort rader eller kolumner av misstag kan du återställa dem direkt genom att klicka på knappen Ångra i verktygsfältet Snabbåtkomst (eller trycka på CTRL+Z).

  • Justera formeln så att den använder en områdesreferens i stället för enskilda celler, t.ex. =SUMMA(B2:D2). Nu kan du ta bort valfri kolumn i summaområdet och Excel automatiskt justera formeln. Du kan också använda =SUMMA(B2:B5) för att summera rader.

Exempel – LETARAD med felaktiga områdesreferenser

I exemplet nedan returnerar =LETARAD(A8,A2:D5,5,FALSKT) ett #REFERENS!-fel eftersom formeln söker efter ett värde som ska returneras från kolumn 5, men referensområdet är A:D, dvs. bara 4 kolumner.

Exempel på en LETARAD-formel med ett felaktigt område.  Formeln är =LETARAD(A8;A2:D5;5;FALSKT).  Det finns ingen femte kolumn i LETARAD-området, så 5 orsakar en #REF! fel.

Lösning

Gör området större eller minska kolumnvärdet så att det matchar referensområdet. =LETARAD(A8,A2:E5,5,FALSKT) skulle vara ett giltigt referensområde, liksom = LETARAD(A8,A2:D5,4,FALSKT).

Exempel – INDEX med felaktig referens för rad eller kolumn

I det här exemplet returnerar formeln =INDEX(B2:E5,5,5) ett #REF! eftersom INDEX-området är 4 rader och 4 kolumner, men formeln ber dig returnera vad som finns i den femte raden och kolumnen 5.

Exempel på en INDEX-formel med en ogiltig områdesreferens.  Formeln är =INDEX(B2:E5,5,5), men området består endast av 4 rader och 4 kolumner.

Lösning

Justera rad- eller kolumnreferenserna så att de är inom INDEX-uppslagsområdet. =INDEX(B2:E5,4,4) returnerar ett giltigt resultat.

Exempel – refererar till en stängd arbetsbok med INDIREKT

I följande exempel försöker en INDIREKT-funktion referera till en arbetsbok som är stängd, vilket orsakar ett #REF! fel.

Exempel på en #REF! som orsakas av INDIREKT-referens till en stängd arbetsbok.

Lösning

Öppna den refererade arbetsboken. Samma fel uppstår om du refererar till en stängd arbetsbok med en dynamisk matrisfunktion.

OLE-problem

Om du har använt en OLE-länk (Object Linking and Embedding) som returnerar en #REF! och starta sedan programmet som länken anropar.

Obs! OLE är en teknik som du kan använda för att dela information mellan program.

DDE-problem

Om du har använt ett DDE-avsnitt (Dynamic Data Exchange) som returnerar ett #REF! kontrollerar du först att du refererar till rätt avsnitt. Om du fortfarande får en #REF! kontrollerar du att ditt Säkerhetscenter har Inställningar externt innehåll enligt beskrivningen i Blockera eller ta bort blockering av externt innehåll i Office dokument.

Obs! DDE (Dynamic Data Exchange)är ett protokoll för att utbyta data mellan Microsoft Windows-baserade program.

Makro-problem

Om ett makro anger en funktion i kalkylbladet som refererar till en cell ovanför funktionen, och cellen som innehåller funktionen finns på rad 1, returnerar funktionen #REF! eftersom det inte finns några celler ovanför rad 1. Kontrollera funktionen om ett argument refererar till en cell eller ett cellområde som inte är giltigt. Det kan kräva att du redigerar makrot Visual Basic VBE (VBE) för att ta hänsyn till den situationen.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community eller få support i Answers-communityn.

Se även

Översikt över formler i Excel

Hur du undviker felaktiga formler

Upptäck fel i formler

Excel-funktioner (alfabetisk ordning)

Excel-funktioner (efter kategori)

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Gå med i Microsoft Office Insiders

Hade du nytta av den här informationen?

Hur nöjd är du med språkkvaliteten?
Vad påverkade din upplevelse?

Tack för din feedback!

×