PRODUKTSUMMA (Funktionen PRODUKTSUMMA)

Funktionen PRODUKTSUMMA returnerar summan av produkterna i motsvarande områden eller matriser. Standardåtgärden är multiplikation, men addition, subtraktion och division är också möjliga.

I det här exemplet använder vi PRODUKTSUMMA för att returnera den totala försäljningen för ett visst objekt och storlek:

Exempel på användning av funktionen PRODUKTSUMMA för att returnera den totala försäljningen när den tillhandahålls med produktnamn, storlek och enskilda försäljningsvärden för varje produkt.

PRODUKTSUMMA matchar alla förekomster av objekt Y/Storlek M och summerar dem, så i det här exemplet är 21 plus 41 lika med 62.

Syntax

Så här använder du standardåtgärden (multiplikation):

=PRODUKTSUMMA(matris1; [matris2]; [matris3]; ...)

Syntaxen för funktionen PRODUKTSUMMA har följande argument:

Argument

Beskrivning

matris1   

Krävs

Det första matrisargument vars komponenter ska multipliceras och sedan adderas.

[matris2]; [matris3],...    

Valfri

De 2 till 255 matrisargument vars komponenter ska multipliceras och sedan adderas.

Så här utför du andra aritmetiska operationer

Använd PRODUKTSUMMA som vanligt, men ersätt de kommatecken som avgränsar matrisargumenten med de aritmetiska operatorerna som du vill använda (*, /, +, -). När alla åtgärder har utförts summeras resultatet som vanligt.

Obs!: Om du använder aritmetiska operatorer kan du omsluta matrisargumenten med parenteser och använda parenteser för att gruppera matrisargumenten för att styra ordningen på aritmetiska operationer.

Kommentarer

  • Matrisargumenten måste ha samma dimensioner. Om de inte gör det returnerar PRODUKTSUMMA #VALUE! felvärde. Till exempel returnerar =PRODUKTSUMMA(C2:C10;D2:D5) ett fel eftersom områdena inte har samma storlek.

  • PRODUKTSUMMA behandlar icke-numeriska matrisposter som om de vore nollor.

  • För bästa prestanda bör PRODUKTSUMMA inte användas med fullständiga kolumnreferenser. Överväg =PRODUKTSUMMA(A:A;B:B), här multiplicerar funktionen 1 048 576 celler i kolumn A med 1 048 576 celler i kolumn B innan de läggs till. 

Exempel

Exempel på funktionen PRODUKTSUMMA som används för att returnera summan av sålda artiklar när den angivna enhetskostnaden och antalet har angetts.

Om du vill skapa formeln med hjälp av exempellistan ovan skriver du =PRODUKTSUMMA(C2:C5,D2:D5) och trycker på Retur. Varje cell i kolumn C multipliceras med motsvarande cell på samma rad i kolumn D och resultatet adderas. Den totala summan för mat är 78,97 kr.

Om du vill skriva en längre formel som ger samma resultat skriver du =C2*D2+C3*D3+C4*D4+C5*D5 och trycker på Retur. När du trycker på Retur blir resultatet detsamma: $78,97. Cell C2 multipliceras med D2 och resultatet adderas till resultatet av cell C3 gånger cell D3 och så vidare.

Exempel 2

I följande exempel används PRODUKTSUMMA för att returnera den totala nettoförsäljningen per säljare, där vi har både den totala försäljningen och kostnaderna per agent. I det här fallet använder vi en Excel-tabell som använderstrukturerade referenser i stället för vanliga Excel-intervall. Här ser du att försäljning, utgifter och agentintervall refereras till efter namn.

Exempel på funktionen PRODUKTSUMMA för att returnera den totala försäljningen per säljare, när den tillhandahålls med försäljning och utgifter för varje produkt.

Formeln är: =PRODUKTSUMMA(((Tabell1[Försäljning])+(Tabell1[Kostnader]))*(Tabell1[Agent]=B8)) och returnerar summan av all försäljning och alla utgifter för agenten som finns i cell B8.

Exempel 3

I det här exemplet vill vi returnera summan av ett visst objekt som sålts av en viss region. I det här fallet hur många körsbär såldes i regionen Öst?

Exempel på hur DU använder PRODUKTSUMMA för att returnera summan av objekt per region. I det här fallet har antalet körsbär sålts i regionen Öst.

Formeln är: =PRODUKTSUMMA((B2:B9=B12)*(C2:C9=C12)*D2:D9). Först multipliceras antalet förekomster av öst med antalet matchande förekomster av körsbär. Slutligen summerar den värdena på motsvarande rader i kolumnen Försäljning. Om du vill se hur Excel beräknar detta markerar du formelcellen och går sedan till Formler > Utvärdera formel > Utvärdera.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community eller få support i Answers-communityn.

Se även

Utföra villkorsstyrda beräkningar på cellområden

Summera baserat på flera villkor med SUMMA.OMF

Räkna antal baserat på flera villkor med ANTAL.OMF

Medelvärde baserat på flera villkor med MEDEL.OMF

Behöver du mer hjälp?

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×