Så här korrigerar du felvärdet #VÄRDEFEL! i funktionen MEDEL eller SUMMA

Om medel eller summa refererar till celler som innehåller #VALUE! fel, formlerna leder till en #VALUE! #REF!.

Felvärdet #VÄRDEFEL! i MEDEL

För att förbise felvärdena skapar vi en formel som ignorerar fel i referensområdet när du beräknar medelvärdet med de återstående ”normala” värdena.

För att lösa det här problemet använder vi en kombination av MEDEL tillsammans med OM och ÄRFEL för att avgöra om det finns ett fel i det angivna området. Just detta scenario kräver en matrisformel:

=MEDEL(OM(ÄRFEL(B2:D2));"";B2:D2))

Det här är en mat ris formel. Du måste antingen trycka på RETUR (bara om du använder Microsoft 365 ) eller CTRL + SKIFT + RETUR i formeln.

Obs!: Om du har en aktuell version av Microsoft 365kan du ange formeln i cellen output och sedan trycka på RETUR för att bekräfta formeln som en dynamisk mat ris formel. Annars måste formeln anges som en äldre mat ris formel genom att först markera cellen, skriva in formeln i utdatatabellen och sedan trycka på CTRL + SKIFT + RETUR för att bekräfta. I Excel infogas klammerparenteser i början och slutet av formeln åt dig. Mer information om matrisformler finns i Riktlinjer för och exempel på matrisformler.

Funktionen matris i genomsnitt för att lösa #VALUE! fel

Obs!: Funktionen ovan fungerar inte bara för #VÄRDEFEL!, utan även för #SAKNAS!, #NULL, #DIVISION/0! och andra felvärden.

Du kan också använda SUMMA på samma sätt:

=SUMMA(OM(ÄRFEL(B2:D2);"";B2:D2))

Har du en specifik fråga om funktioner?

Ställ en fråga i Excel-communityforumet

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Se även

Korrigera felet #VÄRDE! fel

Funktionen MEDEL

Funktionen SUMMA

Översikt över formler i Excel

Upptäck fel i formler

Alla Excel-funktioner (alfabetisk ordning)

Alla Excel-funktioner (efter kategori)

Obs!:  Den här sidan har översatts automatiskt och kan innehålla grammatiska fel och andra felaktigheter. Vår avsikt är att innehållet ska vara användbart för dig. Skulle du vilja svara på om informationen var till hjälp? Här är den engelska artikeln som en referens.

Behöver du mer hjälp?

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×