Felet #DIVISION/0! visas i Microsoft Excel om ett tal delas med noll (0). Det händer när du anger en enkel formel som =5/0 eller när en formel refererar till en cell som innehåller 0 eller är tom, som i följande bild.

Exempel på formler som orsakar #DIV/0! .

Åtgärda felet genom att göra något av följande:

  • Kontrollera att nämnaren i funktionen eller formeln inte är noll eller en tom cell.

  • Ändra cellreferensen i formeln till en annan cell som inte innehåller en nolla (0) eller ett tomt värde.

  • Ange #SAKNAS! i cellen som refereras som nämnaren i formeln. Då ändras formelresultatet till #SAKNAS! vilket innebär att nämnarvärdet inte finns tillgängligt.

Ofta är #DIV/0! eftersom dina formler väntar på indata från dig eller någon annan. I så fall vill du inte att felmeddelandet ska visas alls, så det finns några felhanteringsmetoder som du kan använda för att dölja felet medan du väntar på indata.

Utvärdera nämnaren för 0 eller inget värde

Det enklaste sättet att dölja #DIV/0! är att använda funktionen OM för att utvärdera om det finns någon nämnare. Om värdet är 0 eller inget visas värdet 0 eller inget som formelresultatet i stället för värdet #DIV/0! annars beräkna formeln.

Exempel: Om formeln som returnerar felet är =A2/A3 använder du =OM(A3,A2/A3,0) för att returnera 0 eller =OM(A3,A2/A3,"") för att returnera en tom sträng. Du kan också visa ett anpassat meddelande så här: =OM(A3,A2/A3;"Indata krävs"). Med funktionen KVOT från det första exemplet skulle du använda =OM(A3,KVOT(A2,A3),0). Det innebär följande: OM(A3 finns, returnera resultatet av formeln, ignorera det annars).

Exempel på lösning av #DIV/0! .

Använd OMFEL för att dölja #DIV/0! fel

Du kan också dölja det här felet genom att kapsla in divisionen i funktionen OMFEL. Och med A2/A3 kan du använda =OMFEL(A2/A3;0). Det innebär Excel om formeln utvärderas till ett fel och sedan returnera 0, annars returneras resultatet av formeln.

För tidigare versioner av Excel än Excel 2007 kan du använda OM(ÄRFEL())-metoden: =OM(ÄRFEL(A2/A3),0,A2/A3) (se ÄR-funktioner).

Obs! Både OMFEL- och OM(ÄRFEL())-metoderna är generella felhanterare på så sätt att de ignorerar alla fel, inte bara #DIV/0!. Du måste kontrollera att formeln fungerar korrekt innan du använder felhantering, annars kanske du inte inser att formeln inte fungerar som förväntat.

Tips: Om du har aktiverat felkontroll i Excel kan du klicka på Bild av knapp bredvid den cell som visar felet. Klicka på Visa beräkningssteg, om det alternativet finns tillgängligt, och välj den lösning som fungerar för dina data.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community eller få support i Answers-communityn.

Se även

Funktionen OM

Funktionen OMFEL

Funktionen ÄR

Översikt över formler i Excel

Hur du undviker felaktiga formler

Upptäck fel i formler

Excel-funktioner (alfabetisk ordning)

Excel-funktioner (efter kategori)

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Gå med i Microsoft Office Insiders

Hade du nytta av den här informationen?

Hur nöjd är du med språkkvaliteten?
Vad påverkade din upplevelse?

Tack för din feedback!

×