Skapa en pivottabell med en extern datakälla

Att kunna analysera alla data kan hjälpa dig att fatta bättre affärsbeslut. Men ibland är det svårt att veta var man ska börja, särskilt när du har en stor mängd data som lagras utanför Excel, t.ex. i en Microsoft Access- eller Microsoft SQL Server-databas eller i en OLAP-kubfil (Online Analytical Processing). I så fall kan du ansluta till den externa datakällan och sedan skapa en pivottabell för att sammanfatta, analysera, utforska och presentera dessa data.

Så här skapar du en pivottabell med en befintlig extern dataanslutning:

  1. Klicka på en cell i kalkylbladet.

  2. Klicka på Infoga > Pivottabell.

    Knappen Pivottabell på fliken Infoga

  3. Klicka på Använd en extern datakälla i dialogrutan Skapa pivottabell under Välj de data som du vill analysera.

    Dialogrutan Skapa pivottabell med Använd en extern datakälla markerat

  4. Klicka på Välj anslutning.

  5. Låt Alla anslutningar vara markerat i rutan Visa på fliken Anslutningar, eller välj den anslutningskategori som har den datakälla du vill ansluta till.

Om du vill återanvända eller dela en befintlig anslutning använder du en anslutning från Connections i den här arbetsboken.

  1. Markera den anslutning du vill använda i listan med anslutningar och klicka sedan på Öppna.

  2. Välj en plats under Välj var du vill att pivottabellrapportenska placeras.

    • Om du vill placera pivottabellen i ett nytt kalkylblad med början i cell A1 väljer du Nytt kalkylblad.

    • Om du vill placera pivottabellen i det aktiva kalkylbladet väljer du På detta kalkylblad och anger sedan cellen där du vill att pivottabellen ska börja i rutan Plats.

  3. Klicka på OK.

    Excel en tom pivottabell och visar fältlistan så att du kan visa de fält du vill använda och ordna om dem för att skapa en egen layout.

    Fältlistan som visar externa datafält

  4. Markera kryssrutan bredvid ett fältnamn i fältlistavsnittet om du vill placera fältet i ett standardområde i områdesavsnittet i fältlistan.

    Vanligtvis läggs ickenumeriska fält till i området Rader, numeriska fält läggs till i området Värden och fält för datum och tid läggs till i området Kolumner. Du kan flytta fält till ett annat område efter behov.

    Tips: Du kan också högerklicka på ett fältnamn och sedan välja Lägg till i rapportfilter ,Lägg till i kolumnetiketter, Lägg till i radetiketter eller Lägg till i värden för att placera fältet i det området i områdesavsnittet eller dra ett fält från fältavsnittet till ett område i områdesavsnittet.

    Använd fältlistan för att ytterligare utforma layouten och formatet för en pivottabell genom att högerklicka på fälten i områdesavsnittet och sedan markera det område du vill använda, eller genom att dra fälten mellan områdena i områdesavsnittet.

Anslut till en ny extern datakälla

Så här skapar du en ny extern dataanslutning för SQL Server och importerar data till Excel en tabell eller pivottabell:

  1. Klicka Data > Från andra källor.

Knappen Från andra källor på fliken Data

  1. Klicka på den anslutning du vill använda.

    • Klicka på Från SQL Server för att skapa en anslutning till en SQL Server tabell.

    • Klicka på Från Analysis Services för att skapa en anslutning till SQL Server Analysis-kub.

  2. I guiden Dataanslutning utfördu stegen för att upprätta anslutningen.

    • På sida 1 anger du databasservern och anger hur du vill logga in på servern.

    • På sida 2 anger du den databas, tabell eller fråga som innehåller de data du vill ha.

    • På sida 3 anger du anslutningsfilen som du vill skapa.

Så här skapar du en ny anslutning till en Access-databas och importerar data Excel data till en tabell eller pivottabell:

  1. Klicka på Data > Från Access.

Knappen Från åtkomst på fliken Data

  1. Leta reda på den databas du vill ansluta till i dialogrutan Välj datakälla och klicka på Öppna.

  2. Markera den tabell du vill använda i dialogrutan Välj tabell och klicka sedan på OK.

Om det finns flera tabeller markerar du kryssrutan Aktivera val av flera tabeller så att du kan markera rutorna för de tabeller du vill ha och klickar sedan på OK.

  1. I dialogrutan Importera data väljer du hur du vill visa data i arbetsboken och var du vill placera dem och klickar sedan på OK.

Tabellerna läggs automatiskt till i datamodellenoch Access-databasen läggs till i dina arbetsboksanslutningar.

Mer information om pivottabeller

Behöver du mer hjälp?

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

×