Skapa, läsa in eller redigera en fråga i Excel (Power Query)

Skapa, läsa in eller redigera en fråga i Excel (Power Query)

I Power Query kan du skapa och läsa in Power-frågor i arbetsboken på flera olika sätt. Du kan också ange standardinställningar för frågeinläsning i fönstret Frågealternativ.    

Tips!      För att se om data i ett kalkylblad är formade av Power Query markerar du en cell med data, och om menyfliken Query-sammanhang visas har data lästs in från Power Query. 

Markera en cell i en fråga för att visa fliken Fråga

Veta vilken miljö du är i Power Query är väl integrerat i Excel-användargränssnittet, särskilt när du importerar data, arbetar med anslutningar och redigerar pivottabeller, Excel och namngivna områden. För att undvika förvirring är det viktigt att veta vilken miljö du befinner dig i, Excel Eller Power Query, när som helst.

Det välbekanta Excel-kalkylbladet, menyfliksområdet och rutnätet

Menyfliksområde och förhandsgranskning i Power Query-redigeraren 

Ett vanligt Excel kalkylblad En typisk Power Query-redigeringsvy

Att till exempel hantera data i ett Excel är fundamentalt annorlunda än Power Query. Dessutom kan kopplade data som visas i ett Excel eller så kanske power query fungerar i bakgrunden och formar data. Detta inträffar bara när du läser in data till ett kalkylblad eller en datamodell från Power Query.

Byta namn på kalkylbladsflikar    Det är en bra idé att byta namn på kalkylbladsflikar på ett meningsfullt sätt, särskilt om du har många. Det är särskilt viktigt att förtydliga skillnaden mellan ett kalkylblad med data och ett kalkylblad som läses in från Power Query-redigeraren. Även om du bara har två kalkylblad, ett med en Excel-tabell som kallas Blad1och den andra en fråga som skapats genom att importera den Excel-tabellen, kallad Tabell1,är det lätt att förväxla. Det är alltid bra att ändra standardnamnen på flikarna i kalkylbladet till namn som är mer meningsfulla för dig. Byt till exempel namn på Blad1 till Datatabell och Tabell1 till Frågetabell. Nu är det rensat vilken flik som innehåller data och vilken flik som har frågan.

Du kan antingen skapa en fråga från importerade data eller skapa en tom fråga.

Skapa en fråga från importerade data

Det här är det vanligaste sättet att skapa en fråga.

  1. Importera data. Mer information finns i Importera data från externa datakällor.

  2. Markera en cell i dina data och välj sedan Fråga> Redigera.

Skapa en tom fråga

Du kanske bara vill börja om från början. Du kan göra det på två sätt.

  • Välj Data> Hämta data >Från andra källor > Tom fråga.

  • Välj Data > hämta data > starta Power Query-redigeraren.

I det här läget kan du lägga till steg och formler manuellt om du känner till formelspråket Power Query M väl.

Du kan också välja Start och sedan ett kommando i gruppen Ny fråga. Gör något av följande.

  • Välj Ny källa för att lägga till en datakälla. Det här kommandot är precis som kommandot> Hämta data i menyfliksområdet Excel Datadata.

  • Välj Senast använda källor och välj från en datakälla som du har arbetat med. Det här kommandot liknar kommandot >Senast använda källor i Excel menyfliksområdet.

  • Välj Ange data om du vill ange data manuellt. Du kan välja det här kommandot om du vill prova Power Query-redigeraren oberoende av en extern datakälla.

Om frågan är giltig och inte innehåller några fel kan du läsa in den i ett kalkylblad eller en datamodell.

Läsa in en fråga från Power Query-redigeraren

Gör något av följande i Power Query-redigeraren:

  • Om du vill läsa in i ett kalkylblad väljer du Start> Stäng & läs > Stäng & Läs in.

  • Om du vill läsa in till en datamodell väljer du Start> Stäng & läs > Stäng & Läs in till.

    Välj Lägg till dessa data i datamodellen i dialogrutan Importeradata.

Tips!   Ibland är kommandot Läs in till nedtonat eller inaktiverat. Detta kan inträffa första gången du skapar en fråga i en arbetsbok. Om det inträffar väljer du Stäng &Läs in i det nya kalkylbladet och väljer Data > Frågor & Anslutningar > Fliken Frågor, högerklickar på frågan och väljer sedan Läs in till. Alternativt kan du välja Frågeredigeraren i menyfliksområdet i Power Query> Läsa in till.

Läsa in en fråga från fönstret Frågor och anslutningar 

I Excel kanske du vill läsa in en fråga till ett annat kalkylblad eller en annan datamodell.

  1. I Excel väljer du Data> Frågor & Anslutningaroch sedan fliken Frågor.

  2. Leta reda på frågan i listan med frågor, högerklicka på frågan och välj sedan Läs in till. Dialogrutan Importera data visas.

  3. Bestäm hur du vill importera data och välj sedan OK. Om du vill ha mer information om hur du använder den här dialogrutan markerar du frågetecknet (?).

Det finns flera sätt att redigera en fråga som lästs in i ett kalkylblad.

Redigera en fråga från data i Excel kalkylblad

  • Om du vill redigera en fråga letar du upp en tidigare inläst från Power Query-redigeraren, markerar en cell i dina data och väljer sedan Fråga > Redigera.

Redigera en fråga från & i Anslutningar

Fönstret Frågor och & är mer praktiskt att använda när du har många frågor i en arbetsbok och du snabbt vill hitta en.

  1. I Excel väljer du Data> Frågor & Anslutningaroch sedan fliken Frågor.

  2. Leta reda på frågan i listan med frågor, högerklicka på frågan och välj sedan Redigera.

Redigera en fråga från dialogrutan Frågeegenskaper

  • I Excel väljer du Data> Data & Anslutningar > Fliken Frågor, högerklickar på frågan och väljer Egenskaper, väljer fliken Definition i dialogrutan Egenskaper och väljer sedan Redigera fråga.

Tips!    Om du befinner dig i ett kalkylblad med en fråga väljer du Data> Egenskaper,väljer fliken Definition i dialogrutan Egenskaper och sedan Redigera fråga. 

En datamodell innehåller vanligtvis flera tabeller ordnade i en relation. Du läser in en fråga till en datamodell genom att använda kommandot Läs in till för att visa dialogrutan Importera data och sedan markera kryssrutan Lägg till dessa data i datalägel. Mer information om datamodeller finns i Ta reda på vilka datakällor som används i en arbetsboksdatamodell, Skapa en datamodelli Excel och Använda flera tabeller för att skapa en pivottabell.

  1. Om du vill öppna datamodellen väljer du Power Pivot >Hantera.

  2. Längst ned i Power Pivot-fönstret väljer du kalkylbladsfliken för den tabell du vill använda.

    Bekräfta att rätt tabell visas. En datamodell kan ha många tabeller.

  3. Anteckna namnet på tabellen.

  4. Stäng Power Pivot-fönstret genom att välja Arkiv> Stäng. Det kan ta några sekunder att frigöra minne.

  5. Välj Data > anslutningar & egenskaper > fliken Frågor, högerklicka på frågan och välj sedan Redigera.

  6. När du är klar med ändringarna i Power Query-redigeraren väljer du> Stäng & Läs in.

Resultat

Frågan i kalkylbladet och tabellen i datamodellen uppdateras.

Om du märker att inläsningen av en fråga i en datamodell tar mycket längre tid än inläsningen av ett kalkylblad kan du kontrollera Power Query-stegen för att se om du filtrerar en textkolumn eller en listas strukturerad kolumn med hjälp av en operator som innehåller. Den här åtgärden Excel räknas upp igen genom hela datauppsättningen för varje rad. Dessutom Excel inte effektivt använda flertrådad körning. En lösning kan vara att prova att använda en annan operator, till exempel Lika med eller Börjar med.

Microsoft är medvetna om problemet och det är under undersökning.

Du kan läsa in en Power Query:

  • Till ett kalkylblad. I Power Query-redigeraren väljer du Start > stäng & in > Stäng & läs in.

  • Till en datamodell. I Power Query-redigeraren väljer du Start > Stäng & läs > Stäng & Läs in till.

    Som standard läser Power Query in frågor till ett nytt kalkylblad när en enskild fråga läses in och flera frågor läses in samtidigt till datamodellen.  Du kan ändra standardbeteendet för alla arbetsböcker eller bara den aktuella arbetsboken. När du anger dessa alternativ ändras inte frågeresultatet i kalkylbladet eller datamodellens data och anteckningar i Power Query.

    Du kan också dynamiskt åsidosätta standardinställningarna för en fråga med hjälp av dialogrutan Importera som visas när du väljer Stäng och & Läsintill. 

Globala inställningar som gäller för alla dina arbetsböcker

  1. I Power Query-redigeraren väljer du Arkiv> och inställningar >Frågealternativ.

  2. I dialogrutan Frågealternativ till vänster, under avsnittet GLOBAL,  väljer du Databelastning.

  3. I avsnittet Förvald frågeinläsning Inställningar du följande:

    • Välj Använd standardinställningar för inläsning. 

    • Välj Ange anpassade standardinställningar för inläsning  och markera eller avmarkera läs in i kalkylbladet eller Läs in i datamodell.

Tips!    Längst ned i dialogrutan kan du välja Återställ standardvärden för att enkelt återgå till standardinställningarna.

Arbetsboksinställningar som endast gäller för den aktuella arbetsboken

  1. I dialogrutan Frågealternativ till vänster, under avsnittet AKTUELL ARBETSBOK, väljer du Databelastning.

  2. Utför en eller flera av följande åtgärder:

    • Under Identifiering avtyp markerar eller avmarkerar du Identifiera kolumntyper och rubriker för ostrukturerade källor.

      Standardbeteendet är att identifiera dem. Avmarkera det här alternativet om du föredrar att forma data själv.

    • Under Relationermarkerar eller avmarkerar du Skapa relationer mellan tabeller när du lägger till datamodellen för första gången.

      Innan du läser in till datamodellen är standardbeteendet att hitta befintliga relationer mellan tabeller, till exempel externa nycklar i en relationsdatabas, och importera dem med data. Avmarkera det här alternativet om du föredrar att göra detta på egen hand.

    • Under Relationermarkerar eller avmarkerar du Uppdatera relationer när frågor läses in i datamodellen.

      Standardbeteendet är att inte uppdatera relationer. När frågor som redan har lästs in i datamodellen uppdateras, söker Power Query efter befintliga relationer mellan tabeller, till exempel externa nycklar i en relationsdatabas, och uppdaterar dem. Det kan ta bort relationer som skapats manuellt efter att data importerats eller introducerat nya relationer. Men om du vill göra det väljer du alternativet.

    • Under Bakgrundsdatamarkerar eller avmarkerar du Tillåt att dataförhandsgranskningar laddas ned i bakgrunden.

      Standardbeteendet är att hämta förhandsgranskningar i bakgrunden. Avmarkera det här alternativet om du kan vilja se alla data direkt.

Se även

Power Query för Excel-hjälp

Hantera frågor i Excel

Behöver du mer hjälp?

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

×