Summera tal i ett område med funktionen SUMMA

Du kan använda en enkel formel för att summera tal i ett område (en grupp celler), men funktionen SUMMA är enklare att använda när du arbetar med fler än några tal. Till exempel är =SUMMA(A2:A6) mindre sannolikt att du får skrivfel än =A2+A3+A4+A5+A6.

Använda SUMMA med två områden med tal

Här är en formel som använder tvåcellområden: =SUMMA(A2:A4,C2:C3) summerar talen i områdena A2:A4 och C2:C3. Tryck på Retur om du vill få fram totalt 39787.

Så här skapar du formeln:

  1. Skriv =SUMMA i en cell, följt av en inledande parentes (.

  2. Om du vill ange det första formelområdet, som kallas ett argument (en del av de data som formeln behöver för att köras), skriver du A2:A4 (eller markerar cell A2 och drar till cell A6).

  3. Skriv ett kommatecken (,) för att separera det första argumentet från nästa.

  4. Skriv det andra argumentet, C2:C3 (eller dra för att markera cellerna).

  5. Skriv en avslutande parentes )och tryck sedan på Retur.

Ett argument kan vara ett område, ett tal eller enstaka cellreferenser, avgränsade med kommatecken.

  • =SUMMA(A2:A4;2429;10482)

  • =SUMMA(4823;A3:A4;C2:C3)

  • =SUMMA(4823;12335;9718;C2:C3)

  • =SUMMA(A2;A3;A4;2429;10482)

Tips:  Om du behöver summera kolumner eller rader med tal bredvid varandra kan du använda Autosumma för att summera tal.

Testa själv

Om du vill prova våra exempeldata finns det några data du kan använda.

Du kan se hur funktionen SUMMA fungerar genom att kopiera följande tabell till ett kalkylblad och klistra in den i cell A1.

Data

-5

15

30

'5

SANT

Formel

Beskrivning

Resultat

=SUMMA(3;2)

Adderar 3 och 2.

5

=SUMMA("5";15;SANT)

Adderar 5, 15 och 1. Textvärdet "5" översättas först till ett tal och det logiska värdet SANT översätts först till talet 1.

21

=SUMMA(A2:A4)

Adderar värdena i cellerna A2 till och med A4.

40

=SUMMA(A2:A4;15)

Adderar värdena i cellerna A2 till och med A4, och adderar sedan 15 till resultatet.

55

=SUMMA(A5;A6;2)

Adderar värdena i cellerna A5 och A6, och adderar sedan 2 till resultatet. Eftersom icke-numeriska värden i referenser inte översätts – värdet i cell A5 ('5) och värdet i cell A6 (SANT) behandlas båda som text – värdena i de cellerna ignoreras.

2

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community eller få support i Answers-communityn.

Behöver du mer hjälp?

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×