”Åtgärden är inte tillgänglig. Om du vill använda den här åtgärden måste du först markera den gamla lösningen och försök sedan igen ”visas i Dynamics 365

Symptom

När du väljer en lösning i Dynamics 365 och klicka på knappen tillämpa lösningen uppgraderar stöter du på följande felmeddelande:

”Åtgärden är inte tillgänglig.

Om du vill använda den här åtgärden måste du först markera den gamla lösningen och försök sedan igen ”.

Om du klickar på Hämta loggfil innehåller en referens till felkod-2147187396 i loggfilen.

Orsak

Det här meddelandet visas om du valde lösningen är lösningen-uppdateringen och inte den överordnade lösningen.

Knappen tillämpa uppgradera lösningen är avsedd att användas när du har importerat en uppdatering för en annan lösning som redan är installerad. Finns ett alternativ för ”scenen för uppgradering” som visas när du importerar den uppdaterade lösningen. Om den här kryssrutan är markerad utförs inte åtgärd för funktionsuppgradering under importera lösningen. En gäller lösning uppgradera knappen visas i slutet av importen. Om du inte klickade på knappen du hitta den överordnade lösningen i lösningslistan och sedan på Använd uppgradera lösningen. 

Exempel: Du tidigare har importerat en lösning som kallas SolutionA som var version 1.0.0.0. Senare kan du importera en nyare version av SolutionA som är version 1.0.1.0. Under lösningsimporten markerat alternativet ”scenen för uppgradering”. Om du inte klickade på knappen tillämpa uppgradera lösningen som visades i slutet av importen visas SolutionA och SolutionA_Upgrade i vyn alla lösningar. Om du markerade SolutionA_Upgrade och klickar på Använd lösning uppgradera visas det här felet. I stället måste du markera den överordnade lösningen (SolutionA) och klicka på tillämpa uppgradera lösningen.

Lösning

Klicka på tillämpa lösningen uppgradera den överordnade lösningen.

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Microsoft Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×