Den angivna nyckeln fanns inte i ordlistefelet när du spårar ett e-postmeddelande i Microsoft Dynamics 365 för Outlook

Den här artikeln innehåller en lösning på ett fel som uppstår när du spårar ett e-postmeddelande i Microsoft Dynamics 365 för Outlook.

Gäller för: Microsoft Dynamics 365
Ursprungligt KB-nummer: 4010462

Symptom

När du försöker spåra ett e-postmeddelande i Dynamics 365 för Outlook visas följande fel:

"Den angivna nyckeln fanns inte i ordlistan."

Om du väljer information visas följande annan information:

"Den angivna nyckeln fanns inte i ordlistan.
at System.Collections.Generic.Dictionary2.get_item(Tkey key)
på Microsoft.Crm.AppIication.SMWrappers.AttachmentForOutIook.Get... clientOrganizationContext, IDynamicEntityCoIIectionForOutIook dynamicEntityCoIIectionAttachments)
atMicrosoft.Crm.AppIicationSMWrappers.EmaiIForOutIook.Microsoft.... messageld, String subject, String from, String to, String cc, String bcc, Double receivedon, String submitted8y, String importance, String body, IDynamicEntityCoIIectionForOutIook attachments, Int32 attachmentCount, IDynamicEntityForOutIook extraProperties, String entityXmI, String regardingld, Int64 regardingObjectType, String crmld, Int32& notification)"

Orsak

Det här felet kan inträffa för något av följande villkor:

  1. E-postmeddelandet innehåller en bifogad fil som är större än den storlek som tillåts i Dynamics 365.
  2. E-postmeddelandet innehåller en bifogad fil med ett filnamnstillägg som blockeras av Dynamics 365.

Åtgärd

Lösning 1
Om e-postmeddelandet innehåller en bifogad fil som överskrider storleksgränsen tar du antingen bort den bifogade filen eller ökar storleken på bifogade filer som tillåts i Dynamics 365. Standardstorleken är 5 MB.

Om du har rollen Systemadministratör i Dynamics 365 kan du visa och ändra den här inställningen genom att gå till Inställningar, Administration och sedan välja Systeminställningar. Välj fliken Email och leta upp inställningen Maximal filstorlek (i kilobyte) under rubriken Ange filstorleksgräns för bifogade filer.

Lösning 2
Om e-postmeddelandet innehåller en bifogad fil med ett tillägg som blockeras av Dynamics 365 tar du antingen bort den bifogade filen eller ändrar vilket filnamnstillägg som blockeras av Dynamics 365.

Om du har rollen Systemadministratör i Dynamics 365 kan du visa och ändra den här inställningen genom att gå till Inställningar, Administration och sedan välja Systeminställningar. På fliken Allmänt letar du upp inställningen Ange blockerade filnamnstillägg för bifogade filer.