"Den angivna nyckeln finns inte i ordlistan" fel uppstår när du spårar ett e-postmeddelande i Dynamics 365 för Outlook

Symptom

När du spårar ett e-postmeddelande i Dynamics 365 för Outlook får du följande fel:


"Den angivna nyckeln finns inte i ordlistan."


Om du klickar på information visas följande ytterligare uppgifter:


"Den angivna nyckeln finns inte i ordlistan.

vid System.Collections.Generic.Dictionary2.get_item (Tkey key)

vid

Microsoft.Crm.AppIication.SMWrappers.AttachmentForOutIook.Get... clientOrganizationContext, IDynamicEntityCoIIectionForOutIook dynamicEntityCoIIectionAttachments) atMicrosoft.Crm.AppIicationSMWrappers.EmaiIForOutIook.Microsoft... messageld sträng ämne sträng från sträng till, String kopia, hemlig sträng, dubbelt receivedon, sträng submitted8y, sträng betydelse, sträng organ, IDynamicEntityCoIIectionForOutIook bilagor, Int32 attachmentCount, IDynamicEntityForOutIook extraProperties, sträng entityXmI, sträng regardingld, Int64 regardingObjectType, sträng crmld Int32 & anmälan) "




Orsak

Det här felet kan bero på något av följande villkor:


  1. E-postmeddelandet innehåller en bifogad fil som är större än den tillåtna storleken i Dynamics 365.

  2. E-postmeddelandet innehåller en bifogad fil med ett filtillägg som har blockerats av Dynamics 365.


Lösning

Lösning 1

Om e-postmeddelandet innehåller en bifogad fil som överskrider storleksgränsen, ta bort bilagan eller öka storleken på bilagor i Dynamics 365.  Den maximala standardstorleken är 5MB.


Om du har rollen systemadministratör i Dynamics 365 kan du visa och ändra den här inställningen genom att gå till Inställningar, Administrationoch sedan klicka på Systeminställningar.  Klicka på fliken e-post och leta reda på inställningen för Maximal filstorlek (i kilobyte) under Ange storleksbegränsning för bifogade filer rubrik.


Lösning 2

Om e-postmeddelandet innehåller en bifogad fil med ett filtillägg som har blockerats av Dynamics 365, ta bort den bifogade filen eller ändra vilka filtillägg som har blockerats av Dynamics 365.


Om du har rollen systemadministratör i Dynamics 365 kan du visa och ändra den här inställningen genom att gå till Inställningar, Administrationoch sedan klicka på Systeminställningar.  Leta upp inställningen Ange blockerade filnamnstillägg för bifogade filerpå fliken Allmänt .

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Microsoft Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×