Det går inte att ansluta till Microsoft Dynamics CRM serverfel när du försöker ansluta Microsoft Dynamics CRM 2013 för Microsoft Office Outlook till CRM Online

Den här artikeln innehåller en lösning på ett fel som uppstår när du försöker ansluta Microsoft Dynamics CRM 2013 för Microsoft Office Outlook till CRM Online.

Gäller för: Microsoft Dynamics CRM Online
Ursprungligt KB-nummer: 3089686

Symptom

När du försöker ansluta Microsoft Dynamics CRM 2013 för Microsoft Office Outlook (Outlook-klienten) till en CRM Online-organisation får du följande fel:

"Det går inte att ansluta till Microsoft Dynamics CRM server eftersom vi inte kan autentisera dina autentiseringsuppgifter. Kontrollera anslutningen eller kontakta administratören om du vill ha mer hjälp."

När du väljer Information visas följande ytterligare information:

Värdet får inte vara null.
Parameternamn: path1
på System.IO.Path.Combine(String path1, String path2)
på Microsoft.Crm.Passport.IdCrl.FederationLogOnManager.. ctor(Strängmiljö)
på Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.GetLogonManager()
på Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.SignIn()
på Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.SignIn(Uri endPoint, Credential credentials, AuthUIMode uiMode, IClientOrganizationContext context, Form parentWindow, Boolean retryOnError)
på Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo.DeploymentInfo.LoadOrganizations(AuthUIMode uiMode, Formulär parentWindow, autentiseringsuppgifter)
på Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo.InternalLoadOrganizations(OrganizationDetailCollection orgs, AuthUIMode uiMode, Formulär parentWindow)

Orsak

Inloggningsassistenten för Microsoft Online Services är inte installerad eller så har rätt användarnamn och lösenord inte angetts. Om problemet orsakas av felaktigt användarnamn eller lösenord kan det vara autentiseringsuppgifterna som cachelagras i autentiseringshanteraren för Windows.

Åtgärd

Om inloggningsassistenten för Microsoft Online Services inte är installerad installerar du den med hjälp av lämplig länk nedan. Stäng och öppna konfigurationsguiden för Microsoft Dynamics CRM för Microsoft Office Outlook igen efter installationen.

Om inloggningsassistenten för Microsoft Online Services redan är installerad och du fortfarande får det här felet väljer du OK så bör du se en uppmaning om ditt användarnamn och lösenord. Om användarnamnet och lösenordet redan har fyllts i anger det att autentiseringsuppgifterna cachelagrades. Ange rätt användarnamn och lösenord igen för att kontrollera att felaktiga autentiseringsuppgifter inte används.

Obs!

Om du vill visa om autentiseringsuppgifterna lagras i autentiseringshanteraren för Windows väljer du Start-menyn i Windows och skriver Autentiseringshanteraren. I området Allmänna autentiseringsuppgifter kan du se autentiseringsuppgifter som börjar med Microsoft_CRM. Om du har ändrat ditt lösenord eller använder ett annat användarkonto kanske dessa lagrade autentiseringsuppgifter inte är korrekta. Dessa autentiseringsuppgifter kan tas bort, vilket förhindrar att Microsoft Dynamics CRM för Microsoft Office Outlook använder dem när du försöker ansluta.

Om din CRM Online-organisation redan har uppdaterats till 2015-uppdateringen (7.0 eller senare) kan du använda Microsoft Dynamics CRM 2015 för Microsoft Office Outlook som inte förlitar sig på inloggningsassistenten för Microsoft Online Services.

Mer information

Om inloggningsassistenten för Microsoft Online Services inte är installerad innehåller loggfilen följande fel:

19:23:00| Fel| Fel vid anslutning till URL: https://disco.crm.dynamics.com/XRMServices/2011/Discovery.svc Undantag: System.DllNotFoundException: Inloggningsassistenten för Microsoft Online Services är inte installerad. 32-bitars: https://g.microsoftonline.com/0BX00en/500 64-bitars: https://g.microsoftonline.com/0BX00en/501