”Importera filen är för stor för att överföra”-fel uppstår när du importerar en lösning i Dynamics 365

Symptom

När du försöker importera en lösning i Dynamics 365 importen misslyckas, och följande meddelande visas:

”Importera filen är för stor för att överföra. 

Felkod: 80040375 ”  

Orsak

Även om felmeddelandet anger ett problem med att Importera filen är för stor för att överföra, kan ett annat problem som ett SQL-fel bero på.

Lösning

Klicka på knappen Hämta loggfil om du vill se en mer detaljerad meddelande. Information om följande meddelande visas:

”Den gick inte att importen. Mer information finns i de relaterade felmeddelandena. : System.Data.SqlClient.SqlException (0x80131904): kolumnnamn i varje tabell måste vara unikt. Kolumnnamn '< kolumnnamn >' i tabellen '< enhet/table name >' anges mer än en gång... ”

Ovanstående exempel meddelande är ett SQL-fel kan uppstå om du försöker importera ett fält som redan finns i enheten.

Exempel: Om du har skapat ett anpassat fält i organisationen med ett schemanamn på entiteten konto som kallas new_field1. Nu är du försöker importera en lösning som innehåller ett fält med samma schemanamnet på entiteten konto. SQL tillåter inte flera kolumner med samma namn i samma tabell så detta innebär att importen misslyckas. Du kan hitta i målmiljön du redan har ett fält med samma schemanamn, men olika hölje som new_Field1 och fältet i lösningen som du importerar är new_field1. Om fältet med samma namn inte behövs i målmiljön ta bort den och försök sedan importera igen.

Om felet kvarstår och det går inte att lösa problemet med hjälp av informationen i loggfilen, kan du kontakta Microsoft Support för hjälp. Du kan också använda information i loggfilen för att söka efter möjliga lösningar i Dynamics 365 gemenskaperna.

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Microsoft Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×