Symptom

En varning nivå varning som följande visas i en postlåda i Dynamics 365:

"Ett okänt fel inträffade vid mottagning av e-post via brevlådan" [Brevlådans namn]". Ägaren till den associerade e-postserverprofilen [profilnamn] har anmälts. Systemet kommer att försöka ta emot e-post igen senare.

Felkod för e-postserver: Exchange Server returnerade unknownincomingemailintegrationerror-2147220956 undantag. "

Orsak

Felkod-2147220956 anger ett Isvunförväntat fel. Detta indikerar vanligtvis ett anpassat plugin-program eller arbetsflöde som kastar ett fel och orsakar skapandet av objektet misslyckas.

Lösning

Följande steg använder exemplet med en e-postpost som inte kan skapas. Om du ser det här felet loggas för en annan typ av objekt, till exempel en avtalad tid, kontakt eller uppgift, kan samma typ av steg tillämpas genom att ersätta referenser till "e-post" med den typ av post som du felsöker.

Kontrollera om du har några anpassade plugin-program eller arbetsflöden som körs synkront på Skapa av ett e-postmeddelande. Om ett plugin-eller arbetsflöde orsakar ett fel kan inte serversynkronisering skapa e-postmeddelandet. Stegen nedan kan hjälpa dig att identifiera om det finns några arbetsflöden eller plugin-program i din organisation som körs när du skapar ett e-postmeddelande:

Arbetsflöde

  1. I webbprogrammet Dynamics 365 navigerar du till Inställningar och klickar sedan på processer.

  2. Ändra vyn till aktiverade processer.

  3. Sortera efter den primära entitetskolumnen och leta efter alla rader med e-post som primär entitet och arbetsflöde som kategori. Alternativt kan du använda filtreringsalternativen i rutnätet för att filtrera på kategori = arbetsflöde och primär entitet = e-post

  4. Öppna varje arbetsflöde du hittar som uppfyller kriterierna ovan (om någon).

  5. Om alternativet starta när alternativ har posten har skapats och alternativet Kör det här arbetsflödet i bakgrunden (rekommenderas) inte är markerat, kan det här arbetsflödet potentiellt vara orsaken. Anmärkning: om du felsöker den här typen av fel med en avtalad tid, kontakt eller uppgift, Kontrollera även om arbetsflödet har konfigurerats för att köras under uppdateringen av den typen av post.

  6. Klicka på avsnittet Processsessioner till vänster på sidan och lookg för eventuella fel som är relaterade till e-postmeddelandet som inte har skapats.

Plugins

  1. I webbprogrammet Dynamics 365 navigerar du till Inställningar, anpassningar och klickar sedan på Anpassa systemet.

  2. Klicka på bearbetningssteg för SDK-meddelande.

  3. Sortera efter kolumnen primär objekttypskod (SdkMessage-filter) och leta efter rader för e-postentiteten.

  4. Om du hittar några rader och körningsläget är synkront, kan detta potentiellt vara interfererande med skapandet av e-postmeddelandet.

Om problemet återger konsekvent och det är möjligt att tillfälligt inaktivera arbetsflödet eller plugin-programmet som ett test, kan detta ge dig möjlighet att avgöra om arbetsflödet eller plugin-programmet är orsaken.

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Microsoft Insiders

Hade du nytta av den här informationen?

Hur nöjd är du med översättningskvaliteten?

Vad påverkade din upplevelse?

Har du ytterligare feedback? (Valfritt)

Tack för din feedback!

×