Symptom
När du försöker ansluta en iPhone eller iPad till Dynamics CRM app kan uppstå felet: "Vi är tyvärr. Servern är inte tillgänglig eller stöder inte detta program."
Orsak
SSL-certifikat som genereras av vissa externa certifikatutfärdare kan ha problem med hela certifikatkedjan är betrodd när du konfigurerar CRM-app på en iPhone eller iPad.
Mer Information
Ansluter till Microsoft Dynamics CRM-webbplatsen via ett webbprogram fungerar. Dock för iOS-enheter, SSL-certifikatet som konfigurerats för AD FS och CRM kan ses som inte är betrodda. Du kommer att se liknande certifikat relaterade fel när du använder iOS-appar som återger webbsidor med hjälp av UIWebViews och WKWebViews.
Loggar för iOS-enhet visas: autentisering: autentisering avbryts.
Detta inträffade när SSL-certifikatet är ett jokerteckencertifikat för hela domänen till exempel *. contoso.com. Rotdomänen till exempel https://contoso.com fungerar korrekt. Underdomäner som https://crm.contoso.com fungerar inte som förväntat. Detta kan bero på kompatibilitet med iOS-enheter och certifikat som jokertecken för Alternativt ämnesnamn. Det rekommenderas att testa med certifikat vars rotnivå innehåller CRM underdomän *. crm.domain.com.