Email kan inte skickas eller tas emot när Server-Side synkronisering har konfigurerats med Gmail
Den här artikeln innehåller lösningar på fel som uppstår när Server-Side synkronisering har konfigurerats med Gmail.
Gäller för: Microsoft Dynamics CRM 2013, Microsoft Dynamics CRM 2015, Microsoft Dynamics CRM 2016, Microsoft Dynamics CRM 2016 Service Pack 1
Ursprungligt KB-nummer: 3185281
Symptom
Om Microsoft Dynamics CRM har konfigurerats för att använda Server-Side synkronisering med Gmail kan du få något av följande felmeddelanden:
Email kan inte tas emot för postlådan <Postlådenamn>. Kontrollera att autentiseringsuppgifterna som anges i postlådan är korrekta och har tillräcklig behörighet för att ta emot e-post. Aktivera sedan postlådan för e-postbearbetning.
Ett okänt fel uppstod när e-postmeddelandet "Test Message" skulle skickas. Postlådenamnet <> synkroniserade inte. Ägaren till den associerade e-postserverprofilen <Email Serverprofilnamn> har meddelats.
Orsak
Felen uppstår av någon av följande orsaker:
Orsak 1
E-postadressen, användarnamnet eller lösenordet i postlådan i Microsoft Dynamics CRM stämmer inte.
Orsak 2
Rätt port har inte konfigurerats i posten Email ServerProfil i Microsoft Dynamics CRM.
Orsak 3
POP är inte aktiverat i Gmail-postlådan.
Orsak 4
En inställning i Gmail förhindrar Server-Side Sync från att autentisera till Gmail-postlådan.
Åtgärd
Lösning 1
Kontrollera värdena för fälten Email Adress, Användarnamn och Lösenord i postlådan i Microsoft Dynamics CRM.
Lösning 2
Öppna Email-serverprofilen och välj sedan Avancerat. Ange Inkommande port till 995 och Utgående port till 587.
Lösning 3
Följ Gmail-anvisningarna för att aktivera POP.
Lösning 4
Kontrollera Gmail-postlådan för ett e-postmeddelande om ett blockerat inloggningsförsök. Meddelandet innehåller steg för hur du avblockera åtkomst. När du har följt stegen kan du prova att testa och aktivera postlådan i CRM igen.
Om problemet kvarstår kan du läsa Felsöka inloggningsproblem, som innehåller ytterligare steg som kan vara nödvändiga för att aktivera e-poståtkomst från en app.
Mer information
Informationsavsnittet i aviseringen kan innehålla följande text:
"Fel: System.Net.Mail.SmtpException: Syntaxfel, kommandot är okänt. Serversvaret var:
på System.Net.Mail.SmtpConnection.ConnectAndHandshakeAsyncResult.End(IAsyncResult-resultat)
på System.Net.Mail.SmtpClient.ConnectCallback(IAsyncResult result)"
Ansvarsfriskrivning för information från tredje part
De produkter från andra tillverkare som diskuteras i denna artikel tillverkas oberoende av Microsoft. Produkternas funktion eller tillförlitlighet kan därför inte garanteras.