En avtalad tid avbryts eller tas oväntat bort under synkronisering på serversidan

Den här artikeln innehåller en lösning på ett problem där en avtalad tid avbryts eller tas bort oväntat när du använder synkronisering på serversidan.

Gäller för: Microsoft Dynamics 365
Ursprungligt KB-nummer: 4345686

Symptom

När du använder synkronisering på serversidan för att synkronisera avtalade tider mellan Microsoft Dynamics 365 och Exchange avbryts eller tas en avtalad tid oväntat bort.

Orsak

Det här problemet kan inträffa om den avtalade tiden inte längre uppfyller villkoren för användarens synkroniseringsfilter. Som nämns i Ignorera logiskt borttagna objekt under synkroniseringen finns det flera orsaker till att en avtalad tid inte längre matchar dina synkroniseringsfilter, till exempel organisatören av den avtalade tiden som ändras, synkroniseringsfiltren som ändras eller att användaren inte längre har åtkomst till posten på grund av ändringar i säkerhetsroller eller delning. Som standard skickar synkronisering på serversidan en borttagningsåtgärd till Exchange i det här scenariot, vilket resulterar i att en avtalad tid avbryts.

Åtgärd

En konfigurerbar inställning introducerades så att du kan ändra det här beteendet. Du kan använda något av följande verktyg för att ändra inställningen DistinctPhysicalAndLogicalDeletesForExchangeSync till Sant:

  1. Organisationsinställningar Editor
  2. OrgDBOrgSettings-verktyget för Microsoft Dynamics CRM