Fel när du skriver ut eller förhandsgranskar en rapport i Microsoft Dynamics SL: System Message 7011

Den här artikeln innehåller flera lösningar på ett problem där du får felmeddelandet System Message 7011 när du skriver ut eller förhandsgranskar en rapport i Microsoft Dynamics SL.

Gäller för: Microsoft Dynamics SL 2011
Ursprungligt KB-nummer: 905595

Symptom

Tänk dig att du skriver ut eller förhandsgranskar rapporter i någon av följande moduler:

  • Inköp i Microsoft Dynamics SL
  • Orderhantering i Microsoft Dynamics SL
  • Inventering i Microsoft Dynamics SL
  • Tid och kostnad för projekt i Microsoft Dynamics SL

När du vidtar den här åtgärden får du något av följande felmeddelanden:

Serie 1:

Systemmeddelande 7011 – ROI Hämta RIPARAM misslyckades för CRPERC. Error=.

När du har fått det här meddelandet får du följande felmeddelande:

Systemmeddelande 7011 – ROI Hämta RIPARAM misslyckades för CRPEMSGCNT. Error=.

Se Orsak 1, 2, 3 och 4.

Serie 2:

CRPEHLPR MFC-programmet har stött på ett problem och måste stängas. Vi beklagar besväret.

Följt av:

Systemmeddelande 7011 – ROI Hämta RIPARAM misslyckades för CRPERC. Error=.

Följt av:

Systemmeddelande 7011 – ROI Get RIPARAM failed for CRPEMSGCNT. Error=.

Se Orsak 5.

Serie 3:

Microsoft Visual C++ Runtime Library Runtime Error! Program: Programmet har begärt att Runtime ska avslutas på ett ovanligt sätt. Kontakta programmets supportteam för mer information.

Följt av:

Systemmeddelande 7011 – ROI Hämta RIPARAM misslyckades för CRPERC. Error=.

Följt av:

Systemmeddelande 7011 – ROI Get RIPARAM failed for CRPEMSGCNT. Error=.

Se Orsak 6.

Orsak

Det här problemet uppstår av någon av följande orsaker.

Orsak 1

Funktionen Data Execution Prevention (DEP) blockerar vissa filer från att köras när Microsoft Dynamics SL eller Microsoft Business Solutions – Solomon-programfiler finns på en dator som kör något av följande operativsystem:

  • Windows Server 2008 eller Windows Server 2008 R2
  • Windows 7
  • Windows Server 2003 med Service Pack 1 (SP1)
  • Windows Vista med Service Pack 1 (SP1)
  • Windows XP Professional med Service Pack 2 (SP2)

Orsak 2

Det finns skadade poster i Microsoft Dynamics SL-programdatabasen eller i Microsoft Business Solutions – Solomon-programdatabasen.

Orsak 3

Den Capicom.dll filen registrerades felaktigt.

Orsak 4

Microsoft Dynamics SL använder Crystal Reports 10. Den här versionen av Crystal Reports är en uppgradering från en tidigare version. Därför är vissa programinställningar inte längre kompatibla.

Orsak 5

Det här problemet beror på att det finns en undertryckningsformel i en underrapport som är associerad med den rapport som du försöker skriva ut.

Orsak 6

MSDSL-programrollen eller E7F575915A2E4897A517779C0DD7CE SQL-användaren synkroniseras inte korrekt med Microsoft Dynamics SL-databaserna. Eller så synkroniseras inte både rollen och användaren korrekt. Den här situationen kan inträffa om följande villkor är uppfyllda:

  • Du väljer scenariot Synkronisera allt ägarskap och säkerhetsuppdatering på skärmen Databasunderhåll (98.290.00) och skärmen Databasunderhåll (98.290.00) kommer från en tidigare version av Microsoft Dynamics SL.
  • Du kör uppdateringsscenariot på alla databaser som finns på samma instans av SQL Server som en Microsoft Dynamics SL 7.0-databas.

Lösning 1

Ange funktionen Dataexekveringsskydd för att aktivera Crpehlpr.exe-filen och den Roi.exe filen som ska köras. Gör så här:

  1. Högerklicka på Den här datorn och klicka sedan på Egenskaper.

  2. I Windows Server 2003 eller Windows XP klickar du på fliken Avancerat . I Windows Vista, Windows 7 eller Windows Server 2008 klickar du på länken Avancerade systeminställningar .

  3. I avsnittet Prestanda klickar du på Inställningar.

  4. På fliken Dataexekveringsskydd klickar du på Lägg till.

    Obs!

    Standardalternativet är Aktivera DEP för alla program och tjänster förutom de jag väljer.

  5. Bläddra till installationskatalogen för Microsoft Dynamics SL-programmet eller installationskatalogen för Microsoft Business Solutions – Solomon-programmet. Om du har ytterligare en enhet som är en mappad enhet till den här installationskatalogen måste du lägga till filen via båda sökvägarna.

    Du kan till exempel installera Microsoft Dynamics SL 7.0 i följande mapp:

    C:\Program Files\Microsoft Dynamics\SL\Applications

    På samma dator mappar du S-enheten till följande mapp:

    C:\Program Files\Microsoft Dynamics\SL

    När du följer det här steget måste du lägga till filerna med hjälp av båda följande sökvägar:

    • C:\Program Files\Microsoft Dynamics\SL\Applications\
    • S:\Applications\
  6. Leta upp och klicka sedan för att välja följande fil:

    Crpehlpr.exe

  7. Klicka på Öppna, klicka på Använd och klicka sedan på OK.

  8. Upprepa steg 1 till och med steg 7 för Roi.exe-filen.

Lösning 2

Ta bort de skadade posterna från Microsoft Dynamics SL-programdatabasen eller från Microsoft Business Solutions – Solomon-programdatabasen. Följ instruktionerna nedan.

Obs!

Innan du följer anvisningarna i den här artikeln kontrollerar du att du har en fullständig säkerhetskopia av databasen som du kan återställa om ett problem uppstår.

  1. Kontrollera att alla Microsoft Dynamics SL-användare eller alla Microsoft Business Solutions – Solomon-användare är utloggade.

  2. Starta Microsoft SQL Query Analyzer. Eller starta Microsoft SQL Server Management Studio.

  3. Anslut till lämplig Microsoft Dynamics SL-programdatabas eller till Microsoft Business Solutions – Solomon-programdatabasen.

  4. Kör följande instruktioner.

    Delete from Roidetail
    
    Delete from Rptcompany
    
    Delete from Rptruntime
    

Lösning 3

Lös problemet genom att registrera Capicom.dll-filen manuellt. Gör så här:

  1. Leta upp filen Capicom.dll på den lokala datorn. Som standard finns den här filen i följande mapp:

    SystemDrive:\Windows\System32

  2. Kontrollera att versionen av Capicom.dll-filen är 2.1.0.1 eller en senare version. Gör så här:

    1. Högerklicka på filen Capicom.dll och klicka sedan på Egenskaper.
    2. På fliken Version kontrollerar du att filversionen är 2.1.0.1 eller senare.
    3. Klicka på OK.
  3. Högerklicka på filen Capicom.dll och klicka sedan på Öppna med.

  4. I dialogrutan Windows klickar du på Välj programmet i en lista och klickar sedan på OK.

  5. I dialogrutan Öppna med klickar du på Bläddra.

  6. Leta upp och öppna sedan följande mapp:

    SystemDrive:\Windows\System32

  7. Dubbelklicka på filen Regsvr32.exe och klicka sedan på OK.

  8. Klicka på OK när du får följande meddelande:

    RegSvr32 – DllRegisterServer i SystemDrive:\windows\system32\capicom.dll lyckades.

Obs!

Om du får felmeddelandet "System Message 9827" på en dator på en arbetsstation innan du registrerar Capicom.dll-filen måste du köra scenariot Synkronisera alla ägarskap och säkerhetsuppdateringar igen på skärmen Databasunderhåll (98.290.00).

Lösning 4

Lös problemet genom att markera kryssrutan Ingen skrivare i rapportfilen i Business Objects Crystal Reports. Gör så här:

  1. Öppna Crystal Reports och klicka sedan på rapportfilen för att öppna den.
  2. Klicka på Arkiv.
  3. Klicka på Skrivarkonfiguration.
  4. Klicka för att markera kryssrutan Ingen skrivare och klicka sedan på OK.
  5. Klicka på Spara.

Lösning 5

Ändra rapporten i Business Objects Crystal Reports för att ta bort undertryckningen i underrapporten.

  1. Öppna rapportfilen som genererar felet i Affärsobjekt Crystal Reports.

  2. Om det finns en underrapport i något avsnitt i rapporten högerklickar du på underrapporten. Obs! Om det inte finns någon underrapport fungerar inte den här lösningen.

  3. Klicka på Formatera underrapport. Knappen Utelämna formel som visas bör innehålla röd text. Förekomsten av den här röda texten indikerar att det finns en undertryckningsformel. När formeln använder variabler från den överordnade rapporten måste variablerna tas bort.

    Obs!

    • Om du inte får någon indikation på att det finns en undertryckningsformel fungerar inte den här lösningen.
    • Om undertryckningsformeln använder en kombination av underrapportvariabler och överordnade rapportvariabler måste dessa variabler separeras så att de överordnade rapportvariablerna kan tas bort.
    • Om avsnittet som innehåller underrapporten också innehåller andra variabler som visas måste variablerna separeras.
    • Om avsnittet som innehåller underrapporten redan har en undertryckningsformel måste du bestämma om du vill sammanfoga formlerna och hur du gör detta.
  4. Klicka på Utelämna formel för att öppna dialogrutan Formatredigerare och klicka sedan på Välj allapå redigera-menyn .

    Obs!

    Om undertryckningsformeln endast använder variabler från underrapporten fungerar inte den här lösningen.

  5. redigera-menyn klickar du på Kopiera för att kopiera formeln.

  6. Ta bort formeln.

  7. Stäng dialogrutan Formatredigeraren genom att klicka på OK.

  8. Högerklicka på det vänstra avsnittet på skärmen där underrapporten visas och klicka sedan på Avsnittsexpert.

  9. I dialogrutan Avsnittsexpert klickar du på Utelämna formel och klickar sedan på Klistra inpå redigera-menyn för att klistra in formeln.

  10. Klicka på Spara och stäng och klicka sedan på OK.

  11. Klicka på SparaArkiv-menyn.

Lösning 6

Synkronisera användaren. Gör så här:

  1. Använd SQL Server Management Studio för att köra följande instruktion mot Microsoft Dynamics SL-systemdatabasen:

    DELETE FROM RPTExtra
    
  2. Välj scenariot Synkronisera allt ägarskap och säkerhetsuppdatering på skärmen Databasunderhåll (98.290.00) och klicka sedan på Påbörja bearbetning.