Klientens IP-adress för en Outlook 2010-klient är inte inloggad i Exchange när du använder kommandot Get-LogonStatistics program

Symptom

När du använder kommandot Get-LogonStatistics i antingen Microsoft Exchange Server 2007 eller Microsoft Exchange Server 2010 eller Exchange System Manager (ESM) i Microsoft Exchange Server 2003 kanske inte IP-adressen för klienter som kör Microsoft Outlook 2010 visas.

Cmdlet:en Get-LogonStatistics kan till exempel returnera data enligt följande:

alternativtext

Obs!  I den här bilden är posterna för ClientIPAddress tomma. Andra postattribut som inte visas kan också vara tomma, till exempel för ClientName.

I ESM kan du se data som liknar följande:

alternativtext

Orsak

Eftersom sådana attribut kan ses som personligt identifierbar information skickas inte den här informationen till Exchange i Outlook 2010.

Lösning

Viktigt! Det här avsnittet, metoden eller uppgiften innehåller steg som visar hur du ändrar registret. Men om du ändrar registret på fel sätt kan det orsaka allvarliga problem. Se därför till att du följer de här stegen noggrant. För ytterligare skydd bör du skydda registret innan du ändrar det. Du kan sedan återställa registret om det uppstår problem. Om du vill ha mer information om hur du både kan backa och återställa registret kan du klicka på följande artikelnummer och läsa artikeln i Microsoft Knowledge Base:

322756  Säkerhetskopiera och återställa registret i Windows

Obs! Följande avsnitt innehåller steg för att ändra hur personligt identifierbar information (PII) behandlas i Outlook. När du har följer de här instruktionerna skickar Outlook information som vissa personer eller företag kan tänkas ha som PII. Användare och administratörer måste tänka på vem som ska ha tillgång till den Outlook-genererade information som ska lagras på Exchange-servrarna. Det är ditt ansvar att följa alla företags- eller organisationspolicyer för korrekt hantering av PII.

  • Exchange 2003 eller Exchange 2007

Om du vill konfigurera en Outlook 2010-klient för att skicka ytterligare inloggningsstatistikdata till Exchange 2003- eller Exchange 2007-servrarna som den ansluter till gör du så här:

    1. Avsluta Outlook 2010.

    2. Starta Registereditorn:

      För Windows Vista och för Windows 7:

      1. Klicka alternativtext, skriv regedit i rutan Starta sökning och tryck sedan på RETUR.

        alternativtext

        Om du uppmanas att ange ett administratörslösenord eller att bekräfta skriver du lösenordet eller klickar på Tillåt.

      För Windows XP:

      1. Klicka på Start, klicka Kör, skriv regeditoch klicka sedan på OK.

    3. Leta upp och klicka på följande registerundernyckel:

      HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\CancelRPC Observera Om CancelRPC-nyckeln inte finns skapar du den här nyckeln. Gör så här:

      1. Klicka för att välja undernyckeln för Outlook.

      2. Peka på NyttRedigera-menyn, och klicka sedan på Nyckel.

      3. Skriv CancelRPCoch tryck sedan på RETUR.

      4. Välj undernyckeln CancelRPC och gå sedan till steg 4.

    4. Peka på NyttRedigera-menyn och klicka sedan på DWORD-värde.

    5. Skriv EnablePerfTrackingoch tryck sedan på RETUR.

    6. Klicka på ÄndraRedigera-menyn.

    7. Skriv 28och klicka sedan på OK.
      Obs! Det här är ett hexadecimalt värde.

    8. Avsluta Registereditorn.

    9. Starta Outlook 2010.

  • Exchange 2010

Stegen ovan fungerar inte för Exchange 2010. Du kan dock hämta information om klient-IP från loggfilerna i följande mapp på din klientåtkomstserver (CAS).

\Program Files\Microsoft\Exchange Server\v14\Logging\RPC Client Access

Loggfilerna heter RCA_ datum-#.log (där det datum då loggen samlades in och # är ett indexnummer som börjar med 1). Den här loggning är aktiverad som standard, så du behöver inte göra några konfigurationsändringar för att samla in den här informationen.

På följande bild visas ett exempel på den information som du hittar i den här loggfilen.

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Microsoft Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×