Uppdateringskonsekvens för microsoft Dynamics 365-portallösning för distributioner med flera portaler

Den här artikeln innehåller en lösning på ett fel som uppstår när du navigerar till en portal som är associerad med en Dynamics 365 instans som innehåller några lösningar som ännu inte har uppgraderats.

Gäller för: Microsoft Dynamics CRM
Ursprungligt KB-nummer: 4020942

Symptom

Efter en uppgradering av lösningarna som stöder ett portaltillägg i Dynamics 365 Admin Center kan kunder som har flera portaltillägg kopplade till samma Dynamics 365 instans uppleva fel om lösningarna för andra portaltyper ännu inte har uppgraderats. Användare som navigerar till en portal som är associerad med en Dynamics 365 instans som innehåller vissa lösningar som ännu inte har uppgraderats kan få ett fel som liknar följande exempel:

Vi är ledsna, men något gick fel.
[00000000-0000-0000-0000-000000000000]
Vi har fått ett meddelande om det här problemet och vi tar en titt på det inom kort.
Tack för ditt tålamod.

Orsak

När ett portaltillägg distribueras till en Dynamics 365 instans installeras flera lösningar som stöder portalens funktioner. Uppdateringar till dessa lösningar görs tillgängliga när förbättringar och korrigeringar släpps, och kunder kan distribuera dessa uppdateringar genom att vidta lämpliga åtgärder i Dynamics 365 Admin Center.

Eftersom många lösningar delas av flera portaltyper kan uppgradering av en enda portaltyp utan att uppgradera andra portaltyper som distribueras till samma Dynamics 365 instans orsaka fel och kan göra en eller flera portaler oanvändbara.

Åtgärd

För att undvika problem med matchning av lösningsversioner bör lösningarna för alla portaltyper som distribueras till en enda Dynamics 365 instans uppgraderas senare och under samma tidsintervall. Följande steg bör vidtas för att uppgradera portaltilläggslösningarna för alla distribuerade portaltyper:

  1. Logga in på Dynamics 365 Admin Center med en användare med tillräcklig behörighet för att uppgradera Dynamics 365 lösningar.
  2. På fliken Instanser väljer du den instans som har två eller flera portaler distribuerade.
  3. När instansen är markerad väljer du ikonen Lösningar i fönstret till höger.
  4. I vyn Lösningar väljer du en portaltyp (till exempel Community Portal) som har distribuerats till den här instansen.
  5. Om knappen Uppgradera visas i den högra rutan väljer du den för att uppgradera respektive lösningar i den Dynamics 365 instansen.
  6. När uppgraderingen är klar väljer du nästa tillgängliga portaltyp i vyn Lösningar och upprepar steg 5.

När alla portaltyper har uppgraderats uppstår inga ytterligare matchningsfel i lösningsversionen.