Meddelandet "det går inte att ansluta till Exchange" visas när du använder Dynamics 365 app för Outlook

Symptom

När du använder Dynamics 365 app för Outlook visas följande meddelande:

"Kan inte ansluta till Exchange".

Resten av appen kan läsas in, men möjligheten att spåra objekt och använda Ange ämne kan saknas.

Orsak

Detta inträffar vanligtvis när du använder en lokal postlåda i Microsoft Exchange och kan bero på något av följande:

Orsak 1: OAuth-autentisering har inte aktiverats i Exchange

Orsak 2: Det finns ett problem med autentiseringscertifikatet som används av Exchange.

Lösning

Lösning 1: Kontrollera OAuth-autentisering är aktiverad i Exchange

  1. Öppna Exchange Management Shell på Exchange-servern.

  2. Kör följande kommando: Hämta WebServicesVirtualDirectory | FL-Server, * auth *

  3. Kontrollera resultaten som returneras visar att Oauthathentication har angetts till true.

  4. Om OAuthAthentication har angetts till false, måste ett kommando som följande köras: Set-WebServicesVirtualDirectory-identitet "EWS (standardwebbplats)"-OAuthAuthenticat Ion $true

    Ytterligare information

    Den identifiera värdet är namnet på den virtuella katalogen som finns i Exchange administratörs Center genom att klicka på servrar och sedan klicka på virtuella kataloger eller genom att köra följande kommando och granska värdet returnerade:Get-WebServicesVirtualDirectory | FL Mer information om det här kommandot finns i Exchange-dokumentationen: Set-Web

  5. Services

  6. virtuell

  7. kataloghttps://docs.Microsoft.com/PowerShell/module/Exchange/Client-Access-servers/Set-WebServicesVirtualDirectory?View=Exchange-PS Mer information om autentiseringskrav för att tillåta ett Outlook-tillägg för att göra asynkrona Exchange Web Service (EWS)-begäranden finns i följande artikel: Autentisering och behörighet överväganden för makeEwsRequestAsynchttps://docs.Microsoft.com/Outlook/Add-ins/Web-Services#authentication-and-permission-considerations-for-makeewsrequestasync

  8. Kör följande kommando: Hämta OrganizationConfig | FL OAuth2ClientProfileEnabled Om värdet som returneras är falskt, kör du följande kommando: Ställ in OrganizationConfig-OAuth2ClientProfileEnabled: $true

  9. Kontrollera också din version av Exchange har uppdateringen som nämns i följande artikel: Kan inte komma åt EWS från Outlook/OWA Add-ins via makeEwsRequestAsync i Exchange server 2016 och Exchange server 2013https://support.Microsoft.com/help/4056329

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Microsoft Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×