Symptom

Microsoft hanterade tjänster service etablerar Provider (MMSSPP) inte avetablera en Microsoft Exchange-postlåda eller e-postfunktioner objekt från en dedikerad/ITAR Office 365-miljö.

Orsak

Avetablering har flera definitioner, och i samband med Office 365 dedikerad/ITAR, kan dessa tjänster betyda något av följande:

  • Frånkoppling av en postlåda i Office 365 och konvertering av Office 365-objekt till en e-postaktiverad användare. Detta är vanligt i något av följande scenarier:

    • En användarpostlåda migreras till en annan miljö (till exempel från molnet tillbaka till lokalt).

    • Där e-posttjänster är inaktiverade men andra molntjänster (till exempel Lync eller Skype för företag) bibehålls.

    • Där kontaktinformation kan visas i den globala adresslistan (GAL).

    • Där användaren kan vara medlem i en distributions-eller e-postaktiverad säkerhetsgrupp i Office 365.

  • Avetablering av en e-postaktiverad användare eller en kontakt. Detta tar bort post rättigheter och attribut (e-post, MailNickName, LegacyExchangeDN, proxyAddresses, och targetAddress) och tar bort användaren från alla e-postfunktioner distribution eller säkerhetsgrupper i Office 365, men behåller det etablerade Active Directory (AD) objekt.

  • Fullständig borttagning av användarens objekt från Office 365 Active Directory.

  • Konvertering av en aktiv postlåda som är i rättstvist håller till ett inaktivt tillstånd.

  • Borttagning av en e-postaktiverad grupp från Office 365 Active Directory.

Underlåtenhet att avetablera kan förekomma på grund av en eller flera av följande orsaker:

  • Korrekta processer eller bästa praxis för att avetablera objekt inte följs.

  • Ett felkonfigurerat attributvärde som rapporteras i den dagliga MMSSPP Sync felrapport blockerar avetablering av postlådan eller e-postanvändaren.

  • En postlåda är i rättstvist håller. En sådan postlåda kan aldrig avetableras så länge som flaggan är inställd (även om den kan placeras i inaktivt läge).

Bästa praxis

Scenario 1

Användaren har en postlåda i Office 365D/ITAR och postlådan måste avetableras. Office 365D/ITAR-objektet måste dock stanna i GAL som en e-postaktiverad användare.

  1. Kontrollera den dagliga MMSSPP Sync felrapport och åtgärda eventuella fel som rapporteras. När felrapport filen packas upp finns en bifogad hjälpfil tillsammans och åtgärder för varje feltyp.

  2. Lägg till värdet som utlöser postlåda avetablering på det utsedda attributet ta bort tillhandahållande. Gör inga andra ändringar och vänta tills den hanterade postlådan tas bort från Office 365-miljön (den homeMDB attributvärdet blir null). Detta utförs vanligtvis i en eller två MMSSPP synkroniseringscykler.

    1. Attributet som används för avetablering skiljer sig för varje kund, och det är vanligtvis samma värde som används för postlåda etablering värden (till exempel en vanligtvis etablerad postlåda har extensionAttribute9 = MBX = 50GB; Typ = EP2D; REG = EU;).

    2. Värdet som används för avetablering är olika för varje kund. Emellertid, värdet är vanligtvis RemoveMSOMbx (till exempel, extensionAttribute9 = RemoveMSOMbx).

  3. När postlådan är inaktiverad ändrar du attributvärdet för kunden targetAddress så att det pekar på önskad plats utanför Office 365d/ITAR (vanligtvis är detta SMTP: sameasmailvalue) och ta bort attributet ta bort tillhandahållande. Efter vissa synkroniseringscykler är objektet e-postfunktioner och synligt i GAL.

Scenario 2

Om användaren har en postlåda i Office 365D/ITAR, måste postlådan avetableras och Office 365D/ITAR-objekt måste tas bort från Office 365 AD.

  1. Variation 1: Kunden har inte funktionen automatiska tjänster Reconnection (ASR) som är aktiverad för postlådor mellan skogar. Någon av följande metoder är effektiva:

    • Flytta användarobjektet till en organisationsenhet (OU) som inte omfattas av MMSSPP.

    • Ange lämpligt värde för MMSSPP-filtret. Det här värdet anges för varje kund med hänsyn till både attributet och värdet, men dess struktur kan vara något som extensionAttribute1 = NoSync.

    • Använd universalfiltret för MMSSPP. Det här filtret rensar värden från alla följande attribut:

      • Mail

      • MailNickname

      • Proxyaddresses

      • Targetaddress

    • Ta bort objektet från kund annonsen.

  2. Variation 2: Kunden har funktionen Automatisk systemåterställning som har aktiverats för postlådor mellan skogar. I det här fallet objekt som filtreras, flyttas eller tas bort från kunden annonsen orsaka hanterade objekt flyttas till en bevarande ORGANISATIONSENHET (där de är dolda från GAL men fortfarande ta emot e-post) för 1-3 dagar.

    1. Korrigera eventuella synkroniseringsfel.

    2. Lägg till den Deletenow värde till den utsedda postlåda etablering attribut och aktivera minst en synkroniseringscykel ska slutföras. Detta är ett mellanlagringsvärde som inte utlöser avetablering. Den talar om för MMSSPP att när filtret används för att omedelbart ta bort hanterade AD-objektet i stället för att hålla den i Pendingdeletions OU för 1-3 dagar.

    3. Gör någon av ändringarna som anges i variant 1(flytta, Använd det anpassade filtret, Använd universalfiltret eller ta bort).

Scenario 3

Användarens postlåda är i rättstvist håller. I det här fallet är Office 365-postlåda ansluten och hanterade AD-objektet behålls. Detta är den rekommenderade processen för att placera postlådan i en inaktiv rättstvist håller tillstånd:

  1. Om kundens process är att ta bort användarens AD-objekt efter en tid, ändra värdena för den e-post, targetAddress, och SMTP proxyAddresses attribut för att lägga till _old eller _litHold till prefixet. Detta gör att användaren kan komma åt sina ursprungliga e-post och proxyadresser när de återvänder till anställningen. Gör dessa attributändringar innan du följer nästa steg.

  2. Om andra tjänster (till exempel Lync) måste ändras, gör lämpliga attributändringar.

  3. Lägg till typen = InHold; värde till attributet som används för postlåda etablering värden (Detta skiljer sig åt per kund). Använd det här exemplet: MBX = 50GB; Typ = InHold; REG = EU;

  4. Vänta minst en synkroniseringscykel.

  5. När typen = InHold; värdet synkroniseras till Office 365D/ITAR, kan användaren inte längre logga in till postlådan. Postlådan är dold från GAL och avsändare till den postlådan får en rapport om utebliven leverans NDR).

  6. När du har slutfört steg 1-5 kan kundobjektet filtreras, flyttas utanför omfånget eller tas bort.

  7. Om steg 6 är klar innan du Slutför steg 1-5 är den hanterade postlådan fortfarande inaktiv. Men hoppar över dessa steg kan göra frågor svårare och göra återställning av tjänster mer komplexa när användaren återgår till arbetet.

Scenario 4

Lync Dedicated/ITAR-tjänster måste avetableras:

  1. Lync kan avetableras oberoende av postlådestatus genom att ange värdet 0 i attributet som har valts för Lync-etablering. Detta skiljer sig åt för varje kund.

  2. Om användarens postlåda är i rättstvist håller, Lync avetablering värdet 0 måste anges innan kunden objektet filtreras, tas bort från omfattningen eller tas bort från kund annonsen.

Scenario 5

En e-postaktiverad användare (inte en postlådeaktiverad användare) eller e-postaktiverad kontakt måste avetableras. Tänk på att e-postaktiverade användare vanligtvis är användare som kan logga in på kundens domänresurser, men som tar emot e-post i en brevlåda utanför Office 365D/ITAR-miljön. Dessa postlådor kan finnas i kundens lokala miljö eller på en extern tjänst. Om du vill inaktivera en e-postaktiverad användare använder du någon av följande metoder:

  • Flytta användarobjektet till en ORGANISATIONSENHET som inte omfattas av MMSSPP.

  • Ange lämpligt värde för MMSSPP-filtret. Det här värdet anges för varje kund med hänsyn till både attributet och värdet, men dess struktur kan vara något som extensionAttribute1 = NoSync.

  • Använd universalfiltret för MMSSPP. Det här filtret rensar värden från alla följande attribut:

    • Mail

    • MailNickname

    • Proxyaddresses

    • Targetaddress

  • Ta bort objektet från kund annonsen.

Scenario 6

En e-postaktiverad grupp måste avetableras. I det här fallet tas en grupp som har etablerats på Office 365D/ITAR bort från GAL och Active Directory. Dessutom tas den bort som medlem i en grupp som den är medlem i. Någon av följande metoder är effektiv:

  • Rensa e-postvärdet för gruppen.

  • Ta bort gruppobjektet från kund annonsen.

Lösning

Efter övervägande av lämpliga scenarier, kan du korrigera ett misslyckat avetablering scenario med någon av följande metoder.

Scenario 1

En Office 365D/ITAR-postlåda måste avetableras och användaren måste vara e-postfunktioner (inte postlådeaktiverade) i Office 365D/ITAR.

  1. Returnera värdena för attributen mail och targetAddress till de ursprungliga värden som krävs för att etablera en Office 365D/ITAR-postlåda (till exempel är e-postattributsuffixet i SMTP-inkluderingslistan och targetaddress -attributsuffixet liknar @mgd. customerdomain.com).

  2. Ange attributvärdet för postlåda ta bort tillhandahållande (till exempel extensionAttribute9 = removemsombx).

  3. När postlådan har avetablerats ( Get-Recipient- cmdlet hittar ingen eller cmdleten Get-User returnerar ett värde), ange värdena för den e-post och targetAddress attribut till önskat tillstånd för en e-postfunktioner användare.

Scenario 2

Användaren har en postlåda i Office 365D/ITAR, postlådan måste avetableras och Office 365D/ITAR-objekt måste tas bort från Office 365 AD:

  1. Variation 1: Kunden har inte funktionen för automatisk systemåterställning som är aktiverad för postlåda mellan skogar återkopplingar. Någon av följande metoder är effektiv:

    • Flytta användarobjektet till en ORGANISATIONSENHET som inte omfattas av MMSSPP.

    • Ange lämpligt värde för MMSSPP-filtret. Det här värdet anges för varje kund som har respekt för både attributet och värdet, men dess struktur kan vara något som extensionAttribute1 = NoSync.

    • Använd universalfiltret för MMSSPP. Det här filtret rensar värden från alla följande attribut:

      • Mail

      • MailNickname

      • Proxyaddresses

      • Targetaddress

    • Ta bort objektet från kund annonsen.

  2. Variation 2: Kunden har funktionen Automatisk systemåterställning som har aktiverats för postlådor mellan skogar. I det här fallet objekt som filtreras, flyttas eller tas bort från kunden annonsen orsaka hanterade objekt flyttas till en bevarande ORGANISATIONSENHET (där de är dolda från GAL men fortfarande ta emot e-post) för 1-3 dagar.

    1. Korrigera eventuella synkroniseringsfel.

    2. Lägg till den Deletenow värde till den utsedda postlåda etablering attribut och aktivera minst en synkroniseringscykel ska slutföras. Detta är ett mellanlagringsvärde som inte utlöser avetablering. Den talar om för MMSSPP att när filtret används för att omedelbart ta bort hanterade AD-objektet i stället för att hålla den i Pendingdeletions OU för 1-3 dagar.

    3. Gör någon av ändringarna som anges i variant 1 (flytta, Använd det anpassade filtret, Använd universalfiltret eller ta bort).

Scenario 3

Användarens postlåda är i rättstvist håller.

  1. En postlåda avetableras inte så länge som den är på rättstvist håller.

  2. Se avsnittet "bästa praxis" för rekommendationer som rör processen för att flytta en postlåda till en inaktiv rättstvist håller tillstånd.

  3. Endast när en postlåda tas bort från rättstvist håller, åtgärder i Scenario 1 eller 2 kommer att resultera i postlådan som avetableras.

Scenario 4

Användarens postlåda är i rättstvist håller, men är i inaktivt läge innan Lync-tjänster avetableras. Lync-tjänster måste avetableras.

  1. Om kunden objektet är fortfarande i omfattningen av MMSSPP och inte filtreras (postlådan gjordes inaktiv genom att lägga till den Type = InHold; värde till den Provisioning attribut), ange attributvärdet 0 för den Lync etablering bitmask attribut. Det här värdet resulterar i avetablering av Lync-tjänster efter vissa synkroniseringscykler. Till exempel extensionAttribute6 = 15 ändras till extensionAttribute6 = 0.

  2. Om användarens postlåda är i rättstvist håller, och kunden filtreras eller tas bort objektet från scope innan du avetablerar Lync, måste ytterligare åtgärder vidtas för att avetablera Lync:

    1. Med kunden objektet fortfarande filtreras eller utanför OU scope, lägga till den Type = InHold; värde till den postlåda etablering attributet (om det inte redan har angetts). Detta är mycket viktigt om postlådan är avsedd att förbli inaktiv. Om värdet inte har lagts till skickas postlådan till aktiv status (Aktivera inloggning och e-postleverans) så snart den har returnerats till scopet.

    2. Ange den Lync bitmask attributvärdet till 0.

    3. Ta bort filtret eller flytta tillbaka kundobjektet till ORGANISATIONSENHETS omfång.

    4. Lync-tjänster avetableras efter vissa synkroniseringscykler.

    5. När Lync avetablering har slutförts kan kunden objektet lämnas oförändrad, filtreras, tas bort från omfång eller tas bort enligt kundpolicy.

Scenario 5

En e-postaktiverad användare (inte en postlådeaktiverad användare) eller e-postaktiverad kontakt måste avetableras. Om du vill inaktivera en e-postaktiverad användare är någon av följande metoder effektiv:

  • Flytta användarobjektet till en ORGANISATIONSENHET som inte omfattas av MMSSPP.

  • Ange lämpligt värde för MMSSPP-filtret. Det här värdet anges för varje kund som har respekt för både attributet och värdet, men dess struktur kan vara något som extensionAttribute1 = NoSync.

  • Använd universalfiltret för MMSSPP. Det här filtret rensar värden från alla följande attribut:

    • Mail

    • MailNickname

    • Proxyaddresses

    • Targetaddress

  • Ta bort objektet från kund annonsen.

Scenario 6

En e-postaktiverad grupp måste avetableras. I det här fallet tas en grupp som har etablerats på Office 365D/ITAR bort från GAL och Active Directory. Dessutom tas den bort som medlem i en grupp som den är medlem i. Något av följande är effektivt:

  • Rensa e-postvärdet för gruppen.

  • Ta bort gruppobjektet från kund annonsen.

Kommentarer

  • När ett användarobjekt har etablerats i Office 365D/ITAR, undviker du att rensa attributvärdet för e-post. Avmarkera attributet inte avetablera en postlåda och det kan göra frågeresultat tvetydiga och rutinmässiga underhållsuppgifter onödigt komplicerade.

  • Det här dokumentet är avsett att ge bästa praxis och enkla reparationssteg för att avetablera e-post och Lync-tjänster i Office 365D/ITAR miljöer. Andra åtgärder som vidtas av kunden kan resultera i avetablering av tjänster. Mer information finns i Office 365D/ITAR-handboken för etableringsverktyg.

  • När en postlåda avetableras, oavsett metod, tas den inte bort direkt från Office 365D/ITAR. I stället behålls den i ett frånkopplat tillstånd för den konfigurerade kvarhållningsperioden (normalt 30 dagar), under vilken tid den kan återanslutas automatiskt (om det ursprungliga användarobjektet är ofiltrerad eller flyttas tillbaka till MMSSPP-scope) eller manuellt återansluts (genom en eskalering till Microsoft Support-tjänster).

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Microsoft Insiders

Hade du nytta av den här informationen?

Hur nöjd är du med översättningskvaliteten?
Vad påverkade din upplevelse?

Tack för din feedback!

×