Mottagaren inte ta emot e-postmeddelanden som Microsoft Dynamics CRM-användare skickar genom att använda Microsoft Dynamics CRM-webbklienten

Symptom

I Microsoft Dynamics CRM 3.0-webbklienten

När Microsoft Dynamics CRM-användare skickar ett e-postmeddelande med hjälp av Microsoft Dynamics CRM 3.0-webbklienten, får mottagaren inte e-postmeddelandet. Det här problemet uppstår när följande villkor är uppfyllda:

  • Komponenter för Microsoft Dynamics CRM server och Microsoft Exchange Server är installerade på separata servrar.

  • Under installationen av Microsoft Dynamics CRM server-komponenter Skriv namnet på Exchange-servern som namnet på inkommande Simple Mail Transfer Protocol (SMTP) server och utgående SMTP-servernamn.

  • Microsoft Dynamics CRM-servern har en lokal SMTP-tjänsten installerats.

Obs! Du kan se de olösta e-postmeddelandena i följande katalog på Microsoft Dynamics CRM-servern:

C:\Inetpub\mailroot\BadmailDessutom kan du få följande felmeddelande:

"Det gick inte att initiera nyckeln" initiera Token FailureT

Webbklienten för Microsoft Dynamics CRM 4.0 eller Microsoft Dynamics CRM 2011

När Microsoft Dynamics CRM-användare skickar ett e-postmeddelande med hjälp av webbklienten för Microsoft Dynamics CRM 4.0 eller Microsoft Dynamics CRM 2011, skickas e-postmeddelandet eller köer. Men om ett problem inträffar när användaren skickar e-postmeddelandet, får användaren ett av följande felmeddelanden visas i e-postaktiviteten.

Felmeddelande 1

Detta meddelande har inte skickats för leverans ännu. 1 försök har gjorts hittills.

Felmeddelande 2

Det gick inte att leverera meddelandet. Det måste skickas för vidare bearbetning.

Dessutom visas ett felmeddelande av följande slag i händelseloggen för MSCRMEmailLog:

Händelsen typ: fel

Händelse källa: MSCRMEmailLog

Händelsekategori: ingen

Händelsen ID:0

Date:Date
Time:Time
User:N/A

Computer:ComputerName
Beskrivning: #61042 - ett fel inträffade vid bearbetning av utgående e-postmeddelande med ämnet "test 3 idag CRM:0001011" för SMTP: http://adsrv:81/MS1 för leverans via adsrv. System.Net.Mail.SmtpException: Fel i e-post skickas. ---> System.Net.WebException: Det gick inte att ansluta till fjärrservern---> System.Net.Sockets.SocketException: ingen anslutning kan göras eftersom måldatorn aktivt nekade det.

vid System.Net.Sockets.Socket.DoConnect (endPointSnapshot slutpunkt, socketadress socketadress)

vid System.Net.Sockets.Socket.InternalConnect (EndPoint-remoteEP)

vid System.Net.ServicePoint.ConnectSocketInternal (booleska connectFailure, Socket s4, Socket s6 Socket & socket, IP-adress och adress, ConnectSocketState tillstånd, IAsyncResult asyncResult, Int32 timeout undantag & undantag)

Torrsubstanshalt slut stackdump torrsubstanshalt

vid System.Net.ServicePoint.GetConnection (PooledStream PooledStream, objektets ägare, booleska asynkrona, IP-adress och adress, Socket & abortSocket Socket & abortSocket6, Int32 timeout)

vid System.Net.PooledStream.Activate (objektet owningObject, booleska asynkrona, Int32 timeout, asyncCallback GeneralAsyncDelegate)

vid System.Net.PooledStream.Activate (objektet owningObject, GeneralAsyncDelegate, asyncCallback)

vid System.Net.ConnectionPool.GetConnection (objektet owningObject, asyncCallback GeneralAsyncDelegate, Int32 creationTimeout)

vid System.Net.Mail.SmtpConnection.GetConnection (String värd, Int32-port)

vid System.Net.Mail.SmtpTransport.GetConnection (String värd, Int32-port)

vid System.Net.Mail.SmtpClient.GetConnection()

vid System.Net.Mail.SmtpClient.Send (MailMessage-meddelande)

Torrsubstanshalt slut stackdump torrsubstanshalt

vid System.Net.Mail.SmtpClient.Send (MailMessage-meddelande)

vid Microsoft.Crm.Tools.Email.Providers.SmtpPollingSendEmailProvider.SendMessage (MailMessage mailMessage)

vid Microsoft.Crm.Tools.Email.Providers.SmtpPollingSendEmailProvider.ProcessMessageInternal (e-emailMessage)

vid Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.ProcessMessage (e-emailMessage)

vid Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()



Mer information finns i Hjälp- och supportcenter på http://go.microsoft.com/fwlink/events.asp.

Orsak

Microsoft Dynamics CRM är beroende av den lokala SMTP-servern ska vidarebefordra e-postmeddelanden till Exchange-servern. Problemet beror på något av följande skäl:

  • SMTP-konfiguration för Microsoft Dynamics CRM-servern är inte konfigurerad för att vidarebefordra e-postmeddelanden till Exchange-servern.

  • Exchange server är inte konfigurerad för att vidarebefordra meddelanden från Microsoft Dynamics CRM-servern.

Lösning

Följ instruktionerna för att lösa problemet.

Steg 1: Konfigurera SMTP på Microsoft Dynamics CRM-servern för att vidarebefordra e-postmeddelanden till Exchange-servern

  1. Öppna Internet Information Services (IIS) på Microsoft Dynamics CRM-servern. Genom att klicka på Start, klicka på Administrationsverktygoch klicka sedan på Internet Information Services (IIS) Manager.

  2. Expandera Standard för virtuell SMTP-Serveri Internet Information Services (IIS) Manager, högerklicka på domäner, peka på Nyttoch klicka sedan på domän.

  3. I guiden Ny SMTP-Klicka på fjärrdatorn under Ange domän typoch klicka sedan på Nästa.

  4. Skriv in ditt domännamn i rutan namn och klicka sedan på Slutför.

  5. Högerklicka på domännamnet som du lade till i steg 2 till 4 i den högra rutan, och klicka sedan på Egenskaper.

  6. På fliken Allmänt markerar du kryssrutan Tillåt inkommande e-post vidarebefordras till den här domänen och klicka sedan på Vidarebefordra all e-post till smart värd. I rutan under Vidarebefordra all e-post till smart värd, Skriv namnet på Exchange-servern.

  7. Starta om SMTP-tjänsten i Microsoft Dynamics CRM-servern. Genom att klicka på Start, klicka på Administrationsverktygoch klicka sedan på tjänster. Högerklicka på Simple Mail Transfer Protocol (SMTP)och klicka sedan på Starta om.

Steg 2: Konfigurera Exchange server så att meddelanden från Microsoft Dynamics CRM-servern

Exchange Server 2003

Om du använder Microsoft Exchange Server 2003 måste du först konfigurera begränsningar för vidarebefordran och kontrollera anslutningar kontroll.

Konfigurera begränsningar för återutsändning
  1. Klicka på Start, peka på program, peka på Microsoft Exchangeoch klicka sedan på System Manager.

  2. Klicka på servrar, namnet på Exchange-servern, protokolloch klicka sedan på SMTP.

  3. Högerklicka på Standard för virtuell SMTP-Server, klicka på Egenskaperoch klicka sedan på fliken åtkomst .

  4. Klicka på Relayi området Begränsningar för återutsändning .

  5. Kontrollera att alternativet endast listan nedan och sedan lägga till Microsoft Dynamics CRM-servern i listan.

    Om du använder Microsoft Dynamics CRM 4.0 eller Microsoft Dynamics CRM 2011, se till att du lägger till en server där Exchange router installerad i listan.

  6. Starta om SMTP-tjänsten. Gör så här:

    1. Klicka på Start, peka på program, peka på Administrationsverktygoch klicka sedan på tjänster.

    2. Högerklicka på Simple Mail Transfer Protocol (SMTP)och klicka sedan på Starta om.

Kontrollera anslutningar kontroll
  1. Klicka på Start, peka på program, peka på Microsoft Exchangeoch klicka sedan på System Manager.

  2. Klicka på servrar, namnet på Exchange-servern, protokolloch klicka sedan på SMTP.

  3. Högerklicka på Standard för virtuell SMTP-Server, klicka på Egenskaperoch klicka sedan på fliken åtkomst .

  4. Klicka på anslutningi kontrollområdet för Anslutningar .

  5. Som standard markeras alternativet alla utom listan nedan . Om Microsoft Dynamics CRM-server läggs till i listan, måste du kontakta Exchange-administratören om du vill ta reda på varför Microsoft Dynamics CRM-servern har lagts till.

    Obs! Microsoft Dynamics CRM-servern måste vara ansluta till Exchange-servern för Microsoft Dynamics CRM e-postmeddelanden ska fungera korrekt.

  6. Om alternativet endast listan nedan är markerat måste du lägga till Microsoft Dynamics CRM-servern i listan för att ansluta till Exchange-servern.

  7. Starta om SMTP-tjänsten om du ändrat inställningar för anslutning. Gör så här:

    1. Klicka på Start, peka på program, peka på Administrationsverktygoch klicka sedan på tjänster.

    2. Högerklicka på Simple Mail Transfer Protocol (SMTP)och klicka sedan på Starta om.

Exchange Server 2007

Om du använder Microsoft Exchange Server 2007 måste du skapa en ny Exchange ta emot koppling, konfigurera connector för anonyma användare, konfigurera behörigheter för protokoll för ta emot kopplingen och starta om Microsoft Exchange Transport-tjänsten på Exchange-servern.

Skapa ett utbyte får connector
  1. Öppna Exchange Management Console.

  2. Expandera serverkonfiguration.

  3. Klicka på Hub Transport.

  4. Högerklicka på Får kopplingaroch klicka sedan på Nytt ta emot koppling.

  5. Skriv ett namn i rutan namn .

  6. Klicka på Nästai listan Välj den avsedda användningen för den här kopplingen ta emotinternt.

  7. Klicka på Lägg tilli avsnittet Remote nätverksinställningar och Skriv IP-adressen för Microsoft Dynamics CRM-servern.


    Obs! Om värdet 0.0.0.0-255.255.255.255 visas klickar du på Ta bort.

  8. Klicka på Nästa, klickar du på Nyoch klicka sedan på Slutför.

Konfigurera anslutning för anonyma användare
  1. Högerklicka på Exchange får kopplingen som du skapat och klicka sedan på Egenskaper.

  2. Klicka på fliken Behörighetsgrupper .

  3. Kontrollera att alternativet Ange vem som får ansluta till ta emot kopplingentill anonyma användareoch klicka på Verkställ.

Konfigurera behörigheter för protokoll för kopplingen ta emot

Obs! Du måste ha Windows Support Tools installerat för att kunna slutföra de här stegen. Endast erfarna administratörer bör använda verktyget Adsiedit.msc.

  1. Starta verktyget Adsiedit.msc.

  2. Expandera konfiguration, expandera Services, expandera Microsoft Exchange, expandera CN = första organisation, expandera Administrativa grupper, expandera Exchange administrativa gruppenExpandera servrar, protokoll, och expandera sedan Tar emot SMTP-anslutningar.

  3. Högerklicka på Exchange får kopplingen som du skapat och klicka sedan på Egenskaper.

  4. Klicka på fliken säkerhet .

  5. Klicka på Anonym inloggning.

  6. Klicka på markerar du kryssrutan Skicka meddelanden till mottagare och Avsändare acceptera auktoritär domän , klicka på Verkställoch klicka sedan på OK.

Starta om Microsoft Exchange Transport-tjänsten på Exchange-servern
  1. Klicka på Start, Kör, Skriv services.mscoch klicka sedan på OK.

  2. Högerklicka på Microsoft Exchange Transport-tjänstenoch klicka sedan på Starta om.

Referenser

Mer information om hur du felsöker problem med inkommande och utgående e-post finns på följande Microsoft TechNet-webbplats:

http://technet.microsoft.com/en-us/library/gg583996.aspxMer information om hur du tillåter programservrar vidarebefordra av Exchange Server 2007 finns på följande Microsoft-webbplats:

http://msexchangeteam.com/archive/2006/12/28/432013.aspx

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Microsoft Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×