Vm-gästen kan inte ändras eller tas bort från en skyddsgrupp i Data Protection Manager

Den här artikeln innehåller en lösning på ett fel som uppstår när du ändrar en skyddsgrupp eller tar bort en virtuell dator från en skyddsgrupp.

Ursprunglig produktversion: System Center 2016 Data Protection Manager
Ursprungligt KB-nummer: 4018988

Symptom

När du försöker ändra en skyddsgrupp som innehåller virtuella Hyper-V-datorgäster eller försöker ta bort en virtuell dator från en skyddsgrupp får du ett felmeddelande som liknar följande:

Det gick inte att ta bort Guest_Name:
Fel 157: Guest_Name kan inte läggas till i skyddet eftersom det redan är medlem i en skyddsgrupp.

Orsak

Det här problemet beror på dubbletter av poster i DPM-databasen. Dubblettposterna kan inträffa när en skyddad virtuell dator har migrerats från ett Hyper-V-kluster till ett annat Hyper-V-kluster och sedan skyddas den virtuella datorn på nytt i det nya klustret.

Åtgärd

Åtgärda problemet genom att kontakta Microsoft Support om du behöver hjälp med att ta bort de duplicerade posterna. Aktivera direktmigrering för att förhindra framtida förekomster. Det gör du genom att läsa Konfigurera skydd för direktmigrering.