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You receive one of the following error messages when you start Microsoft FRx, create a new reporting tree, or generate a Microsoft FRx report:

Error message 1

FRx Reporting Engine Error 6 – Overflow

Error message 2

Run-time Error 6 - Overflow

Symptoms

Cause 1

The GL Index (.g32) file for the company that you are trying to access is damaged. To resolve this problem, see resolution 1.

Cause 2

The reporting tree is damaged. To resolve this problem, see resolution 2.

Cause 3

The MaxUnits value in the FRx.ini file is not large enough. To resolve this problem, see resolution 3.

Cause 4

The computer is set to the default short date format of Microsoft Windows. To resolve this problem, see resolution 4.

Cause 5

The row format building block or the column layout building block is damaged. To resolve this problem, see resolution 5.

Cause 6

The accounts or the formulas are incorrect in the row format building block or the column layout building block of the report. To resolve this problem, see resolution 6.

Cause 7

You use a Citrix application and dual monitors. To resolve this problem, see resolution 7.

Cause 8

You print a report that has 13 columns or more to a single page, and the page orientation is set to portrait. To resolve this problem, see resolution 8.

Cause

Resolution 1

To resolve this problem, delete or rename the .g32 files that are located in the SysData folder. To do this, follow these steps.

Note Before you follow these steps, make sure that all users have exited Microsoft FRx and have made a backup of the FRx SysData folder.

  1. Start Microsoft FRx. To do this, click Start, point to All Programs, point to FRx 6.7, and then click Report Designer.

  2. Enter the appropriate logon information if you are prompted.

  3. Click Admin, click Organization, and then click SysData.

  4. Note the path that is listed in the Current Directory box, and then exit Microsoft FRx.

  5. Click Start, and then click Run.

  6. In the Open box, type the path that you noted in step 4, and then click OK.

    The shared SysData folder opens.

  7. Delete or rename all the .g32 files in the shared SysData folder.

  8. Start Microsoft FRx.

  9. In Microsoft FRx, click Company, click Select Default, select a production company, and then click OK.

  10. Enter the appropriate logon information if you are prompted.

  11. Repeat steps 7 through 10 for each company to re-create all the .g32 files.

Resolution 2

To resolve this problem, re-create the reporting tree. To do this, follow these steps.

Note You may want to print a copy of the reporting tree structure to use as a resource when you create the new reporting tree.

  1. Start Microsoft FRx. To do this, click Start, point to All Programs, point to FRx 6.7, and then click Report Designer.

  2. Enter the appropriate logon information if you are prompted.

  3. Click Reporting Trees, select a reporting tree, and then click OK.

  4. On the File menu, click Print Reporting Tree, and then click OK.

  5. Create a new reporting tree. To do this, click File, point to New, and then click Tree.

    Use the printout that you created in step 4 as a reference to create the new reporting tree.

  6. On the File menu, click Save As, enter a unique name in the Name box, and then click OK.

  7. On the File menu, click Close.

  8. Click the drop-down arrow in the Reporting Tree box, and then select the new reporting tree.

  9. In the toolbar, click Generate Report.

  10. On the File menu, click Save to save the report.

Resolution 3

To resolve this problem, use a text editor to increase the MaxUnits value in the FRx.ini file. To do this, follow these steps:

  1. Exit Microsoft FRx.

  2. Click Start, click Search, click All files and folders, type FRx.ini, and then click Search.

  3. Open FRx.ini by using a text editor such as Notepad.

  4. In the section called [Network], find the line that begins with MaxUnits=, and then increase the MaxUnits value by 10,000.

  5. Save the FRx.ini file, and then close the file.

  6. Repeat the steps that caused the error to occur. If the error continues, repeat steps 1 through 5 until the error no longer occurs.

Resolution 4

To resolve this problem, change the computer's short date style and long date style. To do this, follow these steps:

  1. Click Start, click Control Panel, and then double-click Regional and Language Options.

  2. On the Regional Options tab, click Customize this format.

  3. In the Customize Regional Options dialog box, click the Date tab.

  4. In the Date format section, verify that the short date is in one of the following 4-digit year configurations:

    1. M/d/yyyy

    2. MM/dd/yyyy

    3. yyyy/MM/dd

    If the short date is set to a different format, click the drop-down arrow in the Short date format box, and then click a 4-digit year format.

  5. Re-create the .g32 files. To do this, follow the steps in Resolution 1.

Resolution 5

To resolve this problem, duplicate the report building blocks that are used in the report that produces the error message. To do this, follow these steps:

  1. Start Microsoft FRx. To do this, click Start, point to All Programs, point to FRx 6.7, and then click Report Designer.

  2. Enter the appropriate logon information if you are prompted.

  3. Click Catalog of Reports, click a report, and then click OK.

  4. On the File menu, point to Open, and then click Row.

  5. In the Search field, enter the row format name from the Row Format field on the Building Blocks tab of the report catalog, and then click OK.

  6. On the File menu, click Save As, enter a unique name in the Name field, and then click OK.

  7. On the File menu, click Close.

  8. In the Row Format field, click the drop-down arrow, and then click the new row format.

  9. Click the Generate Report button in the toolbar.

  10. If the report generates without error, click Save on the File menu to save the report.

    If you continue to encounter the error, follow similar steps to duplicate the column layout report building block and the reporting tree report building block.

Note This procedure creates a new report that uses the same row format and column layout as the original report.

Resolution 6


To resolve this problem, correct the accounts or the formulas in the row format building block or in the column layout building block of the report. To do this, follow these steps:

  1. Start Microsoft FRx. To do this, click Start, point to All Programs, point to FRx 6.7, and then click Report Designer.

  2. Enter the appropriate logon information if you are prompted.

  3. Click Catalog of Reports, click a report, and then click OK.

  4. On the File menu, point to Open, and then click Row.

  5. In the Search box, enter the row format name that currently populates the Row Format field on the Building Blocks tab of the report, and then click OK.

  6. Make sure that all the CAL rows are formatted correctly and that they reference the correct row numbers and calculations.

  7. Make sure that all the CALC type columns are formatted correctly in the column layout. Follow steps that resemble steps 1 through 6 to open the report's column layout.

  8. Make sure that all the account numbers are correct in the row format's Link to GL columns.

Resolution 7

Configure the Citrix application to use a single display or a smaller display resolution. To do this, use one or more of the following methods:

  • Disable the secondary monitor on the computer that is running the Citrix client.

  • Configure the Citrix published application to use a set window size. To do this, follow these steps.

    1. Start Citrix Program Neighborhood.

    2. Double-click Application Set Manager, click Application Set, and then click Settings.

    3. Click the Default Options tab. Set a window size that is not full-screen. For example, set a window size of 1024 × 768.

  • Create a custom Independent Computing Architecture (ICA) connection to the single, published application that uses the same Window Size setting as the setting in step 2e. For more information about how to do this, see Citrix online Help.

Resolution 8

To resolve this problem, change the page orientation to landscape. To do this, follow these steps:

  1. Start Microsoft FRx. To do this, click Start, point to All Programs, point to FRx 6.7, and then click Report Designer.

  2. Enter the appropriate logon information if you are prompted.

  3. Click Catalog of Reports, select a report, and then click OK.

  4. On the File menu, click Page Setup.

  5. Click Landscape, click Save, and then click Generate Report.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Resolution

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