Internetbrandväggar kan förhindra surfning och fildelning

Om du aktiverar en brandvägg kan du inte söka eller dela filer med andra datorer i ett hemnätverk.

Gäller för: Windows 10 – alla utgåvor, Windows Server 2012 R2
Ursprungligt KB-nummer: 298804

Symptom

När du har aktiverat en Internetbrandvägg kanske du inte kan söka efter andra datorer i ditt hem- eller kontorsnätverk. Och du kanske inte kan dela filer med andra datorer i ditt hem- eller kontorsnätverk. När du till exempel aktiverar ICF-funktionen (Internet Connection Firewall) i Windows XP upptäcker du att du inte kan bläddra i nätverket med hjälp av My Network Places. Om du använder net view \\computername kommandot för att visa resurser på en dator i ditt hem- eller kontorsnätverk kan du få följande felmeddelande:

Systemfel 6118 har inträffat. Listan över servrar för den här arbetsgruppen är inte tillgänglig för närvarande.

Orsak

Det här beteendet kan inträffa om du aktiverar en brandvägg i nätverksanslutningen som du använder för ditt hem- eller kontorsnätverk. Som standard stänger en brandvägg de portar som används för fil- och utskriftsdelning. Syftet är att förhindra att Internetdatorer ansluter till fil- och utskriftsresurser på datorn.

Åtgärd

Lös problemet genom att endast använda en brandvägg för nätverksanslutningar som du använder för att ansluta direkt till Internet. Använd till exempel en brandvägg på en enda dator som är ansluten till Internet direkt via ett kabelmodem, ett DSL-modem eller ett uppringt modem. Om du använder samma nätverksanslutning för att ansluta till både Internet och ett hem- eller kontorsnätverk använder du en router eller brandvägg som hindrar Internetdatorer från att ansluta till delade resurser på hem- eller kontorsdatorerna.

Använd inte en brandvägg på nätverksanslutningar som du använder för att ansluta till ditt hem- eller kontorsnätverk, såvida inte brandväggen kan konfigureras för att endast öppna portar för ditt hem- eller kontorsnätverk. Om du ansluter till Internet med hjälp av ditt hem- eller kontorsnätverk kan en brandvägg endast användas på datorn eller på den andra enheten, till exempel en router, som tillhandahåller anslutningen till Internet. Om du till exempel ansluter till Internet via ett nätverk som du hanterar och nätverket använder anslutningsdelning för att ge Internetåtkomst till flera datorer, kan du installera eller aktivera en brandvägg endast på den delade Internetanslutningen. Om du ansluter till Internet via ett nätverk som du inte hanterar kontrollerar du att nätverksadministratören använder en brandvägg.

Status

Detta är avsiktligt.

Mer information

En brandvägg är programvara eller maskinvara som skapar en skyddsbarriär mellan datorn och potentiellt skadligt innehåll på Internet. Det hjälper till att skydda datorn mot skadliga användare och mot många datorvirus och maskar.

Viktigt

Om du konfigurerar en brandvägg för att skydda datorportar som är anslutna till Internet rekommenderar vi inte att du öppnar dessa portar eftersom de kan exponeras för andra datorer på Internet. Dessutom kan vissa datorer inte beviljas åtkomst till de öppna portarna.

Följande portar är associerade med SMB-kommunikation (fildelning och servermeddelandeblock):

  • Microsofts fildelnings-SMB: UDP-portar (User Datagram Protocol) från 135 till 139 och TCP-portar (Transmission Control Protocol) från 135 till 139.
  • SMB-trafik med direkt värd utan ett grundläggande nätverkssystem för in- och utdata (NetBIOS): port 445 (TCP och UDP).

Teknisk support för Windows x64-utgåvor

Maskinvarutillverkaren tillhandahåller teknisk support och hjälp för Microsoft Windows x64-utgåvor. Maskinvarutillverkaren har stöd eftersom en Windows x64-version ingår i maskinvaran. Maskinvarutillverkaren kan ha anpassat installationen av Windows x64-utgåvan med unika komponenter. Unika komponenter kan innehålla specifika enhetsdrivrutiner eller inkludera valfria inställningar för att maximera maskinvarans prestanda. Microsoft kommer att ge rimlig hjälp om du behöver teknisk hjälp med din Windows x64-utgåva. Du kan dock behöva kontakta tillverkaren direkt. Tillverkaren är bäst lämpad att stödja den programvara som tillverkaren har installerat på maskinvaran.

Mer information finns i Skydda min dator från virus.