Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

You are prompted repeatedly for Exchange credentials after a mailbox is migrated to Exchange Online Dedicated vNext in Microsoft Skype for Business 2016.

Cause

This issue occurs because Skype for Business 2016 incorrectly tries to connect to the old URL of Exchange Web Services (EWS).

Resolution

To fix this issue, install the March 14, 2017, update (KB3178656) for Skype for Business 2016.


Additionally, you have to set the following Group Policy settings or in-band settings through custom Client Policy:


Group Policy settings

  1. Open the Group Policy Management panel, and then create a Group Policy Object (GPO).

  2. Enter the name of the new GPO. Leave the source as "none."

  3. On the Settings tab, press and hold (or right-click) Computer Configuration or User Configuration, and then select Edit.

  4. Press and hold (or right-click) the registry key, and then select New Registry Item from the drop-down menu. You can deploy the registry key under Computer Configuration or User Configuration.

  5. Specify the registry information in the following form:

    • Action: Create

    • Hive: HKEY_CURRENT_USER

    • Key path: Software\Policies\Microsoft\Office\16.0\Lync

    • Value name: ClearAllEwsMailboxTasksOnAutoDiscoverRequest

    • Value type: REG_DWORD

    • Value data: 1

    • Base: Decimal

  6. Repeat the previous steps for following registry entry:

    PromptUserToResignInOnNonExistentMailboxFailure

    • Action: Create

    • Hive: HKEY_CURRENT_USER

    • Key path: Software\Policies\Microsoft\Office\16.0\Lync

    • Value name: PromptUserToResignInOnNonExistentMailboxFailure

    • Value type: REG_DWORD

    • Value data: 1

    • Base: Decimal

In-band settings


You can create a policy to prompt the user to sign in again, and add the policy to the global client policy. To do this, run the following cmdlet:

$a = New-CsClientPolicyEntry -Name PromptUserToResignInOnNonExistentMailboxFailure -Value "true"
$b = New-CsClientPolicyEntry -Name ClearAllEwsMailboxTasksOnAutoDiscoverRequest -Value "true"
Set-CsClientPolicy -Identity Global -PolicyEntry @{Add=$a, $b}

More Information

  • Handle the case in which a user's Exchange mailbox is being migrated. When the Exchange server returns ErrorNonExistentMailbox, and the appropriate registry key is set, show a messagebox to the user to sign out and then sign back in.

  • Cache the auto settings when the Exchange subject alternative name (SAN) is the same as the Lync Front End domain name or the Lync Front End of the on-premises or dedicated deployment.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×