โปรแกรมประยุกต์ไคลเอ็นต์ของ Outlook ไม่สามารถเชื่อมต่อกับโฟลเดอร์สาธารณะหลังจากที่คุณติดตั้ง Exchange Server 2010 SP1

อาการ

โปรแกรมประยุกต์ไคลเอ็นต์ของ Microsoft Outlook บางโปรแกรมประสบปัญหาในการเชื่อมต่อ เมื่อเธรดการบริการจำนวนมากของ Microsoft Exchange RPC Client Access ในโฟลเดอร์สาธารณะรอการตอบสนองจากบริการที่พร้อมใช้งาน ตัวอย่างเช่น ปัญหานี้จะเกิดขึ้นเมื่อมีมากกว่า 500 เธรดที่รอการตอบสนองในโฟลเดอร์สาธารณะ

หมายเหตุ

  • ไม่มีตัวเลือกที่จะปิดใช้งานบริการที่พร้อมใช้งานบนเซิร์ฟเวอร์ Exchange Server 2010 Service Pack (SP1)
  • หากคุณเริ่มการบริการของ Exchange RPC Client Access ใหม่บนเซิร์ฟเวอร์ของโฟลเดอร์สาธารณะ Exchange Server 2010 SP1 ปัญหานี้จะได้รับการแก้ไขชั่วคราว

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากคุณลักษณะใหม่ใน Exchange Server 2010 SP1 คุณลักษณะใหม่นี้จะใช้การบริการของ Microsoft Exchange RPC Client Access เป็นพร็อกซีสำหรับบริการที่พร้อมใช้งานรุ่นก่อนหน้า (ข้อมูลว่าง/ไม่ว่าง) ดังนั้น หากคุณได้ติดตั้งโฟลเดอร์สาธารณะไว้บนเซิร์ฟเวอร์ Exchange Server 2010 SP1 การร้องขอข้อมูลว่าง/ไม่ว่างจะถูกสกัดกั้นโดยการบริการของ Microsoft Exchange RPC Client Access

การแก้ไข

ข้อมูลรีจิสทรีคีย์

สิ่งสำคัญ ส่วน วิธีการ หรืองานนี้ประกอบด้วยขั้นตอนต่างๆ เกี่ยวกับวิธีการปรับเปลี่ยนรีจิสทรี อย่างไรก็ตาม ปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีไม่ถูกต้อง ดังนั้น โปรดตรวจสอบให้แน่ใจว่าคุณได้ทำตามขั้นตอนเหล่านี้อย่างระมัดระวัง สำหรับการป้องกันเพิ่มเติม ให้สำรองรีจิสทรีก่อนทำการปรับเปลี่ยน เพื่อที่คุณจะสามารถคืนค่ารีจิสทรีได้หากมีปัญหาเกิดขึ้น สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสำรองข้อมูลและคืนค่ารีจิสทรี ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความใน Microsoft Knowledge Base:
322756 วิธีการสำรองข้อมูลและคืนค่ารีจิสทรีใน Windows
เมื่อต้องการแก้ไขปัญหานี้ ให้ติดตั้งโปรแกรมปรับปรุงต่อไปนี้บนเซิร์ฟเวอร์ของ Exchange Server 2010 SP1:
2497453 การแก้ไข: โปรแกรมประยุกต์อาจหยุดการตอบสนองหลังจากการร้องขอหลายครั้งของ HTTP ถูกยกเลิก หากคุณใช้คลาส HttpWebRequest เพื่อส่งคำร้องขอใน .NET Framework

หมายเหตุ
: เมื่อต้องการแก้ไขปัญหานี้ ให้ติดตั้งชุดการปรับปรุงสำคัญที่รวบรวมไว้ต่อไปนี้:
2579150 คำอธิบายของชุดการปรับปรุงสำคัญที่รวบรวมไว้ชุดที่ 4 สำหรับ Exchange Server 2010 Service Pack 1


เมื่อต้องการให้เราปิดใช้งานบริการที่พร้อมใช้งานให้กับคุณ หลังจากที่คุณได้ติดตั้งการปรับปรุงนี้ ให้ไปที่ส่วน "แก้ไขปัญหาให้ฉัน" หากคุณต้องการปิดใช้งานบริการที่พร้อมใช้งานด้วยตนเอง ให้ไปที่ส่วน "ให้ฉันแก้ไขด้วยตนเอง"

แก้ไขปัญหาให้ฉัน



เมื่อต้องการปิดใช้งานบริการที่พร้อมใช้งานโดยอัตโนมัติ ให้คลิกปุ่มหรือการเชื่อมโยง Fix it จากนั้น คลิก เรียกใช้ ในกล่องโต้ตอบ ดาวน์โหลดแฟ้ม และทำตามขั้นตอนต่างๆ ในตัวช่วยสร้าง Fix it




หมายเหตุ
  • ตัวช่วยสร้างนี้อาจมีเฉพาะภาษาอังกฤษ อย่างไรก็ตาม การแก้ไขอัตโนมัติจะทำงานกับ Windows รุ่นภาษาอื่นด้วย
  • ถ้าคุณไม่ได้อยู่ที่เครื่องคอมพิวเตอร์ที่มีปัญหา ให้บันทึกโซลูชัน Fix it ลงในแฟลชไดรฟ์หรือซีดี แล้วเรียกใช้บนคอมพิวเตอร์ที่มีปัญหา

จากนั้นไปที่ส่วน "วิธีนี้แก้ไขปัญหาได้หรือไม่"



ให้ฉันแก้ไขด้วยตนเอง

หลังจากที่คุณติดตั้งการปรับปรุงแล้ว ให้ทำตามขั้นตอนเหล่านี้เพื่อปิดใช้งานบริการที่พร้อมใช้งาน: 
  1. คลิก เริ่ม คลิก เรียกใช้ พิมพ์ regedit ในกล่อง เปิด แล้วคลิก ตกลง
  2. ค้นหาและคลิกที่คีย์ย่อยของรีจิสทรีต่อไปนี้:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\
  3. บนเมนู แก้ไข ชี้ไปที่ สร้าง แล้วคลิก คีย์
  4. พิมพ์ ParametersSystem แล้วกด ENTER
  5. ค้นหาและคลิกที่คีย์ย่อยของรีจิสทรีต่อไปนี้:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\ParametersSystem
  6. บนเมนู แก้ไข ชี้ไปที่ สร้าง แล้วคลิก ค่า DWORD
  7. พิมพ์ DisableAvailabilityServiceCalls แล้วกด ENTER
  8. ในบานหน้าต่างแสดงรายละเอียด คลิกขวาที่ DisableAvailabilityServiceCalls แล้วคลิก ปรับเปลี่ยน
  9. ในกล่อง ข้อมูลค่า ให้พิมพ์ 1 แล้วคลิก ตกลง
  10. ออกจากตัวแก้ไขรีจิสทรี
หมายเหตุ หากคุณเลือกที่จะรอชุดการปรับปรุงสำคัญที่รวบรวมไว้ชุดที่ 4 สำหรับ Exchange Server 2010 SP1 จะเป็นการแปลงกลับฟังก์ชันการทำงานที่ได้รับผลกระทบให้กลับไปเป็นฟังก์ชันการทำงานของ Exchange Server 2010 RTM


วิธีนี้แก้ไขปัญหาได้หรือไม่

  • ตรวจสอบว่าปัญหาได้รับการแก้ไขแล้วหรือไม่ หากปัญหาได้รับการแก้ไข แสดงว่าคุณสิ้นสุดขั้นตอนในส่วนนี้แล้ว ถ้าปัญหาไม่ได้รับการแก้ไข คุณสามารถ ติดต่อฝ่ายสนับสนุน
  • เราขอบคุณสำหรับคำติชมของคุณ เมื่อต้องการแสดงคำติชมหรือรายงานปัญหาต่างๆ เกี่ยวกับการแก้ไขนี้ โปรดฝากความคิดเห็นไว้ในบล็อก "แก้ไขปัญหาให้ฉัน" หรือส่งข้อความอีเมลถึงเรา

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "นำไปใช้กับ"

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับบริการที่พร้อมใช้งาน โปรดเข้าสู่เว็บไซต์ Microsoft TechNet ต่อไปนี้:
คุณสมบัติ

รหัสบทความ: 2535105 - การตรวจสอบครั้งสุดท้าย: 23 ม.ค. 2012 - ฉบับแก้ไข: 1

คำติชม