You cannot find the customer when you use the customer search to find a customer for a transaction in Microsoft Dynamics AX for Retail 2012 POS

This article applies to Microsoft Dynamics AX for Retail 2012 for all regions.

Symptoms

Assume that you use the customer search to find a customer for a transaction in Microsoft Dynamics AX for Retail 2012 POS. However, you cannot find the customer. For example, you have a customer who is named as AAK. In Danish_norweigan_CI_AS, it is the same as ÅK. When the form sorts it in English, the letter does not exist.

Cause

This problem occurs because the search result shows in grid is a copy of result and the original result is sorted by database according to the collation of the database.However, the grid always sorts the copy result automatically according to SQL_Latin1_General_CP1_CI_AS sorting rules without affecting original result. If collation sorting rules differs from the SQL_Latin1_General_CP1_CI_AS sorting rules, the copies of result are inconsistent. The selected item is fetched by mistake from the original result by index of the copy result.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, visit the following Microsoft website: You can also contact technical support for Microsoft Dynamics by phone using these links for country specific phone numbers. To do this, visit one of the following Microsoft websites:

PartnersCustomersIn special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.


Installation information

If you have customizations for one or more of the methods or the tables that are affected by this hotfix, you must follow these steps:
  1. Review the changes that are documented in the .xpo file.
  2. Apply these changes in a test environment before you apply the hotfix in a production environment.


For more information about how to install this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:
893082 How to install a Microsoft Dynamics AX hotfix

Prerequisites

You must have Microsoft Dynamics AX for Retail 2012 installed to apply this hotfix.

Restart requirement

You must restart the Application Object Server (AOS) service after you apply the hotfix.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
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Microsoft Dynamics AX 2012, Microsoft Dynamics AX for Retail

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