ผลลัพธ์การค้นหาไม่สมบูรณ์อาจเกิดขึ้นใน Outlook เมื่อติดตั้งตัว iFilter PDF

อาการ

  • เมื่อคุณใช้การค้นหาทันที ใน Microsoft Outlook คุณได้รับข้อความแจ้ง "ไม่พบรายการ" หรือคุณได้รับข้อความของแถบข้อมูลที่ระบุ "ผลลัพธ์การค้นหาอาจไม่สมบูรณ์เนื่องจากรายการยังกำลังถูกทำดัชนี"
  • ถ้าคุณตรวจสอบสถานะของการทำดัชนี คุณเห็นมีสินค้าคงเหลือจะจัดทำดัชนีในหน้าต่างสถานะการทำดัชนี
  • เมื่อคุณตรวจทานเหตุการณ์ลงในบันทึกเหตุการณ์ของโปรแกรมประยุกต์ คุณเห็นรายการที่ มีพารามิเตอร์ต่อไปนี้:
รหัสเหตุการณ์แหล่งที่มาประเภทงานคำอธิบาย
10023ค้นหาตัวรวบรวมกระบวนการโฮสต์ของโพรโทคอล < PID > ไม่ตอบสนอง และกำลังถูกบังคับให้หยุดการทำงานของ {กรองกระบวนการโฮสต์ 6104
10024ค้นหาตัวรวบรวมขั้นตอนการโฮสต์ตัวกรอง < PID > ไม่ตอบสนอง และถูกบังคับให้หยุดการทำงาน


สาเหตุ

ปัญหานี้เกิดขึ้นเมื่อตัว iFilter PDF stalls ทำดัชนีค้นหาของเดสก์ท็อปของ Windows บ่อยที่กำลังทำดัชนีใหม่ของรายการ Outlook ที่ทำให้เกิด

การแก้ปัญหา

เมื่อต้องการแก้ไขปัญหานี้ กรุณาปรับปรุงโปรแกรมประยุกต์ใด ๆ ที่มีหน้าที่การใช้งานแฟ้ม PDF มีแพทช์ล่า จากนั้น ให้ทำตามขั้นตอนเหล่านี้เพื่อสร้างดัชนีใหม่
  1. ในแผงควบคุม คลิกทำดัชนีตัวเลือก

    ถ้าตัวเลือกการทำดัชนีไม่ปรากฏใน'แผงควบคุม' พิมพ์ตัวเลือกการทำดัชนีในกล่องข้อความค้นหา Control Panelแล้ว คลิ กผลลัพธ์การค้นหาตัวเลือกการทำดัชนี
  2. ในกล่องโต้ตอบตัวเลือกการทำดัชนีคลิกขั้นสูง
  3. คลิกสร้างใหม่
  4. คลิกตกลงในกล่องโต้ตอบสร้างดัชนี

ข้อมูลเพิ่มเติม

ถ้าคุณใช้เครื่องมือตัววิเคราะห์การตั้งค่าคอนฟิก Office (OffCAT) เพื่อระบุปัญหานี้ พาธและชื่อของไฟล์.dll สำหรับ iFilter ที่พบในส่วนรายละเอียดการตั้งค่าคอนฟิกของการสแกน OffCAT ของคุณ ค้นหาแฟ้มนี้บนคอมพิวเตอร์ของคุณ และจากนั้น ตรวจสอบคุณสมบัติของการตรวจสอบผู้ผลิตของแฟ้ม ซึ่งจะให้การบ่งชี้ของแอพลิเคชันที่คุณอาจต้องปรับปรุงบนคอมพิวเตอร์ของคุณเพื่อแก้ไขปัญหานี้


คุณสมบัติ

รหัสบทความ: 2925203 - การตรวจสอบครั้งสุดท้าย: 24 ก.พ. 2017 - ฉบับแก้ไข: 1

Outlook 2016, Microsoft Outlook 2013, Microsoft Outlook 2010, Microsoft Office Outlook 2007

คำติชม