NDRs for health mailboxes are stuck in queue in Exchange 2016 or 2013

Symptoms

Consider the following scenario:

  • You have a Microsoft Exchange 2016 or Microsoft Exchange 2013 environment.
  • Multiple accepted domains are configured.
  • The default accepted domain is not the primary SMTP address in the Default Policy email address policy.
In this scenario, non-delivery report (NDR) messages for the health mailboxes are stuck in the Shadow and Outbound SmarHostConnect queues.

Cause

This problem occurs because the managed availability probe for inbound messages uses the default accepted domain, and the health mailboxes do not contain an SMTP address that uses this domain.

Resolution

To resolve this problem, use one of the following methods.

Method 1

Add the default accepted domain as a secondary SMTP address to the Default Policy email address policy.

For more information, see the following TechNet topic:

Method 2

Change the default accepted domain to match the primary SMTP address in the Default Policy email address policy.

For more information, see the following TechNet topic:

More information

For more information about the Set-EmailAddressPolicy cmdlet, see the following TechNet topic:
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Microsoft Exchange Server 2013 Enterprise

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