อาการ
บริการการวินิจฉัยของ microsoft Exchange หยุดทำงานซ้ำๆในสภาพแวดล้อม Microsoft Exchange Server ๒๐๑๓ บริการการวินิจฉัยไม่สามารถสร้างหรือเริ่มบันทึกประสิทธิภาพการทำงานได้ นอกจากนี้คุณจะได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้ในบันทึกเหตุการณ์:
ข้อผิดพลาด๔๙๙๙รายงานServerName.Contoso.com Watson Date/Timeเมื่อต้องการส่งสำหรับ Id กระบวนการ: ProcessIDด้วยพารามิเตอร์: E12IIS, c-RTL-AMD64, VersionNumber, การวินิจฉัยการใช้งาน, การวินิจฉัย. PerformanceLogger, PerformanceLogSet, StartLog, ArgumentException, 95c6, VersionNumber, nErrorReportingEnabled, ServerName.Contoso.com,,,, VersionNumber,,,,,,,
ข้อผิดพลาด๑๐๐๗วันที่/เวลาที่ไม่สามารถสร้างหรือเริ่มบันทึกประสิทธิภาพการทำงานที่มีข้อผิดพลาด: ArgumentException: Value ไม่อยู่ภายในช่วงที่คาดไว้ ที่ PlaLibrary DataCollectorSetClass (บูลีนแบบซิงโครนัส) ที่ Microsoft. PerformanceLogger. PerformanceLogSet StartLog (บูลีนแบบซิงโครนัส) ที่ Microsoft. PerformanceLogger. PerformanceLogMonitor. CheckPerflogStatus () แฟ้มบันทึกประสิทธิภาพการทำงาน: ExchangeDiagnosticsPerformanceLog MSExchangeDiagnostics ServerName.Contoso.com
ตัวกำหนดเวลางานจัดเก็บ GUID ของงานเก่าในหน่วยความจำและวิธีเดียวที่จะล้างข้อมูลเหล่านั้นคือการเริ่มบริการใหม่และล้างงานด้วยตนเอง
สาเหตุ
ปัญหานี้เกิดขึ้นเนื่องจากตัวนับความล้มเหลวที่ทริกเกอร์โดยตัวจัดกำหนดการงานเกินขีดจำกัดและไม่สามารถเรียกข้อมูลจากไฟล์ที่เกี่ยวข้องได้
การแก้ไข
เมื่อต้องการแก้ไขปัญหานี้ให้ติดตั้งการอัปเดตที่สะสม 19สำหรับ exchange server ๒๐๑๓หรือการอัปเดตที่สะสมในภายหลังสำหรับ exchange server ๒๐๑๓
สถานะ
Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "นำไปใช้กับ"
อ้างอิง
เรียนรู้เกี่ยวกับคำศัพท์เฉพาะทางที่ Microsoft ใช้เพื่ออธิบายการอัปเดตซอฟต์แวร์