Unable to send SMTP Email

This article provides a solution to an error that occurs when you try to send mails via your own SMTP server from a newly created Flow app.

Applies to:   Microsoft Dynamics 365
Original KB number:   4535859

Symptoms

You try to send mails via your own SMTP server from a newly created Flow app, but you meet a problem while setting up the connection.

Cause

SSL (Secure Sockets Layer) connection isn't enabled.

Resolution

To fix this issue, you could request to enable the SSL connection and check the security settings for your account. If you enabled two-step verification, try using your app password. Otherwise, enable access for less secure apps.

Screenshot to enable the SSL connection in the SMTP setting.