ข้ามไปที่เนื้อหาหลัก
การสนับสนุน
ลงชื่อเข้าใช้

ขั้นตอนทั่วไป

เมื่อต้องการตรวจสอบให้แน่ใจว่าการติดตั้งเสร็จสมบูรณ์ ตรวจสอบให้แน่ใจว่า:

  • คุณใช้ตัวติดตั้งล่าสุดPower Automateเดสก์ท็อป

  • คุณมีสิทธิ์ระดับผู้ดูแลระบบ: ตัวติดตั้งจะขอให้คุณมีสิทธิ์ระดับผู้ดูแลระบบ และล้มเหลวถ้าคุณเลือกไม่

  • คุณรีสตาร์ตเครื่องแล้ว: Windowsการเปลี่ยนแปลงบางอย่างต้องเริ่มต้นระบบใหม่เพื่อให้มีผลและอาจบล็อกการติดตั้งของคุณ

  • คุณเรียกใช้ OS ที่ได้รับการสนับสนุนเวอร์ชันล่าสุดWindows: Windows 10 (Home, Pro or Enterprise) หรือ Windows Server 2016 หรือใหม่กว่า

ปัญหาและวิธีแก้ปัญหาชั่วคราวเกี่ยวกับการติดตั้งที่ทราบแล้ว

Power Automateเริ่มต้นบริการใหม่: ไม่สามารถโหลด DLL 'uiflowsclient.dll'

สาเหตุ

การติดตั้งล้มเหลวเนื่องจากบริการ Power Automate Windows ไม่สามารถเริ่มได้ และแฟ้มบันทึกของตัวแสดงเหตุการณ์แสดงให้เห็นว่าสาเหตุที่ไม่สามารถเริ่มได้คือ "ข้อยกเว้น System.DllNotFound: ไม่สามารถโหลด DLL 'uiflowsclient.dll'"

วิธีแก้ไขปัญหาชั่วคราว

ถอนการติดตั้ง Microsoft Visual C++ 2015-2019 แบบแจกจ่ายต่อได้

ไปที่การตั้งค่า >แอป>แอป&ฟีเจอร์ต่างๆ และถอนการติดตั้ง แล้วติดตั้งอีกครั้งPower Automateเดสก์ท็อป ตัวPower Automateเดสก์ท็อปจะติดตั้ง C++ แบบแจกจ่ายต่อได้อีกครั้ง ถอนการติดตั้ง Visual C++

บริการ Power อัตโนมัติไม่สามารถเริ่มได้: ตรวจสอบว่าคุณมีสิทธิ์เพียงพอที่จะติดตั้งบริการระบบ

เมื่อต้องการยืนยันว่าปัญหานี้เป็นปัญหาที่คุณพบปัญหา ให้ค้นหาเหตุการณ์ต่อไปนี้ในตัวแสดงเหตุการณ์:

สาเหตุ

บัญชีที่ใช้ในการเริ่มบริการ Power Automateบริการไม่สามารถเริ่มบริการได้เนื่องจากนโยบาย "ปฏิเสธการเข้าสู่ระบบเป็นบริการ" ป้องกันไม่ให้บริการนี้

ตามค่าเริ่มต้นและระหว่างการติดตั้ง UIFlowService จะเรียกใช้เป็น NT SERVICE\UIFlowService บัญชีผู้ใช้ที่ใช้โดย UIFlowService สามารถเปลี่ยนแปลงได้ในภายหลัง แต่เพื่อวัตถุประสงค์ในการติดตั้ง บัญชีนั้นจะต้องไม่ถูกบล็อกจากการเข้าสู่ระบบ

การแก้ไข

อัปเดตนโยบาย "ปฏิเสธการเข้าสู่ระบบเป็นบริการ" เพื่อเอาบัญชีผู้ใช้หรือกลุ่มที่ป้องกันไม่ให้ NT SERVICE\UIFlowService เข้าสู่ระบบในฐานะบริการ

ตัวอย่าง: Everyone

ไม่สามารถผูกใบรับรอง SSL ได้

เมื่อต้องการยืนยันว่าปัญหานี้เป็นปัญหาที่คุณพบ ให้ดูที่แฟ้มบันทึกของตัวติดตั้ง (ดูที่ส่วนการรวบรวมข้อมูลการวินิจฉัยด้านล่าง) เกี่ยวกับ "ข้อยกเว้นถูกทิ้งในขณะที่ SetServiceUrlAcl"

สาเหตุ

เมื่อPower Automateจะผูกใบรับรอง SSL อาจล้มเหลวด้วยเหตุผลบางอย่าง

การแก้ไข

เมื่อต้องการดูรายละเอียดเพิ่มเติมเกี่ยวกับสาเหตุหลัก ให้เรียกใช้สั่ง PowerShell ต่อไปนี้ หนึ่งในนั้นควรล้มเหลวด้วยรหัสข้อผิดพลาดที่เฉพาะเจาะจงซึ่งจะให้ข้อมูลเชิงลึกเกี่ยวกับวิธีการลดปัญหา:

$sslport = 8443
$applicationId = [string]::Format("{{{0}}}", "33BEDDD1-E697-4606-B306-C5DFE7AE0AAE")
$serviceUser = "[USER account]" # TODO: fill with domain\alias
$thumb = "[Certificate thumbprint to bind - certificate located in LocalMachine\My cert store]" # TODO: fill certificate thumbprint

function ExitIfError {
    if ($LASTEXITCODE -ne 0) {
        exit 1
    }
}

Write-Host port: $sslport; thumb: $thumb; applicationId=$applicationId

Write-Host [2] Adding all IP addresses to the IP listen list
netsh http add iplisten ipaddress=0.0.0.0

Write-Host [3] Trying to remove the previous certificate on port $sslPort
netsh http delete sslcert ipport=0.0.0.0:$sslPort

Write-Host [4] Binding port $sslPort to certificate with thumbprint $thumb
netsh http add sslcert ipport=0.0.0.0:$sslPort certhash=$thumb appid=$applicationId verifyclientcertrevocation=disable
& netsh http show sslcert ipport=0.0.0.0:$sslPort # displaying the cert binding
ExitIfError

Write-Host [5] Giving access to https://+:$sslPort/UiFlowDispatcher/ to user $serviceUser
netsh http add urlacl url=https://+:$sslPort/UiFlowDispatcher/ user=$serviceUser

การรวบรวมข้อมูลการวินิจฉัย

เพื่อให้เข้าใจและแก้ไขการติดตั้งได้ดีที่สุด ข้อมูลต่อไปนี้สามารถช่วยได้:

  • บันทึกตัวติดตั้ง : บันทึกเหล่านี้สามารถพบได้ในโฟลเดอร์ %temp% ของผู้ใช้ที่ติดตั้ง (พิมพ์ "temp%' ในแถบที่อยู่ของ File Explorer แล้วกด Enter) มีสองไฟล์ที่จะไปที่นั่นด้วยรูปแบบต่อไปนี้: Power_Automate_Desktop_*.logและPower_Automate_Desktop_*_*_MicrosoftFlowRPA.logคุณสามารถสั่งซื้อไฟล์ตาม "วันที่ปรับเปลี่ยน" เพื่อให้การค้นหาง่ายยิ่งขึ้น  บันทึกตัวติดตั้ง PAD ไฟล์ Power_Automate_Desktop_*.log ถูกลิงก์บนหน้าจอความล้มเหลวของตัวติดตั้ง และจะมีเหตุผลทั่วไปว่าเหตุใดการติดตั้งจึงล้มเหลว ไฟล์ Power_Automate_Desktop_*_*_MicrosoftFlowRPA.log มีบันทึกโดยละเอียดเพิ่มเติมเกี่ยวกับการติดตั้ง

  • บันทึกของตัวแสดงเหตุการณ์: แฟ้มบันทึกเหล่านี้จะมีประโยชน์เมื่อWindowsไม่สามารถเริ่มบริการได้ เปิดตัวWindowsเหตุการณ์นําทางWindows แอปพลิเคชัน>บันทึกและค้นหาข้อผิดพลาด บันทึกตัวแสดงเหตุการณ์

  • บันทึกโปรแกรมข้อมูล : มีบันทึกของคอมโพเนนต์ที่เราติดตั้งบนเครื่องของคุณ คุณสามารถค้นหาได้ที่เส้นทางต่อไปนี้: %programdata%\Microsoft\Power Automate Desktop\Logsบันทึกเหล่านี้จะต้องให้สิทธิ์ระดับผู้ดูแลระบบถูกคัดลอกไปยังโฟลเดอร์อื่น คุณจะต้องคัดลอกก่อนที่จะสามารถเปิดได้ เนื้อหาของโฟลเดอร์นี้เป็นแบบเขียนเท่านั้น

ถ้าคุณต้องการติดต่อฝ่ายสนับสนุน โปรดส่ง 4 รายการเป็นไฟล์ zip พร้อมตั๋วของคุณ:

  1. Power_Automate_Desktop_*.log

  2. Power_Automate_Desktop_*_*_MicrosoftFlowRPA.log

  3. รายการบันทึกของตัวแสดงเหตุการณ์:

    • เลือก กรองบันทึกปัจจุบันเพื่อบันทึกที่ถูกต้องเท่านั้น (เช่น ชั่วโมงสุดท้าย)

    • คลิกขวาบนข้อผิดพลาดที่เลือก

    • เลือก บันทึกไฟล์บันทึกที่กรองเป็น และบันทึกเป็นไฟล์ evtx

  4. %programdata%\Microsoft\Power Automateไฟล์ Desktop\Logs

ต้องการความช่วยเหลือเพิ่มเติมหรือไม่

ขยายทักษะของคุณ
สำรวจการฝึกอบรม
รับฟีเจอร์ใหม่ก่อนใคร
เข้าร่วม Microsoft Insider

ข้อมูลนี้เป็นประโยชน์หรือไม่

คุณพึงพอใจกับคุณภาพการแปลแค่ไหน
สิ่งที่ส่งผลกระทบต่อประสบการณ์ใช้งานของคุณ

ขอบคุณสำหรับคำติชมของคุณ

×