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Summary

This article describes issues that may occur when you try to use a timesheet or employee expense report in Project Time and Expense for Business Portal in Microsoft Dynamics GP. You may receive two error messages when the issues that are listed in the "Cause" section in this article occur. A resolution is provided for each issue.

Symptoms

If you try to create a new a timesheet or employee expense in Project Time and Expense for Business Portal, you receive the following error messages:

Error message 1

You are not authorized to view this page.

Error message 2

An unexpected error has occurred.


These error messages may also appear when you try to view other pages in Project Time and Expense for Business Portal, such as when you click the Project Time option or the Project Expense option.

Note To create a new timesheet in Project Time and Expense for Business Portal, click Project, click Project Time, and then click New. To create a new expense sheet, click Project, click Project Expense, and then click New.

Cause

You may receive these error messages when you experience any one of the following issues:

  • The functional currency is missing.

  • Personal Data Keeper (PDK) was not installed correctly.

  • PDK was not set up correctly.

  • The employee is not configured correctly in Great Plains.

  • The Business Portal user is not assigned correctly in Site Settings.

  • The Project Time and Expense installation did not successfully finish.

  • The currency ID on current transactions is missing or incomplete.

  • The currency index on current transactions is missing or incomplete.

  • The employee has been removed from the access list of a project he had previously entered a transaction for.

  • The manager or supervisor for the employee has changed.

Resolution

The functional currency is missing

In Microsoft Dynamics GP, follow these steps to add the functional currency:

  1. On the Microsoft Dynamics GP menu, point to Tools, point to Setup, point to Financial, and then click Multicurrency .

  2. Enter a currency for both the functional currency and the reporting currency.

  3. In the Default Transaction Rate Types section, enter a rate type for the Financial, Sales, and Purchasing lines.

Note Complete these steps even if you are not registered for multicurrency.

Personal Data Keeper (PDK) is not installed correctly

Follow these steps to reinstall Personal Data Keeper.

  1. Initialize PDK in Microsoft Dynamics GP.

    Click Tools, point to Utilities, point to Project, and then click Initialize PDK.

  2. Run the grant.sql script in the Microsoft SQL Server 2000 SQL or in Microsoft SQL Server 2005 Query Analyzer against the Dynamics database and all the Company databases.

    The grant.sql script is located on your local hard disk drive in the directory where Great Plains is installed.

    Open the SQL folder, and then open the Util folder.

  3. Install Personal Data Keeper.

    Note You can install Personal Data Keeper from the Great Plains 8.0 PS Time and Expense for Microsoft Business Portal CD 2.

Personal Data Keeper (PDK) is not set up correctly

Follow these steps to set up Personal Data Keeper correctly.

  1. Log on to PDK as the sa user.

  2. Click Setup, point to System, enter your PDK system password, and then click User.

    Create a User ID, and then assign the user to an employee in Dynamics GP

  3. Click to select the appropriate option to make this user an Employee, a Manager, or a Supervisor.

    Assign the Manager or Supervisor who is responsible for an employee approval to a specific employee. Then, click to select the approval boxes.

  4. Click Timesheets or Expenses to select additional options if they are required.

The employee information is not configured correctly in Microsoft Dynamics GP

Start Dynamics GP, and then review the following items:

  1. If pay codes are being used, verify that each employee has a Default Pay Code set up. 

    To check this, click Cards, point to Payroll, point to Employee, and then click Project.

  2. Verify that the Unit of Measure is correct.  
    To verify this, follow these steps:

    • On the Microsoft Dynamics GP menu point to Tools, point to Setup, point to Project, and then click Timesheets.

      You will see one of the following fields:

      • Default Pay Codes From

      • Default Unit Costs From

      Check to see if this field is set to Employee, Budget, or Cost Category.

    • If the field is set to Employee, click Cards, click Payroll, point to Employee, and then click Project.

      If the field is set to Budget, click Cards, point to Project, and then click Project.

      Select the project from the Project Maintenance menu, and then type the Project Number in Project No. Then, click Budget.

      If the field is set to Cost Category, click Cards, point to Project, and then click Cost Category.

    • Make sure that the Unit of Measure field for the Employee, Budget, or Cost Category is spelled "Hour."

      Note The syntax is important.

    • Click Cards, point to Project, and then click Project.

      Select the project, and then click Budget.

      Select your Cost Category.

      Click the Expansion button next to the Cost Category.

      Note If the Unit of Measure and the Unit of Measure schedule are not correct, try to change them. You cannot change these fields if you have entered time for this Cost Category.

      If these fields are not correct and you cannot change them, create a new Cost Category with a similar name.

      Select the correct Unit of Measure and Unit of Measure Schedule and use this new cost category going forward.

  3. If you want the employee to be able to enter employee expenses, click Cards, point to Payroll, and then click Employee.

    Select the employee, and then click Project. Mark the Files Employee Expense field.

  4. The employee must be assigned to the access list of at least one project.

    To assign an employee to a list, click Cards, point to Project, and then click Project Access List.

    Select the employee, and then add the appropriate projects.

The Business Portal user is not assigned correctly in Site Settings

  1. Log on to Business Portal with a user who has been granted Administrator rights.

  2. Click Site Settings, click Users and Permissions, and then click Manage Business Portal Users.

    1. Link the user to a Dynamics GP employee in the Advanced Roles section of the page. 

      Click Modify, and then change Role to Employee/Your Company.

      Select the employee, and then click OK.

    2. Assign the user to the appropriate portal role in the Portal Roles section of the Manage Business Portal Users page.

      Click Modify. Then, click to select Timesheet Creator, Expense Creator, Project Approver, or all three options.

    3. Make sure that two users are not assigned to the same employee.

      Examine the advanced role of each user. Click each user name in the User List.

    4. After you make changes to a user, close the browser.

  3. Log on to Business Portal again. Click Project, and then click Project Time.

The Project Time and Expense part of the Business Portal installation did not successfully finish

  1. In Microsoft Windows Explorer, open the following folder to locate the SQL scripts that you must have to complete the installation of Project Time and Expense:

    Program Files\Dynamics GP\Business Portal\Utilities\SQL\Company\PMA

  2. By using Query Analyzer, run the following scripts against your company database in the following specified order:

    • Table.Pma.sql

    • View.Pma.sql

    • View.PmaCanadianPayroll.sql

    • Proc.Pma.sql

    • Proc.Function.Pma.sql

    • Data.Pma.sql

The currency ID on current transactions is missing or incomplete

Note Before you follow these steps, make sure that you have a complete backup copy of the company database that you can restore if a problem occurs.

  1. By using Query Analyzer, run the following script against your company database.

    SELECT * FROM PDK10500 WHERE CURNCYID = ''
  2. If results are returned, run the following scripts against your company database.

    SELECT * FROM MC40000

    Note Notice the value in the FUNLCURR field. Use it to replace the XXXX placeholder in the following script.

    UPDATE PDK10500 SET CURNCYID = ‘XXXX’
  3. Repeat step 2 by replacing the PDK10500 table in the second script with the PDK10000 table.

The currency index on current transactions is missing or incomplete

Note Before you follow these steps, make sure that you have a complete backup copy of the company database that you can restore if a problem occurs.

  1. By using Query Analyzer, run the following script against your company database.

    SELECT * FROM PDK10500 WHERE CURRNIDX = ‘’
  2. If results are returned, run the following scripts against your company database.

    SELECT * FROM MC40000

    Note Notice the value in the FUNCRIDX field. Use it to replace the YYYY placeholder in the following script.

    UPDATE PDK10500 SET CURRNIDX = ‘YYYY’
  3. Repeat step 2 by replacing the PDK10500 table in the second script with the PDK10000 table.


Employee is removed from the access list

If an employee is removed from the access list of a project, and then attempts to review or edit a document that had that project, the error may appear. The employee must be on the access list at the time the document is submitted and approved.

1. Run this script in Microsoft SQL Server Management Studio to find any projects that have timesheets where the employee is no longer on the access list.


select a.PDK_TS_NO, a.EMPLOYID, a.PAPROJNUMBER, b.PAPROJNUMBER from PDK10001 a
left outer join PA01408 b
on
a.PAPROJNUMBER=b.PAPROJNUMBER
and a.EMPLOYID=b.EMPLOYID
where b.PAPROJNUMBER is null

2. Add the employee back on to the project's access list. On the Cards menu, point to Project, and then click Project. Select your project and click Access List to add your employee.

3. Either modify your document by deleting the offending line from it if it is not correct, or submit and process it through.

The manager or supervisor of the employee has changed.


If the manager or supervisor assigned to the employee in PDK User Setup has changed since the document was first entered, the error may appear.

Note The manager and supervisor is captured at the time the document is initially entered.

1. Run this script in Microsoft SQL Server Management Studio to find any unprocessed timesheets that have a manager or supervisor in PDK User Setup that is different from the manager or supervisor on the timesheet. 

select a.* from PDK10000 a, DYNAMICS..PDK40001 b
where a.EMPLOYID = b.EMPLOYID
and (a.MANAGER <> b.MANAGER or a.SUPERVISOR <> b.SUPERVISOR)
and a.PDK_Document_Status < 8

2. If results are returned, then you can either approve the timesheet in Personal Data Keeper (PDK), or change the PDK User Setup back to the manager and supervisor that were on the employee record before. To do this log into PDK as the sa user, then on the Setup menu, point to System, and then click User.

More Information

Other troubleshooting tips

  • Stop and then start Internet Information Services (IIS).

  • Stop and then start Microsoft SQL Server.

  • Delete temporary Internet files.

  • Examine the Event Viewer in IIS for warnings.

  • Close your browser, and then reopen it.

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