"0x000000C4" Stop error after you restart a Windows 7-based, Windows 8-based, Windows Server 2008 R2-based or Windows Server 2012-based computer that has the Driver Verifier tool enabled

Symptoms

Assume that you enable the Driver Verifier tool on a computer that uses certain processors. The computer is running one of the following operating systems:
  • Windows 7
  • Windows Server 2008 R2
  • Windows 8
  • Windows Server 2012
When you restart the computer, the computer crashes before the Desktop is displayed. Additionally, you receive a Stop error message that resembles the following:

STOP: 0x000000C4 (parameter1, parameter2, parameter3, parameter4)
Notes
  • This Stop error describes a DRIVER_VERIFIER_DETECTED_VIOLATION issue.
  • The parameters in this Stop error message vary, depending on the configuration of the computer.
  • Not all "Stop 0x000000C4" errors are caused by this issue.

Cause

This issue occurs because Driver Verifier incorrectly detects that the interrupt service routine (ISR) for the driver has corrupted the extended thread context. Driver Verifier captures XSAVE areas before and after an ISR is called, and compares the values to verify that the context is not corrupted by the ISR. However, the areas differ in the feature mask in some cases. Then, Diver Verifier incorrectly flags the change as a violation. Therefore, the computer crashes.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2 SP1
  • Windows 8
  • Windows Server 2012
For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.
Additional file information
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Makale No: 2816159 - Son İnceleme: 15 May 2013 - Düzeltme: 1

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