FIX: Cannot connect to a mailbox when MAPI over HTTP protocol is used in an on-premises Exchange Server 2016 installation

Symptoms

After you install the on-premises version of Exchange Server 2016 and you add the CGI module of Internet Information Services (IIS) during the installation, users cannot connect to their mailboxes when they use the MAPI over HTTP protocol.

Cause

This issue occurs because the CGI module is locked. This causes MAPI over HTTP endpoints not to initialize.

Cumulative update information

For Exchange Server 2016

To resolve this issue, install Cumulative Update 2 for Exchange Server 2016 or a later cumulative update for Exchange Server 2016.

Workaround

To work around this issue, follow these steps:

  1. Locate the Web.config file. By default, this file is located in the following folders:
    • C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\mapi\nspi
    • C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\mapi\emsmdb

  2. Open the file in a text editor such as Notepad.exe.
  3. Delete the following lines in the file:
    • <remove name="CgiModule" />
    • <remove name="FastCgiModule" />

  4. Save and close the file.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

Learn about the terminology that Microsoft uses to describe software updates.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
Özellikler

Makale No: 3164346 - Son İnceleme: 14 Şub 2017 - Düzeltme: 1

Exchange Server 2016 Enterprise Edition, Exchange Server 2016 Standard Edition

Geri bildirim