Şu anda çevrimdışısınız; İnternet'in yeniden bağlanması bekleniyor

.NET Framework 2.0 SP2 ve .NET Framework 3.0 SP2 güncelleştirmeleri zincirleme olarak başka güncelleştirmeleri yükleyebilir

Windows XP desteği sona erdi

Microsoft, Windows XP desteğini 8 Nisan 2014'te sona erdirdi. Bu değişiklik yazılım güncelleştirmelerinizi ve güvenlik seçeneklerinizi etkiledi. Bunun sizin için ne anlama geldiğini ve korunmaya nasıl devam edebileceğinizi öğrenin.

Windows Server 2003 desteği 14 Temmuz 2015'te sona erdi

Microsoft, Windows Server 2003 desteğini 14 Temmuz 2015'te sona erdirdi. Bu değişiklik yazılım güncelleştirmelerinizi ve güvenlik seçeneklerinizi etkiledi. Bunun sizin için ne anlama geldiğini ve korunmaya nasıl devam edebileceğinizi öğrenin.

Belirtiler
Microsoft .NET Framework 2.0 Service Pack 2 (SP2) veya Microsoft .NET Framework 3.0 SP2 için bazı güncelleştirmeleri yüklediğinizde, bunlar zincirleme olarak ek güncelleştirmeler yükler. Bazı .NET Framework bileşenlerindeki yeni bağımlılıkları karşılamak için bu ek güncelleştirmelerin yüklenmesi gerekir. 
Daha fazla bilgi
.NET Framework 2.0 SP2 veya .NET Framework 3.0 SP2 için bazı güncelleştirmeleri yüklediğinizde, bunlar zincirleme olarak ek güncelleştirmelerin yüklenmesine neden olur. Bunun nedeni, Genişletilmiş Koruma Güvenlik Danışma Belgesi'nin, yeni sağlanan "türlerde" yeni bağımlılıklar içeren yeni genişletilmiş koruma özelliğini kullanıma sunmuş olmasıdır. Bu yeni özellik, .NET Framework 2.0 SP2 ve .NET Framework 3.0 SP2 özellik katmanlarındaki yeni işlevsellikten oluşur. .NET Framework 3.0 SP2 özellik katmanındaki yeni Windows Communication Foundation (WCF) özelliğinin, .NET Framework 2.0 SP2 özellik katmanında buna karşılık gelen yeni özelliğe ve yeni "türe" bir bağımlılığı vardır. .NET Framework 2.0 SP2 özellik katmanındaki yeni ASP.NET özelliğinin de, System.Net'teki (ağ yığını) yeni özelliğe yeni bir bağımlılığı vardır.

.NET Framework bileşenlerinin güncelleştirmeleri toplu olarak yapılır. Bu nedenle, Genişletilmiş Koruma Güvenlik Danışma Belgesi'nden sonra yayımlanmış olan bir ASP.NET bileşeni güncelleştirmesi her zaman genişletilmiş koruma için yeni ASP.NET özelliğini içerecektir. Bu yeni özellik, önceden belirtilmiş olan özellik bağımlılığının (yeni "türde) karşılanmasını gerektirir. WCF ve ASP.NET bileşenlerinin güncelleştirmeleri, bu bağımlılığı karşılamak için gereken şekilde ek güncelleştirmeleri zincirleme olarak yükler. Bu bağımlılık karşılanmazsa, Microsoft Bilgi Bankası'nın aşağıdaki makalesinde açıklanan sorunla karşılaşabilirsiniz:
2262911 982167 güncelleştirmesini veya 982168 güncelleştirmesini yükledikten sonra alınan "'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy' türü yüklenemedi" özel durum hatası
  • Windows XP'de ve Windows Server 2003'te, .NET Framework 2.0 SP2'deki ASP.NET bileşenin güncelleştirmeleri aşağıdaki güncelleştirmeyi de yükleyecektir:
    980773 Windows XP ve Windows Server 2003 üzerinde .NET Framework 3.5 Service Pack 1 ve .NET Framework 2.0 Service Pack 2 için NCL güncelleştirmesi: 8 Haziran 2010'un açıklaması
  • Windows Vista SP1 ve Windows Server 2008'de, .NET Framework 2.0 SP2'deki ASP.NET bileşeninin güncelleştirmeleri aşağıdaki güncelleştirmeyi de yükleyecektir:
    980843 Windows Vista Service Pack 1 ve Windows Server 2008 Service Pack 1 üzerinde .NET Framework 3.5 Service Pack 1 için NCL güncelleştirmesinin açıklaması: 8 Haziran 2010'un açıklaması
  • Windows Vista SP2 ve Windows Server 2008'de, .NET Framework 2.0 SP2'deki ASP.NET bileşeninin güncelleştirmeleri aşağıdaki güncelleştirmeyi de yükleyecektir:
    980842 Windows Vista Service Pack 2 ve Windows Server 2008 Service Pack 2 üzerinde .NET Framework 3.5 Service Pack 1 için NCL güncelleştirmesinin açıklaması: 8 Haziran 2010'un açıklaması
  • Windows XP ve Windows Server 2003'te, .NET Framework 3.0 SP2'deki WCF bileşeninin güncelleştirmeleri aşağıdaki güncelleştirmeleri de yükleyecektir:  
    980773 Windows XP ve Windows Server 2003 üzerinde .NET Framework 3.5 Service Pack 1 ve .NET Framework 2.0 Service Pack 2 için NCL güncelleştirmesi: 08.06.10'un açıklaması
    976765 Windows XP ve Windows Server 2003 üzerinde .NET Framework 3.5 Service Pack 1 ve .NET Framework 2.0 Service Pack 2 için ASP.NET güncelleştirmesi: 8 Haziran 2010'un açıklaması
  • Windows Vista SP1 ve Windows Server 2008'de, .NET Framework 3.0 SP2'deki WCF bileşeninin güncelleştirmeleri aşağıdaki güncelleştirmeleri de yükleyecektir:
    980843 Windows Vista Service Pack 1 ve Windows Server 2008 Service Pack 1 üzerinde .NET Framework 3.5 Service Pack 1 için NCL güncelleştirmesinin açıklaması: 08.06.10'un açıklaması
    976767 Windows Vista Service Pack 1 ve Windows Server 2008 Service Pack 1 üzerinde .NET Framework 3.5 Service Pack 1 için ASP.NET güncelleştirmesinin açıklaması: 8 Haziran 2010'un açıklaması
  • Windows Vista SP2 ve Windows Server 2008'de, .NET Framework 3.0 SP2'deki WCF bileşeninin güncelleştirmeleri aşağıdaki güncelleştirmeleri de yükleyecektir:
    980842 Windows Vista Service Pack 2 ve Windows Server 2008 Service Pack 2 üzerinde .NET Framework 3.5 Service Pack 1 için NCL güncelleştirmesinin açıklaması: 08.06.10'un açıklaması
    976768 Windows Vista Service Pack 2 ve Windows Server 2008 Service Pack 2 üzerinde .NET Framework 3.5 Service Pack 1 için ASP.NET güncelleştirmesinin açıklaması: 8 Haziran 2010'un açıklaması
Özellikler

Makale No: 2436257 - Son İnceleme: 10/26/2010 10:25:00 - Düzeltme: 4.0

Microsoft .NET Framework 3.0 Service Pack 2, Microsoft .NET Framework 2.0 Service Pack 2, Windows 7 Enterprise, Windows 7 Home Basic, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Ultimate, Windows Server 2008 R2 Standard, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Datacenter, Windows Server 2008 Service Pack 2, Windows Server 2008 for Itanium-Based Systems, Windows Server 2008 Datacenter, Windows Server 2008 Enterprise, Windows Server 2008 Standard, Windows Web Server 2008, Windows Vista Service Pack 2, Windows Vista Service Pack 1, Microsoft Windows Server 2003 Service Pack 2, Microsoft Windows XP Service Pack 3

  • kbbug kbexpertiseinter kbsecbulletin kbsecurity kbsecvulnerability KB2436257
Geri bildirim